Cannot increase max_post_size or upload limits through WordPress

3clouds

Member
May 28, 2019
13
2
3
India
cPanel Access Level
Root Administrator
Hi,

I need to upload a backup file through a WordPress plugin which requires 500 MB upload limits or max_post_size. I tried everything from my knowledge but nothing changed!

My cPanel file upload limit is set to 1.5G but the WordPress shows 128M.

1. I tried max_post_size from cPanel > Select PHP Version > Switch to PHP Options. But the max_post_size set to 128M. Cannot increase more than the default.
2. Tried with .htaccess and php.ini file but nothing happens.
3. Tried from WHM > MultiPHP Ini Editor > Post Max Size set to 1024M but not reflecting on the WordPress upload limits.

Please help me. How to increase the max_post_size and file upload limits of PHP settings?

Thanks
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,749
2,205
363
cPanel Access Level
DataCenter Provider
Twitter
Hello @3clouds,

Can you browse to WHM >> MultiPHP Manager and confirm if PHP-FPM is enabled for the affected domain name? If so, the PHP errors are stored in the following location:

/home/username/logs/domain_com.php.error.log

You can also check the global PHP-FPM error log for the specific PHP version associated with the affected domain at:

/opt/cpanel/ea-phpXX/root/usr/var/log/php-fpm/error.log

If PHP-FPM is not enabled, do you notice any specific output to the error_log file in the document root of the WordPress installation, or in /usr/local/apache/logs/error_log when the upload attempt fails?

Thank you.