The Community Forums

Interact with an entire community of cPanel & WHM users.
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot install cPanel on Microsoft Azure Linux

Discussion in 'General Discussion' started by heogia, Dec 26, 2012.

Thread Status:
Not open for further replies.
  1. heogia

    heogia Registered

    Joined:
    Dec 26, 2012
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Hi everybody.

    Recent days, I've got these errors when i install cPanel

    "http://olcentgbl.trafficmanager.net/centos/6/updates/x86_64/Packages/kernel-headers-2.6.32-279.19.1.el6.x86_64.rpm:"

    I checked this package on above address, but i can found it. :confused:

    Does Anybody help me?
     
  2. cPanelJared

    cPanelJared Technical Analyst
    Staff Member

    Joined:
    Feb 25, 2010
    Messages:
    1,842
    Likes Received:
    18
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    What you posted is only a URL, not an error message, so it is difficult to say what is happening. Can you please paste the actual error message from the installer output?

    Note that Microsoft Azure is not on our list of supported virtualization systems:

    http://cpanel.net/cpanel-whm/system-requirements/

    We have not tested cPanel on Microsoft Azure, so we will not be able to support any problems that may arise that are particular to that virtualization system.
     
  3. heogia

    heogia Registered

    Joined:
    Dec 26, 2012
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Thanks for your respone.

    Operating System is: OpenLogic CentOS 6.3

    This is error message:

    2012-12-27 02:05:02 258 (DEBUG): Install 1 Package(s)
    2012-12-27 02:05:02 258 (DEBUG):
    2012-12-27 02:05:02 258 (DEBUG): Total download size: 1.9 M
    2012-12-27 02:05:02 258 (DEBUG): Installed size: 2.4 M
    2012-12-27 02:05:02 258 (DEBUG): Downloading Packages:
    2012-12-27 02:05:02 258 (DEBUG): /http://olcentgbl.trafficmanager.net/centos]Index of /centos /6/updates/x86_64/Packages/kernel-headers-2.6.32-279.19.1.el6.x86_64.rpm: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404"
    2012-12-27 02:05:02 258 (DEBUG): Trying other mirror.
    2012-12-27 02:05:02 258 (DEBUG):
    2012-12-27 02:05:02 258 (DEBUG):
    2012-12-27 02:05:02 258 (DEBUG): Error Downloading Packages:
    2012-12-27 02:05:02 258 (DEBUG): kernel-headers-2.6.32-279.19.1.el6.x86_6 4: failure: Packages/kernel-headers-2.6.32-279.19.1.el6.x86_64.rpm from updates: [Errno 256] No more mirrors to try.
    2012-12-27 02:05:02 258 (DEBUG):
    2012-12-27 02:05:02 258 (ERROR): - ssystem [EXIT_CODE] '/usr/bin/yum' exited with 1 (ignored)
    2012-12-27 02:05:02 258 (DEBUG): - ssystem [END]
    2012-12-27 02:05:02 262 (FATAL): yum failed 6 times. Cannot continue!
    Removing /root/installer.lock


    Thanks
     
  4. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,577
    Likes Received:
    40
    Trophy Points:
    48
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    looks like you may not have any working resolvers
     
  5. heogia

    heogia Registered

    Joined:
    Dec 26, 2012
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    I changed our NameServer into

    nameserver 4.2.2.1
    nameserver 4.2.2.2

    It's still same problems
     
  6. beno9487

    beno9487 Registered

    Joined:
    Mar 12, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Did you have any luck? I got this going a few months ago, but now with centos 6, can get it past

    2013-03-12 07:33:49 295 (DEBUG): - ssystem [BEGIN]: /usr/bin/yum -y install kernel-headers
    2013-03-12 07:33:49 295 (DEBUG): Loaded plugins: security
    2013-03-12 07:33:49 295 (DEBUG): Setting up Install Process
    2013-03-12 07:33:49 295 (DEBUG): No package kernel-headers available.
    2013-03-12 07:33:49 295 (DEBUG): Error: Nothing to do
    2013-03-12 07:33:49 295 (ERROR): - ssystem [EXIT_CODE] '/usr/bin/yum' exited with 1 (ignored)
    2013-03-12 07:33:49 295 (DEBUG): - ssystem [END]
    2013-03-12 07:33:49 299 (FATAL): yum failed 6 times. Cannot continue!
     
  7. toloka

    toloka Registered

    Joined:
    Mar 12, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I also got error, please help


    Code:
    [root@LinuxVM home]# sh latest
    Verifying archive integrity... All good.
    Uncompressing Cpanel & WHM Installer..............
            ____                  _
        ___|  _ \ __ _ _ __   ___| |
       / __| |_) / _` | '_ \ / _ \ |
      | (__|  __/ (_| | | | |  __/ |
       \___|_|   \__,_|_| |_|\___|_|
    
      Installer Version v00028 r67293165e2f92b29b5ddfc2fb3a5907c816107aa
    
    Beginning main installation.
    2013-03-13 00:09:24  557 ( INFO): cPanel install started at: Wed Mar 13 00:09:24 2013!
    2013-03-13 00:09:24  558 ( INFO): This install will take 20-50 minutes depending on your hardware.
    2013-03-13 00:09:24  559 ( INFO): Now is the time to go get another cup of coffee/jolt.
    2013-03-13 00:09:24  560 ( INFO): The install will log to /var/log/cpanel-install.log.
    2013-03-13 00:09:24  561 ( INFO):
    2013-03-13 00:09:24  562 ( INFO): Beginning Installation v3
    2013-03-13 00:09:24  462 ( INFO): centos 6 (Linux) detected!
    2013-03-13 00:09:24  490 ( INFO): Validating that 'LinuxVM.95cdc2827f294948adae7b7b6cc3a2b1.gwagroup-linuxvm.2013924997.asiasoutheast.internal.cloudapp.net' is a FQDN
    2013-03-13 00:09:24 1966 (DEBUG):   - ssystem [BEGIN]: /usr/bin/rdate -s rdate.cpanel.net
    2013-03-13 00:09:30 1966 (DEBUG):   - ssystem [END]
    2013-03-13 00:09:30 1968 ( INFO): Clock set to: Wed Mar 13 00:09:30 2013
    2013-03-13 00:09:30 1978 ( INFO): Clock changed by 6 seconds
    2013-03-13 00:09:30 1503 ( INFO): Setting up needed empty cpanel directories.
    2013-03-13 00:09:30 1522 ( INFO): Setting up update flag files
    2013-03-13 00:09:30 1532 ( INFO): Making sure GPG is setup before importing keys
    2013-03-13 00:09:30 1535 ( INFO): Importing gpg keys for yum
    2013-03-13 00:09:30 1364 (DEBUG):   Retrieving [url]http://httpupdate.cpanel.net/cpanelsync/TIERS[/url] to TIERS
    2013-03-13 00:09:30   92 (DEBUG):   Parsing command line arguments
    2013-03-13 00:09:30  422 ( INFO): Install type: standard
    2013-03-13 00:09:30   97 ( INFO): Running health checks prior to start
    2013-03-13 00:09:30 1119 ( INFO): Validating that we can lookup domains
    2013-03-13 00:09:30 1131 (DEBUG):   Testing cpanel.net
    2013-03-13 00:09:34 1131 (DEBUG):   Testing [url=http://www.cpanel.net]cPanel Inc | Point.Click.Host.[/url]
    2013-03-13 00:09:34 1131 (DEBUG):   Testing updates.cpanel.net
    2013-03-13 00:09:38 1131 (DEBUG):   Testing httpupdate.cpanel.net
    2013-03-13 00:09:38 1131 (DEBUG):   Testing layer2.cpanel.net
    2013-03-13 00:09:39 1131 (DEBUG):   Testing layer1.cpanel.net
    2013-03-13 00:09:40 1131 (DEBUG):   Testing [url=http://www.google.com]Google[/url]
    2013-03-13 00:09:41 1310 ( INFO): we can connect to httpupdate.cpanel.net
    2013-03-13 00:09:41  509 ( INFO): cPanel Layer 1 Installer Starting.....
    2013-03-13 00:09:41  510 ( INFO): Warning !!! Warning !!! WARNING !!! Warning !!! Warning
    2013-03-13 00:09:41  511 ( INFO): -------------------------------------------------------
    2013-03-13 00:09:41  512 ( INFO): cPanel requires a fresh/clean server!
    2013-03-13 00:09:41  513 ( INFO): If you are serving websites off this server (and are
    2013-03-13 00:09:41  514 ( INFO): not already running cPanel) this installer will
    2013-03-13 00:09:41  515 ( INFO): overwrite all of your config files.  You should hit
    2013-03-13 00:09:41  516 ( INFO): Ctrl+C NOW!!!
    2013-03-13 00:09:41  517 ( INFO): If this is a new server please ignore this messages
    2013-03-13 00:09:41  518 ( INFO): -------------------------------------------------------
    2013-03-13 00:09:41  519 ( INFO): Warning !!! Warning !!! WARNING !!! Warning !!! Warning
    2013-03-13 00:09:41  520 ( INFO): Waiting 5 seconds.....
    2013-03-13 00:09:41  521 ( INFO):
    2013-03-13 00:09:41  522 ( INFO):
    2013-03-13 00:09:46  526 ( INFO): Checking for another control panel...
    2013-03-13 00:09:46  120 (DEBUG):   - ssystem [BEGIN]: /usr/sbin/setenforce 0
    2013-03-13 00:09:46  120 (DEBUG):   - ssystem [END]
    2013-03-13 00:09:46 1966 (DEBUG):   - ssystem [BEGIN]: /usr/bin/rdate -s rdate.cpanel.net
    2013-03-13 00:09:47 1966 (DEBUG):   - ssystem [END]
    2013-03-13 00:09:47 1968 ( INFO): Clock set to: Wed Mar 13 00:09:47 2013
    2013-03-13 00:09:47 1978 ( INFO): Clock changed by 1 seconds
    2013-03-13 00:09:47 1359 ( WARN): Warning: Overwriting TIERS
    2013-03-13 00:09:47 1364 (DEBUG):   Retrieving [url]http://httpupdate.cpanel.net/cpanelsync/TIERS[/url] to TIERS
    2013-03-13 00:09:47  129 ( INFO): Installing LTS version 11.36
    2013-03-13 00:09:52  594 ( INFO): No proxy found, installing fastest mirror plugin.
    2013-03-13 00:09:52  595 (DEBUG):   - ssystem [BEGIN]: yum clean all
    2013-03-13 00:09:52  595 (DEBUG):     Loaded plugins: security
    2013-03-13 00:09:53  595 (DEBUG):     Cleaning repos: base extras openlogic updates
    2013-03-13 00:09:53  595 (DEBUG):     Cleaning up Everything
    2013-03-13 00:09:53  595 (DEBUG):   - ssystem [END]
    2013-03-13 00:09:53  596 (DEBUG):   - ssystem [BEGIN]: yum -y install yum-fastestmirror
    2013-03-13 00:09:53  596 (DEBUG):     Loaded plugins: security
    2013-03-13 00:10:19  596 (DEBUG):     Setting up Install Process
    2013-03-13 00:10:20  596 (DEBUG):     Package yum-plugin-fastestmirror-1.1.30-14.el6.noarch already installed and latest version
    2013-03-13 00:10:20  596 (DEBUG):     Nothing to do
    2013-03-13 00:10:20  596 (DEBUG):   - ssystem [END]
    2013-03-13 00:10:20  597 (DEBUG):   - ssystem [BEGIN]: yum clean all
    2013-03-13 00:10:20  597 (DEBUG):     Loaded plugins: security
    2013-03-13 00:10:20  597 (DEBUG):     Cleaning repos: base extras openlogic updates
    2013-03-13 00:10:20  597 (DEBUG):     Cleaning up Everything
    2013-03-13 00:10:20  597 (DEBUG):   - ssystem [END]
    2013-03-13 00:10:20  639 ( INFO): Installing perl development packages so that system perl can install from CPAN
    2013-03-13 00:10:20  295 (DEBUG):   - ssystem [BEGIN]: /usr/bin/yum -y install perl-devel perl-CPAN perl-Module-Build perl-core perl-libwww-perl crontabs sysstat
    2013-03-13 00:10:20  295 (DEBUG):     Loaded plugins: security
    2013-03-13 00:10:38  295 (DEBUG):     Setting up Install Process
    2013-03-13 00:10:38  295 (DEBUG):     Package 4:perl-devel-5.10.1-127.el6.x86_64 already installed and latest version
    2013-03-13 00:10:38  295 (DEBUG):     Package perl-CPAN-1.9402-127.el6.x86_64 already installed and latest version
    2013-03-13 00:10:38  295 (DEBUG):     Package 1:perl-Module-Build-0.3500-127.el6.x86_64 already installed and latest version
    2013-03-13 00:10:38  295 (DEBUG):     Package perl-core-5.10.1-127.el6.x86_64 already installed and latest version
    2013-03-13 00:10:38  295 (DEBUG):     Package perl-libwww-perl-5.833-2.el6.noarch already installed and latest version
    2013-03-13 00:10:39  295 (DEBUG):     Package crontabs-1.10-33.el6.noarch already installed and latest version
    2013-03-13 00:10:39  295 (DEBUG):     Package sysstat-9.0.4-20.el6.x86_64 already installed and latest version
    2013-03-13 00:10:39  295 (DEBUG):     Nothing to do
    2013-03-13 00:10:39  295 (DEBUG):   - ssystem [END]
    2013-03-13 00:10:39  645 (DEBUG):   - ssystem [BEGIN]: touch /etc/checkyumdisable
    2013-03-13 00:10:39  645 (DEBUG):   - ssystem [END]
    2013-03-13 00:10:39  295 (DEBUG):   - ssystem [BEGIN]: /usr/bin/yum -y install kernel-headers
    2013-03-13 00:10:39  295 (DEBUG):     Loaded plugins: security
    2013-03-13 00:10:39  295 (DEBUG):     Setting up Install Process
    2013-03-13 00:10:39  295 (DEBUG):     No package kernel-headers available.
    2013-03-13 00:10:39  295 (DEBUG):     Error: Nothing to do
    2013-03-13 00:10:39  295 (ERROR):   - ssystem [EXIT_CODE] '/usr/bin/yum' exited with 1 (ignored)
    2013-03-13 00:10:39  295 (DEBUG):   - ssystem [END]
    2013-03-13 00:10:39  295 (DEBUG):   - ssystem [BEGIN]: /usr/bin/yum -y install kernel-headers
    2013-03-13 00:10:39  295 (DEBUG):     Loaded plugins: security
    2013-03-13 00:10:39  295 (DEBUG):     Setting up Install Process
    2013-03-13 00:10:40  295 (DEBUG):     No package kernel-headers available.
    2013-03-13 00:10:40  295 (DEBUG):     Error: Nothing to do
    2013-03-13 00:10:40  295 (ERROR):   - ssystem [EXIT_CODE] '/usr/bin/yum' exited with 1 (ignored)
    2013-03-13 00:10:40  295 (DEBUG):   - ssystem [END]
    2013-03-13 00:10:40  295 (DEBUG):   - ssystem [BEGIN]: /usr/bin/yum -y install kernel-headers
    2013-03-13 00:10:40  295 (DEBUG):     Loaded plugins: security
    2013-03-13 00:10:40  295 (DEBUG):     Setting up Install Process
    2013-03-13 00:10:40  295 (DEBUG):     No package kernel-headers available.
    2013-03-13 00:10:40  295 (DEBUG):     Error: Nothing to do
    2013-03-13 00:10:40  295 (ERROR):   - ssystem [EXIT_CODE] '/usr/bin/yum' exited with 1 (ignored)
    2013-03-13 00:10:40  295 (DEBUG):   - ssystem [END]
    2013-03-13 00:10:40  295 (DEBUG):   - ssystem [BEGIN]: /usr/bin/yum -y install kernel-headers
    2013-03-13 00:10:41  295 (DEBUG):     Loaded plugins: security
    2013-03-13 00:10:41  295 (DEBUG):     Setting up Install Process
    2013-03-13 00:10:41  295 (DEBUG):     No package kernel-headers available.
    2013-03-13 00:10:41  295 (DEBUG):     Error: Nothing to do
    2013-03-13 00:10:41  295 (ERROR):   - ssystem [EXIT_CODE] '/usr/bin/yum' exited with 1 (ignored)
    2013-03-13 00:10:41  295 (DEBUG):   - ssystem [END]
    2013-03-13 00:10:41  295 (DEBUG):   - ssystem [BEGIN]: /usr/bin/yum -y install kernel-headers
    2013-03-13 00:10:41  295 (DEBUG):     Loaded plugins: security
    2013-03-13 00:10:41  295 (DEBUG):     Setting up Install Process
    2013-03-13 00:10:41  295 (DEBUG):     No package kernel-headers available.
    2013-03-13 00:10:42  295 (DEBUG):     Error: Nothing to do
    2013-03-13 00:10:42  295 (ERROR):   - ssystem [EXIT_CODE] '/usr/bin/yum' exited with 1 (ignored)
    2013-03-13 00:10:42  295 (DEBUG):   - ssystem [END]
    2013-03-13 00:10:42  295 (DEBUG):   - ssystem [BEGIN]: /usr/bin/yum -y install kernel-headers
    2013-03-13 00:10:42  295 (DEBUG):     Loaded plugins: security
    2013-03-13 00:10:42  295 (DEBUG):     Setting up Install Process
    2013-03-13 00:10:42  295 (DEBUG):     No package kernel-headers available.
    2013-03-13 00:10:42  295 (DEBUG):     Error: Nothing to do
    2013-03-13 00:10:42  295 (ERROR):   - ssystem [EXIT_CODE] '/usr/bin/yum' exited with 1 (ignored)
    2013-03-13 00:10:42  295 (DEBUG):   - ssystem [END]
    2013-03-13 00:10:42  299 (FATAL): yum failed 6 times.  Cannot continue!
    Removing /root/installer.lock
    [root@LinuxVM home]#
     
  8. toloka

    toloka Registered

    Joined:
    Mar 12, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    TRY THIS!!!

    You can install the kernel-headers by issuing the following:

    sudo yum --disableexcludes=main install kernel-headers-2.6.32-279.14.1.el6.openlogic.x86_64


    and try to install cpanel again,

    REF:Openlogic Centos 6.3 image: no kernel-headers
     
  9. beno9487

    beno9487 Registered

    Joined:
    Mar 12, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    THANKS Toloka

    Brilliant. Spent ages trying to fins this out. Works perfectly. installed with NO dramas.

    Really appreciated.

    Now, silly question. How do I log in? I don't have a root login, but another username with root access (did the install with sudo -s). This does not work on the port 2087 whm login screen.

    Any ideas?
     
Loading...
Thread Status:
Not open for further replies.

Share This Page