tomdchi

Well-Known Member
Feb 24, 2008
135
2
68
Atlanta, GA
cPanel Access Level
DataCenter Provider
I am trying to install the cassandra php extension but I get this error:

Code:
pecl/cassandra requires PHP (version >= 5.6.0, version <= 7.1.99), installed version is 7.2.9
No valid packages found
install failed
I found an updated extension here php72-php-pecl-cassandra-1.3.2-1.el7.remi.x86_64 RPM but I am unsure of the right way to install it on WHM. Can someone give me some help here?
 

cPanelLauren

Forums Analyst II
Staff member
Nov 14, 2017
8,080
657
263
Houston
cPanel Access Level
DataCenter Provider
I am trying to install the cassandra php extension but I get this error:

Code:
pecl/cassandra requires PHP (version >= 5.6.0, version <= 7.1.99), installed version is 7.2.9
No valid packages found
install failed
I found an updated extension here php72-php-pecl-cassandra-1.3.2-1.el7.remi.x86_64 RPM but I am unsure of the right way to install it on WHM. Can someone give me some help here?

We only offer stable versions of the extension. You can see on their site here PECL :: Package :: cassandra :: docs that 1.3.2 the most recent stable version supports:

Code:
    PHP Version: PHP version 7.1.99 or older
PHP Version: PHP 5.6.0 or newer
PEAR Package: PEAR 1.4.8 or newer