Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Cannot install Fileinfo in Easyapache 4

Discussion in 'EasyApache' started by Erik1, Nov 5, 2017.

  1. Erik1

    Erik1 Member

    Joined:
    Dec 13, 2014
    Messages:
    24
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    I try to install Fileinfo in Easyapache 4. I select php56-php-fileinfo and press Review.
    But Fileinfo is not listed in the packages to be installed. Even if I rebuild, fileinfo is not installed.
    What am I doing wrong?
     
  2. Erik1

    Erik1 Member

    Joined:
    Dec 13, 2014
    Messages:
    24
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    The problem is not limited to Fileinfo. If I try to install other extension they do not show up in the Review:

    Please review the following list of packages you are about to install by provisioning this profile: There are no packages to be installed.
     
  3. Erik1

    Erik1 Member

    Joined:
    Dec 13, 2014
    Messages:
    24
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    When I provision in EasyApache 4 I get this message: The provision process exited with errors.
    The log show 47 errors. I copied 3 such errors below. Are they important?


    [2017-11-06 18:56:31 +0100] info [xml-api] Not found
    [2017-11-06 18:56:31 +0100] info [xml-api] Error: Package: ea-php56-php-litespeed-5.6.31-5.5.1.cpanel.x86_64 (installed)
    [2017-11-06 18:56:31 +0100] info [xml-api] Requires: ea-php56-php-common(x86-64) = 5.6.31-5.5.1.cpanel
    [2017-11-06 18:56:31 +0100] info [xml-api] Removing: ea-php56-php-common-5.6.31-4.4.1.cpanel.x86_64 (@EA4)
    [2017-11-06 18:56:31 +0100] info [xml-api] ea-php56-php-common(x86-64) = 5.6.31-4.4.1.cpanel
    [2017-11-06 18:56:31 +0100] info [xml-api] Updated By: ea-php56-php-common-5.6.32-1.1.2.cpanel.x86_64 (EA4)
    [2017-11-06 18:56:31 +0100] info [xml-api] ea-php56-php-common(x86-64) = 5.6.32-1.1.2.cpanel
    [2017-11-06 18:56:31 +0100] info [xml-api] Removing: ea-php56-php-common-5.6.31-5.5.1.cpanel.x86_64 (installed)
    [2017-11-06 18:56:31 +0100] info [xml-api] ea-php56-php-common(x86-64) = 5.6.31-5.5.1.cpanel
    [2017-11-06 18:56:31 +0100] info [xml-api] Updated By: ea-php56-php-common-5.6.32-1.1.2.cpanel.x86_64 (EA4)
    [2017-11-06 18:56:31 +0100] info [xml-api] ea-php56-php-common(x86-64) = 5.6.32-1.1.2.cpanel


    [2017-11-06 18:56:31 +0100] info [xml-api] Not found
    [2017-11-06 18:56:31 +0100] info [xml-api] Error: Package: ea-php56-php-litespeed-5.6.31-5.5.1.cpanel.x86_64 (installed)
    [2017-11-06 18:56:31 +0100] info [xml-api] Requires: ea-php56-php-common(x86-64) = 5.6.31-5.5.1.cpanel
    [2017-11-06 18:56:31 +0100] info [xml-api] Removing: ea-php56-php-common-5.6.31-4.4.1.cpanel.x86_64 (@EA4)
    [2017-11-06 18:56:31 +0100] info [xml-api] ea-php56-php-common(x86-64) = 5.6.31-4.4.1.cpanel
    [2017-11-06 18:56:31 +0100] info [xml-api] Updated By: ea-php56-php-common-5.6.32-1.1.2.cpanel.x86_64 (EA4)
    [2017-11-06 18:56:31 +0100] info [xml-api] ea-php56-php-common(x86-64) = 5.6.32-1.1.2.cpanel
    [2017-11-06 18:56:31 +0100] info [xml-api] Removing: ea-php56-php-common-5.6.31-5.5.1.cpanel.x86_64 (installed)
    [2017-11-06 18:56:31 +0100] info [xml-api] ea-php56-php-common(x86-64) = 5.6.31-5.5.1.cpanel
    [2017-11-06 18:56:31 +0100] info [xml-api] Updated By: ea-php56-php-common-5.6.32-1.1.2.cpanel.x86_64 (EA4)
    [2017-11-06 18:56:31 +0100] info [xml-api] ea-php56-php-common(x86-64) = 5.6.32-1.1.2.cpanel

    -- Error(13465) --
    Error: Package: ea-php70-php-cli-7.0.24-3.3.1.cpanel.x86_64 (installed)
    Requires: ea-php70-php-common(x86-64) = 7.0.24-3.3.1.cpanel
    Removing: ea-php70-php-common-7.0.24-2.2.1.cpanel.x86_64 (@EA4)
    ea-php70-php-common(x86-64) = 7.0.24-2.2.1.cpanel
    Updated By: ea-php70-php-common-7.0.25-1.1.2.cpanel.x86_64 (EA4)
    ea-php70-php-common(x86-64) = 7.0.25-1.1.2.cpanel
    Removing: ea-php70-php-common-7.0.24-3.3.1.cpanel.x86_64 (installed)
    ea-php70-php-common(x86-64) = 7.0.24-3.3.1.cpanel
    Updated By: ea-php70-php-common-7.0.25-1.1.2.cpanel.x86_64 (EA4)
    ea-php70-php-common(x86-64) = 7.0.25-1.1.2.cpanel
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    42,693
    Likes Received:
    1,703
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you try running the following commands and let us know if they successfully complete?

    Code:
    yum clean all
    yum update
    Thank you.
     
  5. Erik1

    Erik1 Member

    Joined:
    Dec 13, 2014
    Messages:
    24
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    yum clean all
    Loaded plugins: fastestmirror, universal-hooks
    Cleaning repos: EA4 cpanel-addons-production-feed base extras updates
    Cleaning up Everything
    Cleaning up list of fastest mirrors

    yum update
    Loaded plugins: fastestmirror, universal-hooks
    Setting up Update Process
    Determining fastest mirrors
    * EA4: 216.97.225.163
    * cpanel-addons-production-feed: 216.97.225.163
    * base: mirror.sfo12.us.leaseweb.net
    * extras: mirror.lax.hugeserver.com
    * updates: mirror.hmc.edu
    EA4 | 3.0 kB 00:00 ...
    EA4/primary_db | 33 MB 00:05
    cpanel-addons-production-feed | 2.9 kB 00:00 ...
    cpanel-addons-production-feed/primary_db | 10 kB 00:00
    base | 3.7 kB 00:00
    base/primary_db | 4.7 MB 00:00
    extras | 3.4 kB 00:00
    extras/primary_db | 29 kB 00:00
    updates | 3.4 kB 00:00
    updates/primary_db | 4.7 MB 00:00
    No Packages marked for Update
     
  6. Erik1

    Erik1 Member

    Joined:
    Dec 13, 2014
    Messages:
    24
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    EasyApache 4:
    - creates errors for all extension that are marked as updatable
    - does not install new extensions
     
  7. 24x7server

    24x7server Well-Known Member

    Joined:
    Apr 17, 2013
    Messages:
    1,722
    Likes Received:
    77
    Trophy Points:
    28
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hi,

    Most probably there appears to be some dependency problem with the packages that is causing this, so you have will have to review it first.. If you are not professional enough to sort this out, I will suggest you get a professional system administrator to do this for you or you can raise a ticket to the cPanel support directly..
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    42,693
    Likes Received:
    1,703
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you open a support ticket using the link in my signature so we can take a closer look?

    Thank you.
     
  9. Erik1

    Erik1 Member

    Joined:
    Dec 13, 2014
    Messages:
    24
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    I submitted a ticket and problem was solved very quickly. "The problem was your yum system had five outstanding transactions to run (most likely due to previous yum failures)." Thanks for the support!
     
    cPanelMichael likes this.
Loading...

Share This Page