ruber

Member
Jun 5, 2007
22
0
151
Hi all,

I'm trying to install cPanel on an Amazon EC2 server. The process is stuck for hours on the following lines.

Code:
[8184] Creating /usr/local/apache/conf/includes/post_virtualhost_2.conf
[8184] Could not determine apache version at /usr/local/cpanel/scripts/ensure_includes line 14.
[8184] Requesting script ... Done
[8184] Auto Repair is running......Auto Repair is done.
Requesting script ... Done
Auto Repair is running......Auto Repair is done.
I'm doing a clean install on a new server. I already used cPanel on a lot of dedicated servers and VPS and never had this kind of issue, but is the first time I'm using it on an EC2 server.

Does someone have any idea of what's happening?


Thanks,
R.
 

actiion

Registered
Nov 10, 2013
2
0
1
cPanel Access Level
Root Administrator
Hello,

Installing cpanel 11.40.0.19 on AWS fails at:

Code:
2013-11-10 19:12:43  150 (DEBUG):     [Starting apache]
2013-11-10 19:12:44  150 (DEBUG):     Enabled scgi-bin since suexec is not installed
2013-11-10 19:13:53  150 (DEBUG):     Apache restart failed. Unable to load pid from pid file and no httpd process found in process list.
2013-11-10 19:13:53  150 (DEBUG):     
2013-11-10 19:13:53  150 (DEBUG):     If apache restart reported success but it failed soon after, it may be caused by oddities with mod_ssl.
2013-11-10 19:13:53  150 (DEBUG):     
2013-11-10 19:13:53  150 (DEBUG):     You should run /usr/local/cpanel/scripts/ssl_crt_status as part of your troubleshooting process. Pass it --help for more details.
2013-11-10 19:13:53  150 (DEBUG):     
2013-11-10 19:13:53  150 (DEBUG):     Also be sure to examine apache's various log files.
2013-11-10 19:13:53  150 (DEBUG):     Apache Restart Output:
2013-11-10 19:13:53  150 (DEBUG):     
2013-11-10 19:13:53  150 (DEBUG):     Log:
2013-11-10 19:13:53  150 (DEBUG):     Creating /usr/local/apache/conf/includes/pre_main_global.conf
2013-11-10 19:13:53  150 (DEBUG):     Creating /usr/local/apache/conf/includes/pre_virtualhost_global.conf
2013-11-10 19:13:53  150 (DEBUG):     Creating /usr/local/apache/conf/includes/post_virtualhost_global.conf
2013-11-10 19:13:53  150 (DEBUG):     Creating /usr/local/apache/conf/includes/pre_main_1.conf
2013-11-10 19:13:53  150 (DEBUG):     Creating /usr/local/apache/conf/includes/pre_virtualhost_1.conf
2013-11-10 19:13:53  150 (DEBUG):     Creating /usr/local/apache/conf/includes/post_virtualhost_1.conf
2013-11-10 19:13:53  150 (DEBUG):     Creating /usr/local/apache/conf/includes/pre_main_2.conf
2013-11-10 19:13:53  150 (DEBUG):     Creating /usr/local/apache/conf/includes/pre_virtualhost_2.conf
2013-11-10 19:13:53  150 (DEBUG):     Creating /usr/local/apache/conf/includes/post_virtualhost_2.conf
2013-11-10 19:13:53  150 (DEBUG):     Could not determine apache version at /usr/local/cpanel/scripts/ensure_includes line 19.
2013-11-10 19:13:55  150 (DEBUG):     Requesting script ... Done
2013-11-10 19:13:55  150 (DEBUG):     Auto Repair is running......Auto Repair is done.
2013-11-10 19:13:55  150 (DEBUG):     Requesting script ... Done
2013-11-10 19:13:55  150 (DEBUG):     Auto Repair is running......Auto Repair is done.

Further, there is another trouble that occurs during the install:

Code:
2013-11-10 19:03:28  431 (DEBUG):     !! The server's system package manager, 'YUM', failed. !!
2013-11-10 19:03:28  431 (DEBUG):     !! 
2013-11-10 19:03:28  431 (DEBUG):     This is the command that failed:
2013-11-10 19:03:28  431 (DEBUG):     	yum -y install glibc zlib1-devel compat-expat1.i686 expat-devel gettext automake19 libstdc++.x86_64 libopenssl0-dev gcc-c++ expat openssl glibc-devel zlib-devel zlib bison compat-expat1 glibc-devel.i686 autoconf261 libidn-devel gmake libidn openssl-devel automake coreutils libtool-libltdl-devel libgcc libopenssl0 openssl-dev libtool patch libz-devel libgcc.i686 libltdl3-devel libltdl libopenssl0.9.7-static-devel pam-dev libtool-ltdl-devel libopenssl0.9.7-devel libltdl-devel fileutils e2fsprogs-devel sed lsof krb5-dev ca_root_nss flex glibc-dev expat-dev krb5-devel libstdc++-devel.x64_64 make libstdc++-dev.x86_64 glibc.i686 libtool-ltdl libssl-dev libstdc++-devel.x86_64 pam-devel cpp gcc libopenssl0-devel ssl-dev lex autoconf
2013-11-10 19:03:28  431 (DEBUG):     !!
2013-11-10 19:03:28  431 (DEBUG):     !! 
2013-11-10 19:03:28  431 (DEBUG):     Since EasyApache was unable to resolve it automatically you should:
2013-11-10 19:03:28  431 (DEBUG):     	1) Manually run the failed YUM command (shown above) via SSH
2013-11-10 19:03:28  431 (DEBUG):     	2) See if your particular error is addressed at http://go.cpanel.net/eaerror
2013-11-10 19:03:28  431 (DEBUG):     	3) Resolve the YUM problem manually
2013-11-10 19:03:28  431 (DEBUG):     	4) Re-run EasyApache
2013-11-10 19:03:28  431 (DEBUG):     !!
2013-11-10 19:03:28  431 (DEBUG):     !! Please visit http://go.cpanel.net/eaerror for help with this error. !!
2013-11-10 19:03:28  431 (DEBUG):     
2013-11-10 19:03:28  431 (DEBUG):     !! Restoring original working apache !!
2013-11-10 19:03:28  431 (DEBUG):     !! Executing '/scripts/initsslhttpd' !!
Thank You
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
Are you attempting to install cPanel version 11.40 with no prior modifications? Or, are you attempting to follow the blog post series at the URL referenced in my earlier post?

Thank you.
 

ruber

Member
Jun 5, 2007
22
0
151
Are you attempting to install cPanel version 11.40 with no prior modifications? Or, are you attempting to follow the blog post series at the URL referenced in my earlier post?

Thank you.
Hi, Michael,

I'm running the default cPanel install script. I read your blog posts and didn't find anything unusual to do that could be causing this freezing during install.

Your blog posts are saying about the network and NAT settings to do after cPanel install script is done. Our main issue is that the install is getting stuck on the same point, so we don't have a working WHM to work with.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
Please open a support ticket using the link in my signature so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome.

Thank you.
 

a.post

Member
Mar 23, 2005
20
1
153
The Netherlands
cPanel Access Level
Root Administrator
I have the same problem, if needed I can supply extra logfiles.

So far I've found that:
- DNS-only version installs without any problem
- during preparation checks I noticed the Amazon CentOS AMI has the yumgroup E-mailserver installed
- removing this package or keeping it before running install makes no difference
- whm runs partially (listener on 2086 runs but no reply from UI)
- reinstall after cleanup runs until finish
- whm then runs fully
- upcp however is then still running (hanging?)
- init scripts have not been installed

- I think the new cPanel install is not possible anymore in the t1.micro due to memory issues:

Next to the errors above I found this in the install log:

Code:
2013-11-19 13:57:11  431 (DEBUG):       Installing : libgcc-4.4.7-3.el6.i686                                      1/6 
2013-11-19 13:57:11  431 (DEBUG):       Installing : glibc-2.12-1.107.el6_4.5.i686                                2/6Error in POSTIN scriptlet in rpm package glibc-2.12-1.107.el6_4.5.
i686
2013-11-19 13:57:11  431 (DEBUG):      
2013-11-19 13:57:11  431 (DEBUG):     [B][U]error: Couldn't fork %post(glibc-2.12-1.107.el6_4.5.i686): Cannot allocate memory[/U][/B]
2013-11-19 13:57:11  431 (DEBUG):       Installing : nss-softokn-freebl-3.14.3-3.el6_4.i686                       3/6 
2013-11-19 13:57:11  431 (DEBUG):       Installing : compat-expat1-1.95.8-8.el6.x86_64                            4/6Error in POSTIN scriptlet in rpm package compat-expat1-1.95.8-8.el
6.x86_64
2013-11-19 13:57:11  431 (DEBUG):      
2013-11-19 13:57:11  431 (DEBUG):     error: Couldn't fork %post(compat-expat1-1.95.8-8.el6.x86_64): Cannot allocate memory
2013-11-19 13:57:11  431 (DEBUG):       Installing : glibc-devel-2.12-1.107.el6_4.5.i686                          5/6Error in POSTIN scriptlet in rpm package glibc-devel-2.12-1.107.el
6_4.5.i686
2013-11-19 13:57:11  431 (DEBUG):      
2013-11-19 13:57:11  431 (DEBUG):     error: Couldn't fork %post(glibc-devel-2.12-1.107.el6_4.5.i686): Cannot allocate memory
2013-11-19 13:57:11  431 (DEBUG):       Installing : compat-expat1-1.95.8-8.el6.i686                              6/6Error in POSTIN scriptlet in rpm package compat-expat1-1.95.8-8.el
6.i686
2013-11-19 13:57:11  431 (DEBUG):      
2013-11-19 13:57:11  431 (DEBUG):     error: Couldn't fork %post(compat-expat1-1.95.8-8.el6.i686): Cannot allocate memory
2013-11-19 13:57:11  431 (DEBUG):       Verifying  : nss-softokn-freebl-3.14.3-3.el6_4.i686                       1/6 
2013-11-19 13:57:11  431 (DEBUG):       Verifying  : libgcc-4.4.7-3.el6.i686                                      2/6 
2013-11-19 13:57:11  431 (DEBUG):       Verifying  : compat-expat1-1.95.8-8.el6.x86_64                            3/6 
2013-11-19 13:57:11  431 (DEBUG):       Verifying  : compat-expat1-1.95.8-8.el6.i686                              4/6 
2013-11-19 13:57:11  431 (DEBUG):       Verifying  : glibc-devel-2.12-1.107.el6_4.5.i686                          5/6 
2013-11-19 13:57:11  431 (DEBUG):       Verifying  : glibc-2.12-1.107.el6_4.5.i686                                6/6 
2013-11-19 13:57:11  431 (DEBUG):     Installed:
2013-11-19 13:57:11  431 (DEBUG):       libgcc.i686 0:4.4.7-3.el6                                                     
2013-11-19 13:57:11  431 (DEBUG):     Dependency Installed:
2013-11-19 13:57:11  431 (DEBUG):       nss-softokn-freebl.i686 0:3.14.3-3.el6_4                                      
2013-11-19 13:57:11  431 (DEBUG):     Failed:
2013-11-19 13:57:11  431 (DEBUG):       compat-expat1.i686 0:1.95.8-8.el6    compat-expat1.x86_64 0:1.95.8-8.el6     
2013-11-19 13:57:11  431 (DEBUG):       glibc.i686 0:2.12-1.107.el6_4.5      glibc-devel.i686 0:2.12-1.107.el6_4.5   
2013-11-19 13:57:11  431 (DEBUG):     Complete!
and

Code:
2013-11-19 13:57:12  431 (DEBUG):     Building global cache for cpanel...Done
2013-11-19 13:57:12  431 (DEBUG):     !! Executing '/scripts/initfpsuexec' !!
2013-11-19 13:57:12  431 (DEBUG):     !! Executing '/scripts/initsslhttpd' !!
2013-11-19 13:57:12  431 (DEBUG):     !! Executing '/scripts/update_apachectl' !!
2013-11-19 13:57:12  431 (DEBUG):     !! '/scripts/update_apachectl' failed with exit code '256' !!
2013-11-19 13:57:12  431 (DEBUG):     !! Executing 'rm -f /usr/sbin/httpd' !!
2013-11-19 13:57:12  431 (DEBUG):     !! Executing 'ln -s /usr/local/apache/bin/apachectl /usr/sbin/httpd' !!
2013-11-19 13:57:12  431 (DEBUG):     Compiling report...
2013-11-19 13:57:12  431 (DEBUG):     Sending report. As some of the attached files may be quite large, this could take a few minutes. Thanks for your patience.
2013-11-19 13:57:13  431 (DEBUG):     !! If you  want to create a support ticket with cPanel regarding this please reference 'BuildAP Report Id': '12309007' !!
2013-11-19 13:57:13  431 (DEBUG):     Report processed.
2013-11-19 13:57:13  431 (DEBUG):     !! Feel free to submit a support ticket at [url]https://tickets.cpanel.net/submit/index.cgi?reqtype=tickets[/url] !!
2013-11-19 13:57:13  431 (DEBUG):     !! Verbose logfile is at '/usr/local/cpanel/logs/easy/apache/build.1384869268' !!
2013-11-19 13:57:13  431 (DEBUG):   - ssystem [END]
 

ruber

Member
Jun 5, 2007
22
0
151
Please open a support ticket using the link in my signature so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome.

Thank you.
Hi, Michael,

I think something is wrong with cPanel support system.
This is what I receive when try to create a new account:

Code:
DBD::mysql::st execute failed: INSERT command denied to user 'support'@'208.74.121.20' for table 'groups' at /home/support/commonlib//Manage/Group.pm line 50.

For help, please send mail to the webmaster ([email protected]), giving this error message and the time and date of the error.
 
Last edited:

a.post

Member
Mar 23, 2005
20
1
153
The Netherlands
cPanel Access Level
Root Administrator
It seems to be a memory issue, using the m1.small instance type the install runs flawless.

I think the system requirements for 11.40 will have to be adjusted or commands will have to be split in order to spread memory use during installation.

I'll be trying to change my system to a t1.micro after installation to see if it runs ok during my testing phase.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
Hi, Michael,

I think something is wrong with cPanel support system.
This is what I receive when try to create a new account:

Code:
DBD::mysql::st execute failed: INSERT command denied to user 'support'@'208.74.121.20' for table 'groups' at /home/support/commonlib//Manage/Group.pm line 50.

For help, please send mail to the webmaster ([email protected]), giving this error message and the time and date of the error.
Please try opening a ticket now and let me know if it still fails.

Thank you.