Hiren Mehta

Registered
Oct 22, 2018
2
1
3
India
cPanel Access Level
Root Administrator
WHM is already installed on our server however when I try to access it via http://IP/whm or http://IP:2087 or https://IP/whm or https://IP:2087 it keeps on redirecting me to a domain which is an internal domain name and is not accessible from the internet, something like domainname.internal

I have 2 questions:

1) How do I stop this redirection from IP to this domain? I have already tried changing the following in /var/cpanel/cpanel.config and have restarted cPanel but it is still redirecting:

alwaysredirecttossl=0
cpredirectssl=SSL Certificate Name
requiressl=1

2) How can I change that domain from SSH? I have root access to the server.

Please help as I cannot access WHM due to this issue.

Thanks & Regards
 

24x7server

Well-Known Member
Apr 17, 2013
1,907
95
78
India
cPanel Access Level
Root Administrator
WHM is already installed on our server however when I try to access it via http://IP/whm or http://IP:2087 or https://IP/whm or https://IP:2087 it keeps on redirecting me to a domain which is an internal domain name and is not accessible from the internet, something like domainname.internal
When you use HTTP with proxy subdomains, then there is possbility that this will be redirected to the HTTPS and go to the hostname also, however, when you use HTTP with IP address on the WHM port, you should never be redirected. If it is redirecting, then you must be having a browse cache issue. Just to verify, please login to the https://IP:2087 on different browser.. if you still get the issue, kindly update to us here with a screenshot..
 

Hiren Mehta

Registered
Oct 22, 2018
2
1
3
India
cPanel Access Level
Root Administrator
When you use HTTP with proxy subdomains, then there is possbility that this will be redirected to the HTTPS and go to the hostname also, however, when you use HTTP with IP address on the WHM port, you should never be redirected. If it is redirecting, then you must be having a browse cache issue. Just to verify, please login to the https://IP:2087 on different browser.. if you still get the issue, kindly update to us here with a screenshot..
You were right, it was a cache issue. Used another browser and it works.

Thank you guys
 
  • Like
Reactions: DennisMidjord