Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot manage PostgreSQL DBs/Tables with phpPgAdmin

Discussion in 'Database Discussions' started by Oldiesmann, Dec 29, 2016.

Tags:
  1. Oldiesmann

    Oldiesmann Active Member

    Joined:
    Dec 30, 2008
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    56
    Location:
    Cincinnati, Ohio, USA
    cPanel Access Level:
    Root Administrator
    I am running CentOS 7 with PostgreSQL 9.2.18 and the latest release version of cPanel/WHM (it's a VPS). I mostly use PostgreSQL to test a forum script that I am a developer for. Recently we added a few more columns to one of the database tables. Since it's a development version, the simplest option was to go into phpPgAdmin and add the columns. However, upon trying to execute the changes, I just get an error saying "Error: must be owner of relation <table>". This is when logged in to cPanel as the account owner (not as root). All of the tables are owned by the user that created them, but the cPanel user doesn't have the appropriate privileges to fix the tables. I even tried granting the cPanel user all privileges on the database (which I was able to do), but I couldn't grant that user privileges. The only way I was able to add the columns was to login to PostgreSQL via the shell as the user that owned the database.

    In WHM I went in to the "Configure PostgreSQL" section and clicked "add users", but now trying to log in to phpPgAdmin fails entirely (it just says "Login failed").
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,419
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Our PostgreSQL Databases document offers a note that may explain the issue you are experiencing:

    Could you let us know if using the Synchronize Grants option helps?

    Thank you.
     
  3. Oldiesmann

    Oldiesmann Active Member

    Joined:
    Dec 30, 2008
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    56
    Location:
    Cincinnati, Ohio, USA
    cPanel Access Level:
    Root Administrator
    The only way I'm able to login is if I use the synchronize grants option. However, I'm still unable to add columns to a table created by one of the database users.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,419
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  5. Oldiesmann

    Oldiesmann Active Member

    Joined:
    Dec 30, 2008
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    56
    Location:
    Cincinnati, Ohio, USA
    cPanel Access Level:
    Root Administrator
    Thanks. The ticket ID is 8129137. I also referenced this topic in the ticket.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,419
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    To update, it looks like the issue was not reproducible and is no longer occurring.

    Thanks!
     
Loading...

Share This Page