The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot migrate from legacy backup

Discussion in 'Data Protection' started by dannette, May 1, 2017.

Tags:
  1. dannette

    dannette Member

    Joined:
    Apr 27, 2010
    Messages:
    11
    Likes Received:
    2
    Trophy Points:
    53
    I have received the notice to migrate to the newer backup system. However the message I am getting when I check the settings is that it times out when trying to connect to the ftp backup drive after 2 minutes.

    In the destination drive I am getting files made called validate.tmp-string-of-numbers.txt. When I open the files it says "This is a test file created to determine if backups are operable::same-string-of-numbers."

    When I go ahead and try to migrate, I get:

    The system failed to migrate from the Legacy Backup system to the new Backup system. Refresh your page and try again.
    There was a failure trying to convert the existing Legacy Backup Config's FTP settings, no changes have been made: Could not list files in destination: “Cpanel::Transport::Files::_perms_str2oct” was given an invalid permissions string: date

    I haven't been able to find out what this means.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,064
    Likes Received:
    1,287
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    This can happen if the remote FTP server you are using does not have MLSD enabled. Can you enable MLSD on the remote FTP server, or contact the administrator of that server to see if it's possible to enable it?

    Thank you.
     
  3. dannette

    dannette Member

    Joined:
    Apr 27, 2010
    Messages:
    11
    Likes Received:
    2
    Trophy Points:
    53
    Thanks. We have a dedicated server with a remote backup. I will have our data center look into it.
     
    cPanelMichael likes this.
  4. dannette

    dannette Member

    Joined:
    Apr 27, 2010
    Messages:
    11
    Likes Received:
    2
    Trophy Points:
    53
    I had put in a ticket to our data center and this was their reply:

    Most things I’m finding online are pointing to changing it to “only use plain FTP”, or under transfer Settings, use Active rather than default (active vs passive), use LIST if MLSD fails, or it being another connection settings mismatch.

    I tried active and got a 'could not connect' error. Where would I try LIST rather than MLSD?
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,064
    Likes Received:
    1,287
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    In "WHM >> Backup Configuration", you can edit your FTP destination so that "Passive FTP" is disabled if it's not already configured that way. Also, could you verify which FTP server software is installed on your remote FTP destination?

    Thank you.
     
  6. dannette

    dannette Member

    Joined:
    Apr 27, 2010
    Messages:
    11
    Likes Received:
    2
    Trophy Points:
    53
    That's what I did when I tried active. After further discussion with the data center, we found they had the FTP destination set to MS-DOS so they changed to UNIX and it verified (I'm assuming the remote server is Winders). I am cautiously optimistic it they will transport tonight. I didn't want to test during the day and bog the server down.
     
    cPanelMichael likes this.
  7. dannette

    dannette Member

    Joined:
    Apr 27, 2010
    Messages:
    11
    Likes Received:
    2
    Trophy Points:
    53
    So that seemed to have fixed the problem here.
    Overnight almost all of them transported.
    I looked at the backups made and all are there locally, however one did not make it to the ftp destination.
    I got a vague error:

    Unable to send “/home/backups/2017-06-02/accounts/accountname.tar.gz” to destination “FTP Destination”

    I looked at logs in the cpbackup_transporter and there were none for today. Just a message from the server with the above error. Is there a way to 'requeue' a backup for transport? I couldn't find anything about that.
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,064
    Likes Received:
    1,287
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    This typically happens when the connection to the FTP server times out or hangs. How large is the account? You can't initiate a transport of a single archive, but you can force a new backup generation of all accounts with the following command:

    Code:
    /usr/local/cpanel/bin/backup --force
    Thank you.
     
  9. dannette

    dannette Member

    Joined:
    Apr 27, 2010
    Messages:
    11
    Likes Received:
    2
    Trophy Points:
    53
    That particular account wasn't even one of the biggest. I don't really want to have a new backup generated. I saw the backup is on the source server locally - I just wonder if there is a command to requeue that one account to transport.
     
  10. dannette

    dannette Member

    Joined:
    Apr 27, 2010
    Messages:
    11
    Likes Received:
    2
    Trophy Points:
    53
    Also, I have destination timeout at 9600 and the one that failed was in the middle alphabetically if that matters. Should that 9600 be increased? Is there a high limit?
     
  11. dannette

    dannette Member

    Joined:
    Apr 27, 2010
    Messages:
    11
    Likes Received:
    2
    Trophy Points:
    53
    I just upped it to 18000 seconds (5 hours) - we'll see what that does.
     
Loading...

Share This Page