The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot ping ipalias address from outside world

Discussion in 'General Discussion' started by sclayton, Mar 3, 2006.

  1. sclayton

    sclayton Member

    Joined:
    Jun 15, 2005
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    UK
    Hi

    I have set up 2 aliases on my main eth0, as follows:

    eth0 - 194.x.x.2
    eth0:1 - 194.x.x.3
    eth0:2 - 195.x.x.2

    I can ping any on the ip addresses internally when logged onto the cPanel server, but from the outside world I can ping either of the 194 addresses (eth0, eth0:1) but cannot ping eth0:2, I also cannot access any website assigned to eth0:2 from the outside world.

    Anyone got any ideas?

    thanks
     
  2. brianoz

    brianoz Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,146
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    Melbourne, Australia
    cPanel Access Level:
    Root Administrator
    Have you got a firewall set up (like apf etc) that might be blocking pings from outside the machine?

    Is routing set up at your data centre (or similar) for those IPs?
     
  3. sclayton

    sclayton Member

    Joined:
    Jun 15, 2005
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    UK
    I have got APF but I can ping both eth0 and eth0:1 ips ok from the outside world, it's just eth0:2 that I cannot. With regards to routing I can ping the main internet router on both the 194.x.x.x network and the 195.x.x.x network from the cPanel server.
     
  4. sclayton

    sclayton Member

    Joined:
    Jun 15, 2005
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    UK
    I can also ping the main internet router from the outside world on both the 194.x.x.x and 195.x.x.x networks
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    That might suggest that either the additional IP addresses are not indeed routed to your server, or they've been setup with the wrong network mask.
     
Loading...

Share This Page