SOLVED Cannot Read License File

celdad

Registered
Aug 30, 2022
3
0
1
Ontario, Canada
cPanel Access Level
Root Administrator
little help please.. trying to get cpanel running and i have purchased a license from cpanel. i have the firewall disabled on the os. and the ports open on the router. im hoping its a port thing but i cant tell. what i get is this message:

The cPanel license server said that a license could not be issued for your server (66). For more information visit: lic | cPanel The exact message was: This machine is not licensed for a cloud server. A metal license is required for this machine. (myserveraddress)

same message when i run the command in root.
/usr/local/cpanel/cpkeyclt

and thats about all i can think of to put in here.. the OS is cloudlinux. any help would be great thanks.
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
11,667
1,853
363
cPanel Access Level
Root Administrator
Hey there! It seems that you have purchased the wrong license type for your particular system. If no virtualization software is detected, you'll need to purchase a metal license for the dedicated server. Can you try upgrading the license to a metal type to see if that gets things working?

If you don't think that should be a requirement for your machine, please email [email protected] so our Customer Service team can check the license settings for you.
 
  • Like
Reactions: celdad

celdad

Registered
Aug 30, 2022
3
0
1
Ontario, Canada
cPanel Access Level
Root Administrator
Hey there! It seems that you have purchased the wrong license type for your particular system. If no virtualization software is detected, you'll need to purchase a metal license for the dedicated server. Can you try upgrading the license to a metal type to see if that gets things working?

If you don't think that should be a requirement for your machine, please email [email protected] so our Customer Service team can check the license settings for you.
would like to thank you.. bang on the money.. sometimes just need someone else to look and tell you.. thanks !!