The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot recieve emails that contain jpgs as attachments

Discussion in 'E-mail Discussions' started by Jeff75, Aug 18, 2004.

  1. Jeff75

    Jeff75 Well-Known Member

    Joined:
    Apr 11, 2003
    Messages:
    555
    Likes Received:
    0
    Trophy Points:
    16
    One of my clients cannot receive any emails that contain .jpg files as attachments. I checked the mail logs and any email that contains a .jpg is going to /dev/null. Here's what shows up:

    Code:
    2004-08-18 18:52:33 1BxZIH-000Ija-Gk <= login@server.domain.com U=login P=local-bsmtp S=115813 id=20040818225931.MJXO14988.imf19aec.mail.isp.net@jeff
    2004-08-18 18:52:33 1BxZIH-000Ija-Gk => /dev/null <test@login.org> R=central_filter T=**bypassed**
    2004-08-18 18:52:33 1BxZIH-000Ija-Gk Completed
    2004-08-18 18:52:33 1BxZIH-000IjU-28 => test <test@login.org> R=virtual_sa_user T=virtual_sa_userdelivery
    2004-08-18 18:52:33 1BxZIH-000IjU-28 Completed
    I tried removing his mail filters and restarting Exim and it didn't help. They have plenty of disk space available and are nowhere near the quota.

    I also tested this on another email account on another domain on the server and the problem didn't occur. Does anybody know why this is happening and how to fix it?
     
  2. Jeff75

    Jeff75 Well-Known Member

    Joined:
    Apr 11, 2003
    Messages:
    555
    Likes Received:
    0
    Trophy Points:
    16
    Anybody? I really need to fix this ASAP.
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Have you checked in /etc/antivirus.exim to see if it blocks that extension?
     
  4. Jeff75

    Jeff75 Well-Known Member

    Joined:
    Apr 11, 2003
    Messages:
    555
    Likes Received:
    0
    Trophy Points:
    16
    No, but I don't think that's the problem because I'm able to receive emails with .JPGS on other accounts off of other domains on the server.
     
  5. ljprevo

    ljprevo Well-Known Member

    Joined:
    Apr 15, 2003
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    They have a filter set to reject these possibly?
     
  6. GOT

    GOT Get Proactive!

    Joined:
    Apr 8, 2003
    Messages:
    900
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Norfolk, VA
    cPanel Access Level:
    DataCenter Provider
    Are there any aliases set to :blackhole:? Same for the default email.

    Does an email to the same address without a jpg extension get delivered?

    Have you installed exiscan?
     
  7. goodmove

    goodmove Well-Known Member

    Joined:
    May 12, 2003
    Messages:
    624
    Likes Received:
    0
    Trophy Points:
    16
    R=central_filter T=**bypassed**

    That suggests an email filter in the user's account. Try and check /etc/vfilters/{userdomain} for the contents.

    T=virtual_sa_userdelivery

    That suggests the user has Spamassassin and the spam box activated. Have him login to his Webmail account for his mail address (where he was expecting to receive the email) and check the folder called spam. If not found, repeat the steps but this time for the main email account.
     
  8. Stephanie_R

    Stephanie_R Active Member

    Joined:
    Mar 1, 2004
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    Open /etc/exim.conf and make sure:
    system_filter = /etc/antivirus.exim
    Is commented out with a # save exit then restart exim.
    /etc/rc.d/init.d/exim restart
     
  9. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    A better way to do away with /etc/antivirus.exim (because upcp and exim4 scripts will overwrite that change whenever exim is upgraded), is to do the following instead:

    pico -w /scripts/postupcp

    If it doesn't already exist, put this at the top:

    #!/bin/sh

    Then add:

    cat /dev/null > /etc/antivirus.exim

    Exit, then set execute permissions on it:

    chmod +x /scripts/postupcp
     
  10. GOT

    GOT Get Proactive!

    Joined:
    Apr 8, 2003
    Messages:
    900
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Norfolk, VA
    cPanel Access Level:
    DataCenter Provider
    Or how about this? In WHM, under Exim Configuration, there is the area where this is set and if it is left blank it is disabled.
     
Loading...

Share This Page