The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot restart Postgresql!

Discussion in 'General Discussion' started by NobeleeNa, Aug 18, 2004.

  1. NobeleeNa

    NobeleeNa Active Member

    Joined:
    May 26, 2004
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Makassar, Sulawesi Selatan - INDONESIA
    Hello,

    I was intalling Postgresql in my server and after that I try to restart it to see if it's working or not and bellow is the result i found.

    Attempting to restart postgresql
    Waiting for postgresql to restart.... . . . . . . . . . . finished.

    postgresql status


    postgresql has failed, please contact the sysadmin (result was "postmaster is not running").

    Can anyone help please?


    Regards,

    Bryan
     
  2. WMS

    WMS Active Member

    Joined:
    Jul 18, 2003
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Moscow
    /tmp

    Check the permissions of your /tmp.
    They HAVE to be 777.
    If they are not, do the follwoing:

    chmod 777 /tmp
    chmod +t /tmp

    To Cpanel Support:
    WHY DO YOU CHANGE THE PERMISSIONS OF /tmp WHEN REBUILDING APACHE???????
     
  3. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    Is this on RHE or Fedora? If so, run the install script again and then initialize it manually:

    initdb -D /var/lib/pgsql/data


    Also be sure to configure postgres from WHM after initializing it.
     
  4. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,367
    Likes Received:
    5
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Would be happy to be corrected but would have to say that setting /tmp to 777 may create security problems. Better to go with 1777 to turn on the sticky bit.
     
Loading...

Share This Page