The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot run FCGI (invalid configuration) - Bug???

Discussion in 'General Discussion' started by DReade83, Dec 9, 2008.

  1. DReade83

    DReade83 Well-Known Member

    Joined:
    Oct 20, 2006
    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Cheshire, UK
    This is what WHM says when I select "fcgi" from the drop-down under "PHP and suEXEC Configuration". I've built Apache with FastCGI and selected the fcgid support for PHP too.

    Why won't it work??
     
  2. MikeDVB

    MikeDVB Well-Known Member
    PartnerNOC

    Joined:
    Jun 4, 2008
    Messages:
    212
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    Indiana, USA
    I know this thread is very old but I ran across this same issue and found this via Google search so my post may help somebody else in the future.

    Go back trough EasyApache and make sure to go to the Exhaustive list of options and check fcgi support under PHP as well as at the top for Apache and then rebuild it and this will resolve the issue.
     
  3. Sergiu Tot

    Sergiu Tot Well-Known Member

    Joined:
    Jul 17, 2007
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Cluj, Romania
    cPanel Access Level:
    Root Administrator
    The same thing happends to me. Does anyone have any ideea?

    WHM 11.28.52
    FreeBSD 8.0-RELEASE
     
  4. mysterym

    mysterym Registered

    Joined:
    Nov 3, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    it's dumb but you cannot have fastcgi php working unless you compile php as a dso ;)
    which doesn't make sense since I was trying to compile only the stuff I need and php dso I do not need

    so, for it to work, you need to compile also php as a dso and then enable fastcgi ;)
    took me some time to figure this out

    usually I completelly disable php, enable fastcgi and just use php via fastcgi
    or perl
    or whatever
     
Loading...

Share This Page