Cannot run yum commands or use EA4

Angus Allan

Registered
Mar 20, 2018
3
0
1
Wellington, New Zealand
cPanel Access Level
Root Administrator
Hi all,

Yesterday I ran the "yum cleanall" command because inside EA4 in WHM it could not find any packages. Now I cannot run any yum commands at all. For example:

yum update yum makecache yum upgrade

All of these fail and return an error like this:

yum update
Loaded plugins: universal-hooks Could not retrieve mirrorlist http://httpupdate.cpanel.net/cPAddons-c7-x8664-mirrorlist error was 12: Timeout on http://httpupdate.cpanel.net/cPAddons-c7-x8664-mirrorlist: (28, 'Connection timed out after 30006 milliseconds')

One of the configured repositories failed (Unknown), and yum doesn't have enough cached data to continue. At this point the only safe thing yum can do is fail. There are a few ways to work "fix" this:

1. Contact the upstream for the repository and get them to fix the problem.

2. Reconfigure the baseurl/etc. for the repository, to point to a working
upstream. This is most often useful if you are using a newer
distribution release than is supported by the repository (and the
packages for the previous distribution release still work).

3. Run the command with the repository temporarily disabled
yum --disablerepo=<repoid> ...

4. Disable the repository permanently, so yum won't use it by default. Yum
will then just ignore the repository until you permanently enable it
again or use --enablerepo for temporary usage:

yum-config-manager --disable <repoid>
or
subscription-manager repos --disable=<repoid>

5. Configure the failing repository to be skipped, if it is unavailable.
Note that yum will try to contact the repo. when it runs most commands,
so will have to try and fail each time (and thus. yum will be be much
slower). If it is a very temporary problem though, this is often a nice
compromise:

yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true
Cannot find a valid baseurl for repo: EA4

Also, when trying to access EA4 in WHM I get:
The YUM cache is incomplete. The system is updating the cache to repair the issue. This operation can take a few minutes to complete (it is very network and disk i/o intensive). EasyApache 4 will be available as soon as possible …

Followed by this error about 30 seconds later:
YUM encountered errors outside of EasyApache 4. Log into the system via SSH to resolve them, or you can click the ‘Refresh’ button to rebuild the system‘s YUM cache.


I have tried:
Changing the DNS servers
Uncommenting the baseurl in the mirrorlist
About 5 hours of other things tinkering

Does anyone know what I am doing wrong?

Thanks in advance for any help, I really appreciate it.
 

Angus Allan

Registered
Mar 20, 2018
3
0
1
Wellington, New Zealand
cPanel Access Level
Root Administrator
Thanks for the reply Dalem!

Sadly I tried the suggested solution in that thread. This was the suggestion:

Code:
$ nano /etc/yum.repos.d/nano EA4.repo

Find the line mirrorlist=http://httpupdate.cpanel.net/ea4-c$releasever-$basearch-mirrorlist

change c$releasever to c7

$yum clean all;
$yum makecache
$yum update
After trying that I get an identical error :(
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
Hello,

Please post the output from the following commands:

Code:
 cat /etc/yum.repos.d/EA4.repo
cat /etc/redhat-release
grep distro /etc/yum.conf
Also, are you able to successfully run the "ping httpupdate.cpanel.net" command from the cPanel server?

Thank you.
 

Angus Allan

Registered
Mar 20, 2018
3
0
1
Wellington, New Zealand
cPanel Access Level
Root Administrator
Hi Michael,

Thanks for your reply.

Pinging that address returned the following:
PING httpupdate.cpanel.net (63.247.66.98) 56(84) bytes of data.
64 bytes from atl.nwss.co (63.247.66.98): icmp_seq=1 ttl=48 time=225 ms
64 bytes from atl.nwss.co (63.247.66.98): icmp_seq=2 ttl=48 time=225 ms
64 bytes from atl.nwss.co (63.247.66.98): icmp_seq=3 ttl=48 time=225 ms
64 bytes from atl.nwss.co (63.247.66.98): icmp_seq=4 ttl=48 time=225 ms
64 bytes from atl.nwss.co (63.247.66.98): icmp_seq=5 ttl=48 time=225 ms
^C
--- httpupdate.cpanel.net ping statistics ---
6 packets transmitted, 5 received, 16% packet loss, time 5010ms
rtt min/avg/max/mdev = 225.722/225.769/225.801/0.301 ms


Here is the output from the commands you listed:

# cat /etc/yum.repos.d/EA4.repo
[EA4]
name=EA4 ( EasyApache 4 )
mirrorlist=http://httpupdate.cpanel.net/cPAddons-c7-x86_64-mirrorlist
gpgcheck=1
gpgkey=https://securedownloads.cpanel.net/cPanelPublicRPMKey.asc
enabled=1
cost=50
# cat /etc/redhat-release
CentOS Linux release 7.4.1708 (Core)
# grep distro /etc/yum.conf
distroverpkg=centos-release

Thanks for your help
 

dalem

Well-Known Member
PartnerNOC
Oct 24, 2003
2,980
156
368
SLC
cPanel Access Level
DataCenter Provider