The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot send E-mail to domains NOT on server....

Discussion in 'E-mail Discussions' started by Spuds, Oct 10, 2003.

  1. Spuds

    Spuds Registered

    Joined:
    Oct 6, 2003
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    This is a strange problem. I've thought about it for a bit, but can't seem to figure it out. Here goes:

    Server is on network A.

    E-mail client is on network B.

    If I send e-mail from client on B, the e-mail will never get sent.

    If I send e-mail from webmail client on network A, e-mail gets sent out.

    dig from network B shows that everything is in order as far as DNS... as far as I can tell, anyway...

    C:\WINDOWS\system32>dig MX windsorhost.com

    ; <<>> DiG 9.2.2 <<>> MX windsorhost.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 41
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 4

    ;; QUESTION SECTION:
    ;windsorhost.com. IN MX

    ;; ANSWER SECTION:
    windsorhost.com. 8337 IN MX 0 windsorhost.com.

    ;; AUTHORITY SECTION:
    windsorhost.com. 8337 IN NS ns2.windsorhost.com.
    windsorhost.com. 8337 IN NS ns.windsorhost.com.

    ;; ADDITIONAL SECTION:
    windsorhost.com. 7785 IN A 69.57.173.50
    ns.windsorhost.com. 8138 IN A 69.57.173.50
    ns.windsorhost.com. 8138 IN A 69.57.173.51
    ns2.windsorhost.com. 8118 IN A 69.57.173.50

    ;; Query time: 110 msec
    ;; SERVER: 216.106.1.2#53(216.106.1.2)
    ;; WHEN: Fri Oct 10 12:35:45 2003
    ;; MSG SIZE rcvd: 148


    The only thing I can think of is that ns.windsorhost.com is mentioned with A records TWO TIMES with different IPs. I have fixed that problem.

    Otherwise, the IP and DNS configuration is correct.

    I do not own these domains, I'm simply trying to fix the problem for a client.

    Any hints / suggestions?

    Spuds

    cPanel.net Support Ticket Number:
     
  2. NNNils

    NNNils Well-Known Member

    Joined:
    Sep 17, 2002
    Messages:
    580
    Likes Received:
    0
    Trophy Points:
    16
    Did you check /etc/resolv.conf ?
     
Loading...

Share This Page