Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Cannot send e-mails in horde

Discussion in 'E-mail Discussion' started by screege, Jun 4, 2007.

  1. screege

    screege Well-Known Member

    Joined:
    Aug 11, 2004
    Messages:
    190
    Likes Received:
    0
    Trophy Points:
    166
    Hi I cannot send e-mails using horde it gives me this error:

    There was an error sending your message: unable to connect to smtp server localhost:25

    But when sending with squirrel mail I have no problems any ideas?

    Thanks
     
  2. JayAtjeu

    JayAtjeu Member

    Joined:
    Apr 27, 2006
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    151
    One of my clients is having the same issue. Anyone know of a fix? I'll be trying some things and let you know if I find a fix.
     
  3. screege

    screege Well-Known Member

    Joined:
    Aug 11, 2004
    Messages:
    190
    Likes Received:
    0
    Trophy Points:
    166
    Well in my case it was csf (configservers firewall) who was blocking horde I putted an option yto allow scripts to send.
     
  4. ttremain

    ttremain Well-Known Member

    Joined:
    Feb 16, 2003
    Messages:
    215
    Likes Received:
    0
    Trophy Points:
    166
    cPanel Access Level:
    Root Administrator
    Instead of letting scripts send SMTP mail, which is dangerous...

    I seem to have solved this...

    I edited /usr/local/cpanel/base/horde/config/conf.php

    Found: $conf['mailer']['type'] = 'smtp';

    and replaced it with: $conf['mailer']['type'] = 'sendmail';
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. keithc

    keithc Member

    Joined:
    Jun 5, 2007
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    151
    I've found that the Cpanel update sometimes causes this change to revert back to "smtp". Is there a way to keep the setting as "sendmail" or is there another issue that is causing this not to work with the "smtp" setting? I was thinking about just creating a cronjob to change it back to "sendmail" if the conf.php file gets changed? In the past 2 months, I've had this issue and have changed it back to reflect "sendmail" 2 or 3 times.

    Thanks,

    Keith
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice