The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot send email using Thunderbird

Discussion in 'E-mail Discussions' started by ria_river, Jun 22, 2011.

  1. ria_river

    ria_river Member

    Joined:
    Sep 8, 2010
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Hi to all!

    I setup my email in Thunderbird and was able to receive emails but the problem is I cannot send emails and it will display the error below:

    "Sending of message failed. The message could not be sent because connecting to SMTP server [my server name] failed. The server may be unavailable or is refusing SMTP connections. Please verify that your SMTP server settings is correct and try again, or else contact your network administrator."

    I followed the "Mail Client Configuration in cpanel" using manual configurations:

    my email add is username@mydomainname.com

    Mail Server Username: username+mydomainname.com
    Incoming Mail Server: mail.mydomainname.com
    Incoming Mail Server: (SSL) myservername.com
    Outgoing Mail Server: mail.domainname.com (server requires authentication) port 25
    Outgoing Mail Server: (SSL) myservername.com (server requires authentication) port 465
    Supported Incoming Mail Protocols: POP3, POP3S (SSL/TLS), IMAP, IMAPS (SSL/TLS)
    Supported Outgoing Mail Protocols: SMTP, SMTPS (SSL/TLS)

    So I configure Thunderbird outgoing server (SMTP):
    server name: myservername.com
    port: 465
    username: username+mydomainname.com
    secure connection: SSL

    I also tried mail.domainname.com using port 25 but I still get the same error.

    Operating system: Ubuntu 9.04

    I setup my gmail account in Thunderbird and works perfectly. So I think this is an issue with my outgoing server settings. Any suggestions are greatly appreciated.

    Ria
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
  3. ria_river

    ria_river Member

    Joined:
    Sep 8, 2010
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    I changed + to @ but I still get the same error.
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    On the server or your desktop?

    I think I see the problem overlooked earlier:

    Outgoing Mail Server: (SSL) myservername.com (server requires authentication) port 465
    Supported Incoming Mail Protocols: POP3, POP3S (SSL/TLS), IMAP, IMAPS (SSL/TLS)
    Supported Outgoing Mail Protocols: SMTP, SMTPS (SSL/TLS)

    Unless thats a typo, you're missing something it looks like, highlighted in bold here.

    Outgoing Mail Server: (SSL) thispart.myservername.com (server requires authentication) port 465

    Is this server's hostname setup properly?
     
  5. ria_river

    ria_river Member

    Joined:
    Sep 8, 2010
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Yes. It looks like this companyname.managed.servername.com.
     
  6. ria_river

    ria_river Member

    Joined:
    Sep 8, 2010
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    I changed + to @ on my desktop not on the server. Should I change it on the server? If so, how will I do it?
     
  7. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    In WHM > Networking Setup > Change Hostname, you'll see sample hostnames listed. None of them look like yours.



    Changing the setting on your computer should be fine.
     
  8. ria_river

    ria_river Member

    Joined:
    Sep 8, 2010
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    The Hostname I have has the same format with the "Ten Randomly Generated Hostnames". Is their a need for me to change my hostname inorder to get my Outgoing Mail Server working in Thunderbird?
     
  9. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Yours has 3 words, those have 2. I'm just going by your post looking for issues I can see. I don't use thunderbird so cannot assist there, hopefully someone who does will be by soon.
     
  10. ria_river

    ria_river Member

    Joined:
    Sep 8, 2010
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    The "Ten Randomly Generated Hostnames" have 3 words in it too. What are the other possible reasons why the server may be unavailable or is refusing SMTP connections?
     
  11. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,281
    Likes Received:
    37
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    Your ISP may be blocking your ability to connect to TCP 25 from your current connection . Many ISPs / wireless hotspots / coffee shops / hotels / etc prevent their users from being able to connect to TCP 25 on a server external to their network.

    You can try setting up your Thunderbird to use an alternate port. But, you can only do this if your cPanel server is already configured to listen for SMTP connections on an alternate port. Otherwise, set your Thunderbird up to use SMTP over SSL and port 465.

    So, two options:

    1. Use SMTP-over-SSL
    2. Configure your server to listen on an alternate SMTP port (such as TCP 26).

    #2 is done by loggging into WHM, then selecting Service Configuration, then Service Manager, then "Exim on another port"

    exim on another port

    Allow exim to listen on port __26__
    Useful for providers that block port 25.

    In my case, I set Exim up to also listen on port 26. So I can then tell my customers to set the SMTP Port in their email configuration to 26 to bypass any ISP restriction that may be blocking outbound TCP 25 connections from their location.

    Mike
     
  12. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    If you're counting the .com yours has 4:

    companyname.managed.servername.com

    This is acceptable:
    managed.servername.com


     
  13. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,281
    Likes Received:
    37
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    I don't think his problem has anything to do with hostnames. Incidentally an FQDN can consist of many dots. You can have, for instance, a subdomain added called billy.bob.is.cool.at.my.domain.com and you can create billy@billy.bob.is.cool.at.my.domain.com and can send/receive email for that subdomain. You've got a domain name, a host, and the combination of the host + domain name is going to be your FQDN.

    I suspect his issue is one where he is attempting to send outgoing mail over the default SMTP Port of 25 and that his ISP / company / wireless hotspot / hotel / wherever he is getting connectivity is simply blocking TCP 25 traffic outbound as a spam prevention measure. I suspect he simply needs to use an alternate port (if his server is configured to listen on an alternate port) or use SMTP-over-SSL (which by default is going to use a different port).

    Mike
     
  14. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Possibly. I'm leaning toward the server not being setup properly though.

    I can only guess what his problem is, but I can look at his posts and see what I think might be incorrect and mention it. Sometimes its the small things overlooked and all. ;)
     
  15. ria_river

    ria_river Member

    Joined:
    Sep 8, 2010
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Hi mtindor,

    For option #1 I use the following configurations:
    server name: companyname.managed.servername.com
    port: 465
    username: username@mydomainname.com
    secure connection: SSL

    Result: I got the same error

    For option #2 I use the following configurations:
    I already configure the server to listen on an alternate SMTP port 26
    server name: companyname.managed.servername.com
    port: 26
    username: username@mydomainname.com
    secure connection: SSL (I also tried None)

    Result: I still get the same error.
     
    #15 ria_river, Jun 23, 2011
    Last edited: Jun 23, 2011
  16. ria_river

    ria_river Member

    Joined:
    Sep 8, 2010
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Below is my Exim configurations:

    ACL Options
    SpamAssassin™ reject spam score threshold [?] - No reject rule by spam score default
    Dictionary attack protection [?] - ON
    Blacklist: Reject remote mail sent to primary host [?] - OFF
    Ratelimit suspicious SMTP servers [?] - ON
    SpamAssassin™: ratelimit spam score threshold [?] - No ratelimiting by spam score default
    Require HELO before MAIL [?] - ON
    Require remote (hostname/IP) HELO [?] - ON
    Require remote (domain) HELO [?] - OFF
    Require RFC-compliant HELO [?] - ON
    Blacklist: SPF Checking [?] - OFF
    Maximum message recipients (soft limit) [?] - No rejection based on number of recipients default
    Maximum message recipients before disconnect (hard limit) [?] - No disconnection based on number of recipients

    Access Lists
    Automatically whitelist known mobile device providers [?] - ON

    Domains and IPs
    Send mail from account’s dedicated IP [?] - OFF
    Reference /etc/mailhelo for outgoing SMTP HELO [?] - OFF
    Reference /etc/mailips for outgoing SMTP connections [?] - OFF

    Filters
    System Filter File [?] - /etc/cpanel_exim_system_filter
    Attachments: Filter messages with dangerous attachments - ON
    SpamAssassin™: Global Subject Rewrite [?] - ON
    SpamAssassin™: bounce spam score threshold [?] - No bouncing by spam score
    SpamAssassin™: X-Spam-Subject/Subject header prefix for spam emails [?] - ***SPAM***

    Mail
    Log sender rates in the exim mainlog - ON
    Sender Verification Callouts [?] - OFF
    Send generic recipient failure messages [?] - OFF
    Allow mail delivery if malware scanner fails [?] - ON
    Reject mail for users over quota [?] - ON
    Sender Verification [?] - ON
    Set SMTP Sender: headers [?] - OFF
    Allow mail delivery if spam scanner fails [?] - ON

    Security
    Allow weak SSL/TLS ciphers [?] - OFF
    Require clients to connect with SSL or issue the STARTTLS command before they are allowed to authenticate with the server. [?] - OFF


    Please let me know what needs to be changed.
     
  17. ria_river

    ria_river Member

    Joined:
    Sep 8, 2010
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    By the way, my Firewall is already turned off.
     
  18. ckh

    ckh Well-Known Member

    Joined:
    Dec 6, 2003
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Phoenix, AZ
    cPanel Access Level:
    DataCenter Provider
    My ISP blocks both ports 25 & 26 so you may want to try a different alternate port.
     
  19. ria_river

    ria_river Member

    Joined:
    Sep 8, 2010
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    What other ports will I use?
     
  20. ria_river

    ria_river Member

    Joined:
    Sep 8, 2010
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    I tried Evolution Mail and Microsoft Outlook as mail client but I still get the same problem. Incoming settings work but Outgoing settings won't. Sending and receiving mails via cpanel webmail works perfectly. Is there something wrong with my server SMTP config that makes it unavailable and will refuse connections from mail clients? Any suggestions?
     
Loading...

Share This Page