The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot send out emails via port 587.

Discussion in 'E-mail Discussions' started by SuperBaby, May 14, 2008.

  1. SuperBaby

    SuperBaby Well-Known Member

    Joined:
    Nov 27, 2003
    Messages:
    331
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Thailand
    cPanel Access Level:
    Website Owner
    Twitter:
    Recently the telco (TmNet) in our country has blocked out port 25 nationwide in order to find spam. According to them, they allow only port 587. As a result, the existing setting for my Outlook 2007 cannot send emails via my server:

    SMTP Mail Server: xxxx.com
    SMTP Port: 25

    I then changed the port above to "587" and added "587" under TCP_IN and TCP_OUT in the firewall of this server (note that I am using ConfigServer Firewall which can be found under WHM >> Plugins >> ConfigServer Security&Firewall).

    But I still cannot send out emails via Outlook 2007. See screenshot attached below.

    I suspected that the DNS of my server is not properly setup. Please help. I need to use my own mail server and not the sluggish one provided by the telco.
     

    Attached Files:

  2. SuperBaby

    SuperBaby Well-Known Member

    Joined:
    Nov 27, 2003
    Messages:
    331
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Thailand
    cPanel Access Level:
    Website Owner
    Twitter:
  3. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    You'll have to use their outgoing SMTP server details. No way around it.
     
  4. SuperBaby

    SuperBaby Well-Known Member

    Joined:
    Nov 27, 2003
    Messages:
    331
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Thailand
    cPanel Access Level:
    Website Owner
    Twitter:
    If you read the news release above, you can see that they said "you can use port 587 if you use your own mail server".
     
  5. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    On the link they provide for mailserver there's a piece concerning Exim where it clearly states what you could try.
    http://webmail.tm.net.my/info/smtp-proxy.html#Exim

    Is your server in Malasia? If so that might be worth trying. Short of that simply setting up your mail client to use their outgoing mail details shouyld solve your problem.

    Many ISPs in the US now force you to use their mail server for outgoing as well.
     
  6. SuperBaby

    SuperBaby Well-Known Member

    Joined:
    Nov 27, 2003
    Messages:
    331
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Thailand
    cPanel Access Level:
    Website Owner
    Twitter:
    I just found the solution thanks to the tech support from The Planet hosting. If you are using WHM/cPanel, go to WHM >> SERVICE CONFIGURATION >> SERVICE MANAGER. Near to the bottom of the page, you can specify to run another copy of EXIM under a different port. Simply key in "587". Make sure you enable port 587 under the firewall too. That solves the problem.

    BTW, my server is in Dallas.
     
  7. zlatan

    zlatan Registered

    Joined:
    Mar 19, 2005
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Thank you

    This was very helpful. I had the same issue and enabling the other port helped.
     
Loading...

Share This Page