The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot send outgoing mail when I set default address to :fail:

Discussion in 'E-mail Discussions' started by zaggs, Sep 27, 2006.

  1. zaggs

    zaggs Member

    Joined:
    Dec 5, 2004
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Hi guys,

    When I set the default unrouted email address to :fail: I am not able to send outgoing mail. However, if I change it to :blackhole: it works fine again.

    Any ideas what to do?
     
  2. angelina_holy

    angelina_holy Well-Known Member

    Joined:
    Aug 6, 2006
    Messages:
    113
    Likes Received:
    0
    Trophy Points:
    16
    cannot send email

    i dont think there si any relation in sending mails and setting to fail .If you set default address to fail the unrouted mails will be bounced back . Its better to set it to blackhole or set a default catchall . Kindly provide us the error that you get while sending mails .
     
  3. RandyO

    RandyO Well-Known Member

    Joined:
    Jun 17, 2003
    Messages:
    173
    Likes Received:
    0
    Trophy Points:
    16
    I would most certainly not use :blackhole:... :fail: is by far a better option

    Please read this http://configserver.com/free/fail.html

    I have some very busy mail servers and this makes a radical difference... Thanks Chirpy :)

    As far as the problem goes, I have also had complaints about this from some users. I have had them kill and recreate the accounts and it seems to clear up the problem. I have no idea what the issue is however...
     
    #3 RandyO, Sep 28, 2006
    Last edited: Sep 28, 2006
  4. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,381
    Likes Received:
    23
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    When you are sending out e-mail, are you using a valid e-mail address on the server to send out from?

    If example.com exists on your server and you are using mail.example.com as your outgoing mail server and you are sending out mail from bob@example.com. Exim on your server (mail.example.com) will see that the domain you are sending from (example.com) exists on the server. It will then check to make sure that the e-mail address you are sending from (bob@example.com) exists on this server. If it does not then the transaction will fail, because the sender verification process will fail. If you do not have the bob@example.com e-mail address set up, then the default box will be checked. Setting your default box to :blackhole: is the same as accepting the e-mail just not delivering it anywhere. So in this situation, any e-mail address on the example.com domain will be seen as valid. When the default box is set to :fail: only those addresses that are set up as actual mail account and/or forwarders will be accepted.

    Basically, you need to insure that you are sending mail from a valid e-mail address that can also accept e-mail on the server.
     
Loading...

Share This Page