The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Cannot send/receive emails on new server

Discussion in 'E-mail Discussions' started by chris_huh, Dec 8, 2016.

  1. chris_huh

    chris_huh Member

    Joined:
    Dec 5, 2016
    Messages:
    9
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    London
    cPanel Access Level:
    Root Administrator
    Since moving to a new server I can't send emails to Forwarders or send/receive from/to Email Accounts.

    After a while I realised the firewall on my server didn't have the necessary ports open so I opened them. But I'm still getting "Connection timed out" errors.

    When I try to telnet to a gmail server on port 110 or 26 I also get a "Connection timed out" error even though those ports are open in my firewall. My host blocks port 25 by default so I am trying to use port 26 and have changed the setting in WHM's Tweak Settings accordingly.

    In another "emails not working" thread I found the cat /etc/resolv.conf command. When I run that, my nameservers show up incorrectly: they are missing a digit at the end. I'm not sure if that is a problem or just the way cat /etc/resolv.conf shows itself.

    Looking in exim_mainlog I find the emails look like this:

    Code:
    +++ 1cEzE2-0002HH-Pu has not completed +++
    2016-12-08 13:59:06 1cEzE2-0002HH-Pu <= testaccount@domain.com H=xxxxxxxxxx.com ([IPv6:::ffff:192.168.1.68]) [109.147.90.193]:63274 P=esmtpsa X=TLSv1.2:ECDHE-RSA-AES256-GCM-SHA384:256 CV=no A=dovecot_plain:testaccount@domain.com S=2390 T="Test 1359" for email@gmail.com
    2016-12-08 13:59:06 1cEzE2-0002HH-Pu SMTP connection outbound 1481205546 1cEzE2-0002HH-Pu domain.com email@gmail.com
    2016-12-08 14:01:14 1cEzE2-0002HH-Pu H=alt1.gmail-smtp-in.l.google.com [173.194.221.27] Connection timed out
    2016-12-08 14:29:58 1cEzE2-0002HH-Pu SMTP connection outbound 1481207398 1cEzE2-0002HH-Pu domain.com email@gmail.com
    2016-12-08 14:49:03 1cEzE2-0002HH-Pu H=gmail-smtp-in.l.google.com [74.125.133.27] Connection timed out
    2016-12-08 14:51:11 1cEzE2-0002HH-Pu H=alt1.gmail-smtp-in.l.google.com [74.125.205.27] Connection timed out
    2016-12-08 14:53:18 1cEzE2-0002HH-Pu H=alt2.gmail-smtp-in.l.google.com [74.125.68.27] Connection timed out
    2016-12-08 14:55:25 1cEzE2-0002HH-Pu H=alt3.gmail-smtp-in.l.google.com [108.177.97.27] Connection timed out
    2016-12-08 14:57:32 1cEzE2-0002HH-Pu H=alt4.gmail-smtp-in.l.google.com [74.125.28.27] Connection timed out
    2016-12-08 14:57:32 1cEzE2-0002HH-Pu == email@gmail.com R=lookuphost T=remote_smtp defer (110): Connection timed out
    
    Does this look like it might be a problem with my server's ports not actually being open or could there be a setting somewhere else blocking them?

    Thanks
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,064
    Likes Received:
    1,288
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Please review the following post regarding port 25:

    change port 25

    Thank you.
     
  3. chris_huh

    chris_huh Member

    Joined:
    Dec 5, 2016
    Messages:
    9
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    London
    cPanel Access Level:
    Root Administrator
    Ah, thanks. I will have to ask my host to open port 25 then.

    But would this also stop the sending of mail as well as receiving? I find it strange that trying to telnet to port 110 still shows up as blocked when I've opened the port in the server's firewall.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,064
    Likes Received:
    1,288
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Yes, your server would need to connect to the remote mail server over port 25 to send a message.

    Regarding port 110, that port should be open if you want to allow your customers the ability to use POP3 in their email client to download their email messages. Note the SSL port for POP3 is 995.

    Thank you.
     
    danielpmc likes this.
  5. chris_huh

    chris_huh Member

    Joined:
    Dec 5, 2016
    Messages:
    9
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    London
    cPanel Access Level:
    Root Administrator
    I asked the host to lift the block they had on port 25 and it's working now.

    Thanks
     
    cPanelMichael likes this.
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,064
    Likes Received:
    1,288
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    I'm happy to see the issue is now resolved. Thank you for updating us with the outcome.
     
Loading...

Share This Page