The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cannot start named

Discussion in 'General Discussion' started by JoelP, Aug 26, 2006.

  1. JoelP

    JoelP Member

    Joined:
    Oct 2, 2005
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I've been Googling for hours and nothing I've tried has worked.
    The problem started a day or so after setting up DNS clustering. The other server in the cluster works fine and as far as I can tell their configurations are much the same. I have since turn off clustering on both servers.

    Relevant command output as follows (--- denotes end of output):

    # service named restart
    Shutting down named: [FAILED]
    Starting named: [FAILED]
    ---

    # tail /var/log/messages
    Aug 27 02:53:31 us1 named-wrapper[21877]: using 4 CPUs
    Aug 27 02:53:31 us1 named-wrapper[21879]: loading configuration: failure
    Aug 27 02:53:31 us1 named-wrapper[21879]: exiting (due to fatal error)
    Aug 27 02:53:31 us1 named: named-wrapper startup failed
    Aug 27 02:55:05 us1 named: named shutdown failed
    Aug 27 02:55:05 us1 named-wrapper[24009]: starting BIND 9.2.4 -u named
    Aug 27 02:55:05 us1 named-wrapper[24009]: using 4 CPUs
    Aug 27 02:55:05 us1 named-wrapper[24012]: loading configuration: failure
    Aug 27 02:55:05 us1 named-wrapper[24012]: exiting (due to fatal error)
    Aug 27 02:55:05 us1 named: named-wrapper startup failed
    ---

    # cat /etc/named.conf
    include "/etc/rndc.key";

    controls {
    inet 127.0.0.1 allow { localhost; } keys { "key"; };
    };

    options {
    directory "/var/named";
    dump-file "/var/named/data/cache_dump.db";
    statistics-file "/var/named/data/named_stats.txt";
    };


    zone "." IN {
    type hint;
    file "/var/named/named.ca";
    };

    zone "localdomain" IN {
    type master;
    file "/var/named/localdomain.zone";
    allow-update { none; };
    };

    zone "localhost" IN {
    type master;
    file "/var/named/localhost.zone";
    allow-update { none; };
    };

    zone "0.0.127.in-addr.arpa" IN {
    type master;
    file "/var/named/named.local";
    allow-update { none; };
    };

    zone "0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa" IN {
    type master;
    file "/var/named/named.ip6.local";
    allow-update { none; };
    };

    zone "255.in-addr.arpa" IN {
    type master;
    file "/var/named/named.broadcast";
    allow-update { none; };
    };

    zone "0.in-addr.arpa" IN {
    type master;
    file "/var/named/named.zero";
    allow-update { none; };
    };
    ---


    The file continues with the zones in the format:
    zone "domainname.com" {
    type master;
    file "/var/named/domainname.com.db";
    };


    # cat /etc/rndc.conf
    options {
    default-server localhost;
    default-key "key";
    };

    server localhost {
    key "key";
    };

    key "key" {
    algorithm hmac-md5;
    secret "[[KEY REMOVED ON FORUM FOR SECURITY REASONS]]";
    };
    ---

    # cat /etc/rndc.key
    key "key" {
    algorithm hmac-md5;
    secret "[[KEY REMOVED ON FORUM FOR SECURITY REASONS]]";
    };
    ---

    Any help would be appriciated.

    Thanks.

    Joel.
     
  2. JoelP

    JoelP Member

    Joined:
    Oct 2, 2005
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Fixed

    I found the answer on another thread
    For anyone else with this probelm go to
    http://forums.cpanel.net/showthread.php?t=55403

    I'm running centos so this what I did:

    # yum check-update

    # yum update bind-libs

    # service named start


    Joel
     
  3. jameshsi

    jameshsi Well-Known Member

    Joined:
    Oct 22, 2001
    Messages:
    347
    Likes Received:
    0
    Trophy Points:
    16
    Hi!
    1. How do u know if your OS is centos ?
    2. When trying to do
    yum check-update
    it shows:
    # yum check-update
    Gathering header information file(s) from server(s)
    Server: CentOS Linux 3.1 for RHEL3 - Base
    retrygrab() failed for:
    http://mirror.aelix.com/pub/cAos/centos-3/3.1/os/i386/headers/header.info
    Executing failover method
    failover: out of servers to try
    Error getting file http://mirror.aelix.com/pub/cAos/centos-3/3.1/os/i386/headers/header.info
    [Errno 4] IOError: <urlopen error >


     
  4. styer

    styer Member

    Joined:
    Aug 26, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    It works!

    up2date will not run on CentOS.

    I use:

    Code:
    root@x [/scripts]# yum update bind-libs
    Gathering header information file(s) from server(s)
    Server: CentOS-3 - Addons
    Server: CentOS-3 - Base
    Server: CentOS-3 - Extras
    Server: CentOS-3 - Updates
    Finding updated packages
    Downloading needed headers
    Resolving dependencies
    Dependencies resolved
    I will do the following:
    [update: bind-libs 20:9.2.4-14_EL3.i386]
    Is this ok [y/N]: y
    Downloading Packages
    Getting bind-libs-9.2.4-14_EL3.i386.rpm
    bind-libs-9.2.4-14_EL3.i3 100% |=========================| 548 kB    00:00
    Running test transaction:
    Test transaction complete, Success!
    bind-libs 100 % done 1/2
    Completing update for bind-libs  - 2/2
    Updated:  bind-libs 20:9.2.4-14_EL3.i386
    Transaction(s) Complete
    root@x [/scripts]# service named start
    Starting named:                                            [  OK  ]
    root@x [/scripts]#
    
    :D
     
  5. websupport

    websupport Well-Known Member

    Joined:
    Jun 24, 2006
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    6
    For CentOS

    You will get details about your OS in red-hat release file.

    For CentOS Use Following command :

    yum upgrade bind-libs
    service named start

    :)
     
Loading...

Share This Page