Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot update kernel through yum

Discussion in 'General Discussion' started by gfserver, Aug 22, 2017.

Tags:
  1. gfserver

    gfserver Registered

    Joined:
    Feb 18, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello, I've been searching with no luck about this.

    I have a WHM/cPanel VPS and I received an email indicating that my kernel is out of date:

    The system kernel is at version “2.6.32-642.15.1.el6.x86_64”, but an update is available: 2.6.32-696.6.3.el6.x86_64 Update the system (run “yum -y update” on the command line)

    But, whe I run "yum update" I'm getting this error message:

    "ERROR with rpm_check_debug vs depsolve:
    ImageMagick = 6.9.2-0 is needed by (installed) ImageMagick-devel-6.9.2-0.x86_64
    ** Found 7 pre-existing rpmdb problem(s), 'yum check' output follows:
    ImageMagick-devel-6.9.2-0.x86_64 has missing requires of ImageMagick = ('0', '6.9.2', '0')
    ImageMagick-devel-6.9.2-0.x86_64 has missing requires of ImageMagick-libs = ('0', '6.9.2', '0')
    ImageMagick-devel-6.9.2-0.x86_64 has missing requires of OpenEXR-devel
    ImageMagick-devel-6.9.2-0.x86_64 has missing requires of lcms2-devel
    ImageMagick-devel-6.9.2-0.x86_64 has missing requires of libMagickCore-6.Q16.so.2()(64bit)
    ImageMagick-devel-6.9.2-0.x86_64 has missing requires of libMagickWand-6.Q16.so.2()(64bit)
    ImageMagick-devel-6.9.2-0.x86_64 has missing requires of libwebp-devel
    Your transaction was saved, rerun it with:
    yum load-transaction /tmp/yum_save_tx-2017-08-22-17-38CaigIl.yumtx"

    I'm a newbie, any help please?

    Kind Regards
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,165
    Likes Received:
    1,371
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    It looks like your system package manager (YUM) is unable to successfully update due to missing ImageMagick RPMs. Could you run the below command and let us know the output?

    Code:
    yum info ImageMagick|grep Repo
    yum info ImageMagick-devel|grep Repo
    Also, if you want a temporary workaround until you can resolve the issue with your ImageMagick RPMs, simply append the following entry to the "Exclude=" line in your system's /etc/yum.conf file:

    Code:
    ImageMagick*
    Then, run the "yum update" command to update your kernel.

    Thank you.
     
  3. gfserver

    gfserver Registered

    Joined:
    Feb 18, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello, many thanks for yout answer

    The output is:

    Code:
    root@server2 [~]# yum info ImageMagick|grep Repo
    Repo        : installed
    Repo        : base
    Repo        : base
    root@server2 [~]# yum info ImageMagick-devel|grep Repo
    Repo        : installed
    Repo        : base
    root@server2 [~]#
    
    I added

    Exclude=ImageMagick*

    To the /etc/yum.conf file

    When I ran yum -y update the output was
    Code:
    root@server2 [~]# yum -y update
    Loaded plugins: fastestmirror, security, tsflags, universal-hooks
    Setting up Update Process
    Loading mirror speeds from cached hostfile
     * cpanel-addons-production-feed: 50.115.17.252
     * base: mirror.es.its.nyu.edu
     * extras: ftp.usf.edu
     * updates: mirror.atlantic.net
    Resolving Dependencies
    --> Running transaction check
    ---> Package dovecot.x86_64 0:2.2.31-1.cp1162 will be updated
    --> Processing Dependency: dovecot = 2.2.31-1.cp1162 for package: dovecot-xaps-2.2.31-1.cp1162.x86_64
    ---> Package dovecot.x86_64 1:2.0.9-22.el6 will be an update
    --> Finished Dependency Resolution
    Error: Package: dovecot-xaps-2.2.31-1.cp1162.x86_64 (installed)
               Requires: dovecot = 2.2.31-1.cp1162
               Removing: dovecot-2.2.31-1.cp1162.x86_64 (installed)
                   dovecot = 2.2.31-1.cp1162
               Updated By: 1:dovecot-2.0.9-22.el6.x86_64 (base)
                   dovecot = 1:2.0.9-22.el6
     You could try using --skip-broken to work around the problem
    ** Found 7 pre-existing rpmdb problem(s), 'yum check' output follows:
    ImageMagick-devel-6.9.2-0.x86_64 has missing requires of ImageMagick = ('0', '6.9.2', '0')
    ImageMagick-devel-6.9.2-0.x86_64 has missing requires of ImageMagick-libs = ('0', '6.9.2', '0')
    ImageMagick-devel-6.9.2-0.x86_64 has missing requires of OpenEXR-devel
    ImageMagick-devel-6.9.2-0.x86_64 has missing requires of lcms2-devel
    ImageMagick-devel-6.9.2-0.x86_64 has missing requires of libMagickCore-6.Q16.so.2()(64bit)
    ImageMagick-devel-6.9.2-0.x86_64 has missing requires of libMagickWand-6.Q16.so.2()(64bit)
    ImageMagick-devel-6.9.2-0.x86_64 has missing requires of libwebp-devel
    root@server2 [~]#
    
    Then I enetered

    yum -y update --skip-broken

    And the kernel and several things was updated. Rebooted and all is going fine

    But I now have two errors with yum -y update:
    Code:
    Error: Package: dovecot-xaps-2.2.31-1.cp1162.x86_64 (installed)
               Requires: dovecot = 2.2.31-1.cp1162
               Removing: dovecot-2.2.31-1.cp1162.x86_64 (installed)
                   dovecot = 2.2.31-1.cp1162
               Updated By: 1:dovecot-2.0.9-22.el6.x86_64 (base)
                   dovecot = 1:2.0.9-22.el6
     You could try using --skip-broken to work around the problem
    ** Found 7 pre-existing rpmdb problem(s), 'yum check' output follows:
    ImageMagick-devel-6.9.2-0.x86_64 has missing requires of ImageMagick = ('0', '6.9.2', '0')
    ImageMagick-devel-6.9.2-0.x86_64 has missing requires of ImageMagick-libs = ('0', '6.9.2', '0')
    ImageMagick-devel-6.9.2-0.x86_64 has missing requires of OpenEXR-devel
    ImageMagick-devel-6.9.2-0.x86_64 has missing requires of lcms2-devel
    ImageMagick-devel-6.9.2-0.x86_64 has missing requires of libMagickCore-6.Q16.so.2()(64bit)
    ImageMagick-devel-6.9.2-0.x86_64 has missing requires of libMagickWand-6.Q16.so.2()(64bit)
    ImageMagick-devel-6.9.2-0.x86_64 has missing requires of libwebp-devel
    
    Any ideas?
    Thank you!!!
     
    #3 gfserver, Aug 24, 2017
    Last edited by a moderator: Aug 24, 2017
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,165
    Likes Received:
    1,371
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Could you open a support ticket using the link in my signature so we can take a closer look at the affected system?

    Thank you.
     
Loading...

Share This Page