The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot update to latest EDGE

Discussion in 'General Discussion' started by irchs, Feb 17, 2005.

  1. irchs

    irchs Well-Known Member

    Joined:
    Jun 3, 2004
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    I am on FC3 x86_64, and I cannot update to the very latest edge build.

    As of this time, when I try to update to the latest edge build, WHM downloads the following version:

    Installed Version: 10.0.0-CURRENT_43
    Newest Version: 10.0.0-EDGE_42

    When in the changelog, we have the following version:

    10.0.0 (build 106) - EDGE Tree

    I could really use some of the fixes mentioned in the later egde builds, yet I can't update to it. Is this a deliberate thing, or a mistake by the WHM developers?!

    Thanks

    Jan
     
  2. cPanelBilly

    cPanelBilly Guest

    Fedora Core 3 is not supported.
     
  3. irchs

    irchs Well-Known Member

    Joined:
    Jun 3, 2004
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    oh dont fob me off with that. FC3 is identical to 2, just need to disable SELINUX.

    I can update fine to the latest edge on i386, and thats FC3 too.

    CPanel runs fine on FC3.

    Jan
     
  4. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
    Although billy is correct (cPanel won't support non-supported O/S's) You could try the following;

    1. Check /etc/cpupdate.conf and ensure CPANEL=manual-edge

    2. In /usr/local/cpanel move the version file to version2

    For each of those try to do /scripts/upcp --force
     
  5. irchs

    irchs Well-Known Member

    Joined:
    Jun 3, 2004
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    A appreciate the reason for not offering support for non-supported OS's, but for more experienced admins, they can at least ignore the fact that I am on 3, and pretend I am on 2 or something, since they are both near enough identical.

    Anyway, thanks for your suggestions, I shall try them now :)

    Jan
     
  6. irchs

    irchs Well-Known Member

    Joined:
    Jun 3, 2004
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    I tried both of those, but no joy :(

    I take it this isn't meant to happen?!

    Jan
     
  7. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
    Should not happen that I am aware of....

    Try one more thing.

    Change to Release, upcp, then back to Edge, upcp.

    Sometimes going back then forward again works. (I know makes no sense. :) )
     
  8. irchs

    irchs Well-Known Member

    Joined:
    Jun 3, 2004
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    I have tried that.

    Anything else you can suggest?!

    Jan
     
  9. BenThomas

    BenThomas Well-Known Member

    Joined:
    Feb 12, 2004
    Messages:
    598
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Houston, Texas USA
    cPanel Access Level:
    Root Administrator
    10.0.0-EDGE_42 is the latest Edge release for x86_64. x86_64 builds are on a seperate tree. http://layer2.cpanel.net has the matrix of latest builds for each tree.
     
  10. gorilla

    gorilla Well-Known Member

    Joined:
    Feb 3, 2004
    Messages:
    699
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Sydney / Australia
    hehe too funny , for an experienced sysadmin you lack the reading ability ! :D


    Linux x86-64

    STABLE
    9.9.8-STABLE_16
    (Fri Oct 22 18:30:59 2004)

    RELEASE
    10.0.0-RELEASE_11
    (Wed Jan 19 17:58:01 2005)

    CURRENT
    10.0.0-CURRENT_43
    (Mon Jan 24 22:59:22 2005)

    EDGE
    10.0.0-EDGE_42
    (Mon Jan 24 22:33:32 2005)


    So as cpanelben pointed out, seems that you'r up to date ! :)
     
  11. irchs

    irchs Well-Known Member

    Joined:
    Jun 3, 2004
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    hhmmm... I see. Its a bit strange keeping scripts in two seperate trees, but I guess it eases some confusion.

    How long is the shift between the two builds, cause I could really use the MySQL 4.1 tweaks :)

    Jan
     
Loading...

Share This Page