Operating System & Version
CentOS Linux release 7.8.2003
cPanel & WHM Version
11.88.0.2

mr_xero

Member
Nov 13, 2018
5
0
1
Dhaka
cPanel Access Level
Root Administrator
Hi,
Getting emails that "cPanel & WHM update failure in upcp script"
And when i trying to upgrade from SSH executing command:

Code:
/scripts/upcp --force
Update stopped and return error:

Code:
----------------------------------------------------------------------------------------------------
=> Log opened from cPanel Update (upcp) - Slave (63521) at Thu May 14 11:00:35 2020
[2020-05-14 11:00:35 +0300]   Detected cron=0 (--force passed on command line)
[2020-05-14 11:00:35 +0300]   1% complete
[2020-05-14 11:00:35 +0300]   Running Standardized hooks
[2020-05-14 11:00:35 +0300]   2% complete
[2020-05-14 11:00:35 +0300]   mtime on upcp is 1586884305 (Tue Apr 14 20:11:45 2020)
----------------------------------------------------------------------------------------------------
=> Log opened from /usr/local/cpanel/scripts/updatenow (63523) at Thu May 14 11:00:36 2020
[2020-05-14 11:00:36 +0300]   Running version '11.88.0.2' of updatenow.
[2020-05-14 11:00:36 +0300]   Detected version '11.88.0.2' from version file.
[2020-05-14 11:00:36 +0300]   --force passed on command line. Upgrade will disregard update config settings.
[2020-05-14 11:00:36 +0300]   Target version set to '11.86.0.20'
[2020-05-14 11:00:36 +0300] E Blocker found: A major version downgrade from 11.88.0.2 to 11.86.0.20 is not allowed.
[2020-05-14 11:00:36 +0300] E The install encountered a fatal error: A major version downgrade from 11.88.0.2 to 11.86.0.20 is not allowed.
=> Log closed Thu May 14 11:00:36 2020
[2020-05-14 11:00:36 +0300]   17% complete
Server is in production mode, please help.

Edit: Sorry for the title, i cannot edit that. It's WHM not WHMCS.
 
Last edited:

GOT

Get Proactive!
PartnerNOC
Apr 8, 2003
1,739
301
363
Chesapeake, VA
cPanel Access Level
DataCenter Provider
Did you switch your server to stable from release or something like that? The error indicates it's trying to downgrade from 88 to 86 which is not possible.

I would verify that your channel is set to release.
 

directory92

Member
Dec 30, 2015
7
2
3
Lahore, Pakistan
cPanel Access Level
Root Administrator
I am also having same issue

ERROR:

[2020-05-15 11:19:18 +0500] Detected cron=0 (--force passed on command line)
----------------------------------------------------------------------------------------------------
=> Log opened from cPanel Update (upcp) - Slave (23935) at Fri May 15 11:19:18 2020
[2020-05-15 11:19:18 +0500] Detected cron=0 (--force passed on command line)
[2020-05-15 11:19:18 +0500] 1% complete
[2020-05-15 11:19:18 +0500] Running Standardized hooks
[2020-05-15 11:19:18 +0500] 2% complete
[2020-05-15 11:19:18 +0500] mtime on upcp is 1582159226 (Thu Feb 20 05:40:26 2020)
----------------------------------------------------------------------------------------------------
=> Log opened from /usr/local/cpanel/scripts/updatenow (23938) at Fri May 15 11:19:18 2020
[2020-05-15 11:19:18 +0500] Running version '11.88.0.2' of updatenow.
[2020-05-15 11:19:18 +0500] Detected version '11.88.0.2' from version file.
[2020-05-15 11:19:18 +0500] --force passed on command line. Upgrade will disregard update config settings.
[2020-05-15 11:19:18 +0500] Target version set to '11.86.0.20'
[2020-05-15 11:19:18 +0500] E Blocker found: A major version downgrade from 11.88.0.2 to 11.86.0.20 is not allowed.
[2020-05-15 11:19:18 +0500] E The install encountered a fatal error: A major version downgrade from 11.88.0.2 to 11.86.0.20 is not allowed.
=> Log closed Fri May 15 11:19:18 2020
[2020-05-15 11:19:18 +0500] 17% complete
[2020-05-15 11:19:18 +0500] E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1589523558.log --force` failed, exited with code 5 (signal = 0)
=> Log closed Fri May 15 11:19:19 2020
=> Log closed Fri May 15 11:19:19 2020
[[email protected] ~]#
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,252
313
Houston
This isn't an update error - this is in both instances here an error as a result of an attempt to downgrade. It's clearly noted in the error as well:

Code:
[2020-05-15 11:19:18 +0500] E Blocker found: A major version downgrade from 11.88.0.2 to 11.86.0.20 is not allowed.
[2020-05-15 11:19:18 +0500] E The install encountered a fatal error: A major version downgrade from 11.88.0.2 to 11.86.0.20 is not allowed.
As noted by @GOT did you attempt to change tiers? cPanel does not support downgrades of major versions.