Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Cannot write files after upgrade

Discussion in 'EasyApache' started by Liam McArthur, Jan 31, 2018.

Tags:
  1. Liam McArthur

    Liam McArthur Registered

    Joined:
    Jan 31, 2018
    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    United Kingdom
    cPanel Access Level:
    Root Administrator
    I'm experiencing a problem on my Centos 6.9 server. I've used EasyApache 4 to enable HTTP2 support, but to do this I've had to remove the mod_mpm_prefork and enable either mod_mpm_worker. The install went smoothly and all of my websites appear to be working fine, but all have lost the ability to write new files (e.g. WordPress updates, adding images etc).

    I did some research and was told that the issue was SELinux, but what I don't understand it when I revert my changes and re-enable the prefork, it works fine again. Does anybody have any suggestions on what could be causing the issue? I did contact my server hosting company who provide support for my server, but all they did was chmod 777 my uploads directory which is not what I want at all.

    Many thanks!
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    41,516
    Likes Received:
    1,616
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Liam McArthur likes this.
  3. Liam McArthur

    Liam McArthur Registered

    Joined:
    Jan 31, 2018
    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    United Kingdom
    cPanel Access Level:
    Root Administrator
    That was my problem. I was still using CGI as my PHP handler. I've changed this globally to PHP-FPM and it is working perfectly. Many thanks for this fast response - it means a lot!
     
    #3 Liam McArthur, Feb 1, 2018
    Last edited: Feb 1, 2018
    cPanelMichael likes this.
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    41,516
    Likes Received:
    1,616
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    I'm glad to see that helped. Thank you for sharing the outcome.
     
Loading...

Share This Page