Can't access CPanel over some ISPs

YaddyVirus

Registered
Apr 19, 2020
1
0
0
New Delhi, India
cPanel Access Level
Root Administrator
So I've just discovered a big problem with GoDaddy/CPanel and It's making me want to bang my head against the wall.



No matter what I do, I can't seem to access my CPanel. I have been given delegate access from my client. I log into my account, go to Delegate access and then access my client's account. Afterward, when I click on the Manage button in the hosting tab, it just does nothing. It keeps on loading until I get this error. I'm attaching all relevant screenshots.


Screenshot from 2020-04-20 06-23-30.png


I tried contacting GoDaddy Support but obviously to no avail. However, when I try accessing the CPanel through Mobile Hotspot from my phone, it loads up just fine. But that's no good as well as I keep getting an IP address changed error and keep getting logged out. I tried using a VPN, it didn't work. I tried using Tor, GoDaddy won't even let me log in there.

I can't do any work on the server, can't upload/update my site. Please help me with this or at the very least, tell me what the problem is so that I can go find a fix myself.
 

Attachments

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,252
313
Houston
It sounds a lot like your IP address is blocked. Especially if you're able to access using the phone's mobile hotspot. I hate to tell you this but there's nothing we can do to help, besides tell you to access from a different IP address.

If you can access from a different IP address like your mobile phone's hotspot, you'd want to disable cPhulk and any firewall software that might be present on the server then attempt to log in again. If it fails the only solution is to go through GoDaddy's support.