The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

can't access cpanel using /cpanel, only direct port? https not working

Discussion in 'General Discussion' started by jacksony, Jan 16, 2006.

  1. jacksony

    jacksony Well-Known Member
    PartnerNOC

    Joined:
    Nov 30, 2005
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    Hi, I have a serious problem here.

    Problem 1

    I am able to access my cpanel and whm directly using direct ports at http://www.apc.sg:2082 and http://www.apc.sg:2086 respectively. however when I tried to access using http://www.apc.sg/cpanel or /whm, it returns 'page not found error'.

    Problem 2

    Also, I have installed all the relevant SSL modules, openssl, curl with ssl. And I even has a SSL installed on my server. But the problem is when I try to access using https://www.apc.sg:2083 or :2087, it returns page not found at all.

    I can access my ssl site at https://www.apc.sg/ but when I try to access SSL of cpanel or whm, it just returns page not found. anyone has this problem can enlighten me? Thank you very much!
     
  2. jacksony

    jacksony Well-Known Member
    PartnerNOC

    Joined:
    Nov 30, 2005
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    I am using cpanel on redhat 9.
     
  3. jacksony

    jacksony Well-Known Member
    PartnerNOC

    Joined:
    Nov 30, 2005
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    This is my recompile of apache. could it be any of the error below that is leading to the problem above?

    "/etc/rc.d/init.d/httpd start: httpd started
    Setting /home permissions to 0711......Done
    Setting permissions
    17:49:04 URL:http://layer1.cpanel.net/buildapache/1/libmcrypt-2.5.7.tar.gz [5233 21/523321] -> "libmcrypt-2.5.7.tar.gz" [1]
    Untarring mcryptDone
    configure libmcrypt-2.5.7...(--prefix=/usr --disable-posix-threads)............. .....................Done
    make -j 4 libmcrypt-2.5.7....................................................... .............................Done
    make libmcrypt-2.5.7...(install)........Done
    17:51:03 URL:http://layer1.cpanel.net/buildapache/1/mhash-0.8.18.tar.gz [347483/ 347483] -> "mhash-0.8.18.tar.gz" [1]
    Untarring mhashDone
    configure mhash-0.8.18...(--prefix=/usr)........................................ .Done
    make -j 4 mhash-0.8.18...........................Done
    make mhash-0.8.18...(install).....Done
    17:52:09 URL:http://layer1.cpanel.net/buildapache/1/curl-7.12.0.tar.gz [1520041/ 1520041] -> "curl-7.12.0.tar.gz" [1]
    Untarring curl......Done
    configure curl-7.12.0...(--prefix=/usr)......................................... ...................................................Done
    make -j 4 curl-7.12.0........................................................... ........Done
    make curl-7.12.0...(install).........Done
    Untarring imap....Using RPM Backend: RPM version 4.2
    installed: imap-devel-2001a-18.1.rh9.swsoft
    ln: `c-client.a': File exists
    Using RPM Backend: RPM version 4.2
    installed: gettext-0.11.4-7.2.legacy
    17:55:15 URL:http://layer1.cpanel.net/buildapache/1/php-4.4.1.tar.gz [5110458/51 10458] -> "php-4.4.1.tar.gz" [1]
    Untarring php....Done
    Applying CURL curl_formfree patch
    patching file ext/curl/curl.c
    Hunk #1 succeeded at 590 (offset 45 lines).
    Hunk #2 succeeded at 904 (offset 19 lines).
    configure php-4.4.1...(--with-apxs=/usr/local/apache/bin/apxs --prefix=/usr/loca l --with-xml --enable-bcmath --enable-calendar --with-curl --enable-exif --enabl e-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/u sr/X11R6 --with-gettext --with-imap --with-imap-ssl --with-kerberos --enable-mbs tring --enable-mbstr-enc-trans --enable-mbregex --with-mcrypt --with-mhash --ena ble-magic-quotes --with-mysql=/usr --with-openssl --enable-discard-path --with-p ear --enable-sockets --enable-track-vars --enable-versioning --with-zlib)....... ................................................................................ ..........Done
    configure: error: build test failed. Please check the config.log for details.
    make -j 4 php-4.4.1...(clean)....Done
    Can't open Makefile: No such file or directory.
    make -j 4 php-4.4.1.......Done
    make php-4.4.1...(install)....Done
    /etc/rc.d/init.d/httpd start: httpd started
    configure php-4.4.1...(--prefix=/usr --with-xml --enable-bcmath --enable-calenda r --with-curl --enable-exif --enable-ftp --with-gd --with-jpeg-dir=/usr/local -- with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --with-gettext --with-imap --with-im ap-ssl --with-kerberos --enable-mbstring --enable-mbstr-enc-trans --enable-mbreg ex --with-mcrypt --with-mhash --enable-magic-quotes --with-mysql=/usr --with-ope nssl --enable-discard-path --with-pear --enable-sockets --enable-track-vars --en able-versioning --with-zlib).................................................... .............Done
    configure: error: build test failed. Please check the config.log for details.
    make -j 4 php-4.4.1...(clean)....Done
    Can't open Makefile: No such file or directory.
    make -j 4 php-4.4.1.......Done
    make php-4.4.1...(install)....Done
    initfpsuexec: using apache 1.x support
    chattr: Inappropriate ioctl for device while reading flags on _vti_bin/fpexe
    chattr: Inappropriate ioctl for device while reading flags on _vti_bin/fpexe
    PHP version file is up to date
    Executing /scripts/postbuildapache (if exists)...Done
    /etc/rc.d/init.d/httpd start: httpd started
    Waiting for httpd to restart..............finished.

    root 4512 0.6 0.0 5628 3332 ? S 17:58 0:00 /usr/local/apache /bin/httpd -DSSL

    httpd started ok"
     
  4. elleryjh

    elleryjh Well-Known Member

    Joined:
    Apr 12, 2003
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
    Do you have this line in your httpd.conf:
    ScriptAlias /cpanel /usr/local/cpanel/cgi-sys/redirect.cgi

    Here are all the redirects that cpanel uses:

    Code:
    ErrorDocument 400 /400.shtml
    ErrorDocument 401 /401.shtml
    ErrorDocument 403 /403.shtml
    ErrorDocument 404 /404.shtml
    ErrorDocument 500 /500.shtml
    ScriptAlias /cgi-sys/ /usr/local/cpanel/cgi-sys/
    Alias /sys_cpanel/ /usr/local/cpanel/sys_cpanel/
    Alias /java-sys/ /usr/local/cpanel/java-sys/
    Alias /img-sys/ /usr/local/cpanel/img-sys/
    Alias /akopia/ /usr/local/cpanel/3rdparty/interchange/share/akopia/
    Alias /neo-images/ /usr/local/cpanel/base/neomail/neo-images/
    ScriptAliasMatch ^/cpanel/(.*) /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /cpanel /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /whm /usr/local/cpanel/cgi-sys/whmredirect.cgi
    ScriptAlias /securewhm /usr/local/cpanel/cgi-sys/swhmredirect.cgi
    ScriptAlias /webmail /usr/local/cpanel/cgi-sys/wredirect.cgi
    ScriptAliasMatch ^/webmail/(.*) /usr/local/cpanel/cgi-sys/wredirect.cgi
    ScriptAliasMatch ^/kpanel/(.*) /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /controlpanel /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /securecontrolpanel /usr/local/cpanel/cgi-sys/sredirect.cgi
    Alias /mailman/archives/ /usr/local/cpanel/3rdparty/mailman/archives/public/
    ScriptAlias /mailman/ /usr/local/cpanel/3rdparty/mailman/cgi-bin/
    Alias /pipermail/ /usr/local/cpanel/3rdparty/mailman/archives/public/
    Alias /interchange/ /usr/local/cpanel/3rdparty/interchange/share/interchange/
    Alias /interchange-5/ /usr/local/cpanel/3rdparty/interchange/share/interchange-5/
    
     
  5. jacksony

    jacksony Well-Known Member
    PartnerNOC

    Joined:
    Nov 30, 2005
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    Yes I checked all the lines are there exactly the same.

    The problem is there seems to be a dns error when I access using /cpanel or /whm and not direct port access.
     
  6. elleryjh

    elleryjh Well-Known Member

    Joined:
    Apr 12, 2003
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
    Ok, I see what's going on...


    You have the option alwaysredirecttossl set to 1 in /var/cpanel/cpanel.config so it always sends http://domain.com/cpanel to https://domain.com:2083 - set it to 0 and it will redirect to http://domain.com:2082 and since your ssl for cpanel isn't working for you, it's not working.

    https access to cpanel on your domain is working for me, but appearantly not for you. Try generating a new certificate in WHM, maybe? Not sure why it wouldn't be working for you...
     
  7. jacksony

    jacksony Well-Known Member
    PartnerNOC

    Joined:
    Nov 30, 2005
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    Hi, Thank you so much for your help! Yep https is working for me now but I am not sure what they have done to fix it. I asked them for the solution and hope we can learn from it!

    Btw I will try to change the settings see how it goes. Thank you! :)
     
  8. jacksony

    jacksony Well-Known Member
    PartnerNOC

    Joined:
    Nov 30, 2005
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    Thanks its fixed now! :) But I have another problem.

    My https for cpanel/whm is using different ssl cert from the one i installed for https://www.apc.sg. I don't know how does it happen. is it possible to set cpanel/whm to use the ssl cert i installed for https://www.apc.sg as well?
     
  9. elleryjh

    elleryjh Well-Known Member

    Joined:
    Apr 12, 2003
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
    Go to:
    WHM > SSL/TLS > Change Server Certificates > cPanel/WHM Server
    Type the domain that your certificate is for in the "Domain this CRT is for" box
    Press tab or click on a blank part of the page
    The crt and key should be filled in automatically. If not, check that the domain is exactly the right one, i.e. "www" may or may not be in your certificate.
     
  10. jacksony

    jacksony Well-Known Member
    PartnerNOC

    Joined:
    Nov 30, 2005
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    thank you very much! :) I will try it now~
     
Loading...

Share This Page