The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cant access via ftp

Discussion in 'General Discussion' started by Kelvin_n, Aug 11, 2006.

  1. Kelvin_n

    Kelvin_n Member

    Joined:
    Aug 11, 2006
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    This is what My ftp client tells me.

    R] Connecting to *.*.*.* -> IP=*.*.*.* PORT=21
    [R] Connected to *.*.*.*
    [R] 220 ProFTPD 1.2.10 Server (ProFTPD Default Installation) [*.*.*.*]
    [R] USER ***
    [R] 331 Password required for milsim.
    [R] PASS (hidden)
    [R] 230 User *** logged in.
    [R] SYST
    [R] 215 UNIX Type: L8
    [R] FEAT
    [R] 211-Features:
    [R] MDTM
    [R] REST STREAM
    [R] SIZE
    [R] AUTH TLS
    [R] PBSZ
    [R] PROT
    [R] 211 End
    [R] PWD
    [R] 257 "/" is current directory.
    [R] TYPE A
    [R] 200 Type set to A
    [R] PASV
    [R] 227 Entering Passive Mode (*,*,*,*,128,222).
    [R] Opening data connection IP: *.*.*.* PORT: 32990
    [R] Data Socket Error: No route to Host
    [R] List Error
    [R] PASV
    [R] 227 Entering Passive Mode (*,*,*,*,128,223).
    [R] Opening data connection IP: *.*.*.* PORT: 32991

    I have tried with both Pureftp and proftpd.

    My best guess it that it opens dataconnection on a random port for security issues. How ever that would mess up my firewall rules.

    Any one have a good idea of how to get me started on putting files up.
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Try switching off passive (PASV) mode in your FTP client.
     
  3. mehrdad abed

    mehrdad abed Well-Known Member

    Joined:
    Mar 18, 2006
    Messages:
    127
    Likes Received:
    0
    Trophy Points:
    16
    if you are using port filtering on your server, try to open the passive ftp port rang in OUTPUT rules.
     
  4. Kelvin_n

    Kelvin_n Member

    Joined:
    Aug 11, 2006
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    thansk for the help guys. Both solutios did the trick. Gonna keep the passive port range open so that my future clients dont have to mess about in their settings.
     
Loading...

Share This Page