The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't access Webmail through mydomain.com/webmail

Discussion in 'E-mail Discussions' started by Wwhite720, Apr 18, 2007.

  1. Wwhite720

    Wwhite720 Registered

    Joined:
    Apr 18, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I setup a website a couple of months ago for the company I work for. It is very simple and basically there to provide general company information.

    The problem I am having is that I can't access web mail through www.mydomain.com/webmail. The only way for me to access it is to enter the IP directly, followed by /webmail.

    This is the error I receive when trying to access web mail through the domain name

    After getting the above error, I tried setting up a Forwarder through cPanel to direct MyDomain/webmail to My IP/webmail. I could not get this to work either.

    Also,
    It was suggested that I try adding port 2095 to the end of the URL. This did not help either and I get the following

    www.klwood.com:2095 - Problem loading page, unable to connect.

    This would generally make me think it was a problem on my end, but I can access the web mail for my personal site with no problems (also hosted by midphase)

    The only difference between the two sites is that the Personal site is Windows based and klwood is Linux

    I use Firefox as my default browser, but tried IE as well with the same result.

    I have searched the forums and could not find a potential solution to my problem. Would someone lend me a hand, as I am sure it is something simple that I have overlooked.

    Thanks
    -Walt
     
  2. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    765
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    N.W. Iowa
    make sure you have the following lines(usually toward the bottom), in your httpd.conf file
    Code:
    ScriptAlias /webmail /usr/local/cpanel/cgi-sys/wredirect.cgi
    ScriptAliasMatch ^/webmail/(.*) /usr/local/cpanel/cgi-sys/wredirect.cgi
    
    Mickalo
     
  3. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    765
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    N.W. Iowa
    by default, for cpanel machines, it's located in the /usr/local/apache/conf folder ... httpd.conf

    Mickalo
     
  4. Wwhite720

    Wwhite720 Registered

    Joined:
    Apr 18, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    mickalo,

    I have looked through my directory and can't seem to find that file.

    Is there any chance that it would be named differently or have a specific file path?

    Thanks
     
  5. Wwhite720

    Wwhite720 Registered

    Joined:
    Apr 18, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    It seems as though this must be a problem with my local machine.

    I just jumped onto another office pc and I have no problem accessing the webmail.

    Thanks for the help
     
  6. david510

    david510 Well-Known Member

    Joined:
    Aug 22, 2004
    Messages:
    473
    Likes Received:
    0
    Trophy Points:
    16
    Turn off the firewall in your local machine and have a try. It may be that the port 2095 is blocked in your local PC.
     
  7. Wwhite720

    Wwhite720 Registered

    Joined:
    Apr 18, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    David,

    Adding port 2095 to my exceptions list corrected the problem.

    The strange thing is that I could access the webmail on port 2095 for my personal site, just not the company site. Now that the exception is added I can access both webmail login screens on both sites (although I could already access one of them previously).

    Thanks for the suggestion
    -Walt
     
Loading...

Share This Page