The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't Add Addon Domain (1 Solution Inside!)

Discussion in 'General Discussion' started by randomuser, Nov 18, 2005.

  1. randomuser

    randomuser Well-Known Member

    Joined:
    Jun 25, 2005
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    Can't Add Addon Domain (1 (New?) Solution Inside!)

    I haven't seen this solution posted yet, so have at it.

    Problem: customer attempting to add an Addon Domain via cPanel and running into issues about "user does not control this domain", or some other random error (I saw at least 2 different errors while trying to add this domain).

    Solution: ask if the user is adding their domain using uppercase and lowercase (ie: My-Domain.com). If so, you may need to do the following before readding the domain in ALL lowercase via Addon Domains from within cPanel. Use lowercase in both the Domain Name: fields and the Username/directory/subdomain Name: field



    grep -i domain /etc/localdomains (remove entries with vi)
    grep -i domain /etc/userdomains (remove entries with vi)
    grep -i domain /etc/named.conf (if an entry exists, this will be removed when you remove the zone via WHM)
    ls -lsa /var/named/|grep -i domain (if an entry exists, this will be removed when you remove the zone via WHM)
    grep -i domain /var/named/PRIMARYCUSTOMERDOMAIN.com.db
    * edit PRIMARYCUSTOMERDOMAIN.com zone via WHM (remove lingering entries for the subdomain)
    grep -i domain /usr/local/apache/conf/httpd.conf (nothing should exist)
    grep -i domain /var/cpanel/users/username (remove all entries with vi)
    ls -lsa /home/user/www/domain-dir/ (if this exists, rename it using the command below)
    mv /home/user/www/domain-dir /home/user/www/domain-dir.old

    or just rm it


    Hope this helps someone resolve this odd issue.


    update: wow, or you could just tell the user to use all lowercase and not do all the above steps. Seems to be working so far. gah


    If this helps you, please vote on bug 3534:
    http://bugzilla.cpanel.net/show_bug.cgi?id=3534
     
    #1 randomuser, Nov 18, 2005
    Last edited: Nov 23, 2005
Loading...

Share This Page