The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't add http auth user (password protect directories)

Discussion in 'General Discussion' started by erinspice, May 15, 2007.

  1. erinspice

    erinspice Well-Known Member

    Joined:
    Feb 12, 2006
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    16
    Hi, a client is having the following problem: He has several nested subdirectories, some of whose names contain spaces. When he tries to password protect a directory where there is a space in the path, he can successfully turn on the option to require a password (the checkbox at the top), but he cannot add a user/password and gets this error, which contains an incorrect path from which all the spaces have been stripped.

    For instance, if the path should be /home/username/public_html/foo bar/, cPanel is looking for /home/username/public_html/foobar/ with no spaces, and of course, not finding it. How can I fix this?
     
  2. erinspice

    erinspice Well-Known Member

    Joined:
    Feb 12, 2006
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    16
    The customer, since reporting the initial error, has informed me that this used to work with these same directories a year ago, and sometime at the end of 2006 it stopped working. Does anyone know anything about this?
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Sounds like a bug in the cPanel code if it's stripping out the spaces through the UI. You should log a bugzilla entry with details on how to recreate the problem. In the meantime, they'll have to update the .htpasswd and .htaccess files manually.
     
  4. cPDan

    cPDan cPanel Staff
    Staff Member

    Joined:
    Mar 9, 2004
    Messages:
    711
    Likes Received:
    3
    Trophy Points:
    18
    Just to let you know that I'm looking into the code for this now. Thanks for the info! I'll let you know how it comes along :)
     
  5. cPDan

    cPDan cPanel Staff
    Staff Member

    Joined:
    Mar 9, 2004
    Messages:
    711
    Likes Received:
    3
    Trophy Points:
    18
    Hello again,

    I'm having difficulty reproducing that exactly, I did discover this on my test server:

    http://bugzilla.cpanel.net/show_bug.cgi?id=5469

    but its not the same issue really.

    Coulds you create a support ticket at support.cpanel.net and make it "ATTN: Dan" and mention this forum URL in it so I can take a look at the problem?

    Thanks!
     
  6. cPDan

    cPDan cPanel Staff
    Staff Member

    Joined:
    Mar 9, 2004
    Messages:
    711
    Likes Received:
    3
    Trophy Points:
    18
  7. karlos

    karlos Member

    Joined:
    Oct 1, 2003
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    0
    Hello cpdan,

    I have CPanel 10.9.1-STABLE 14304 and when I try to create a user for a protected folder, in the "Password Protect Directories" of Cpanel X, I get the same error. :confused:

     
Loading...

Share This Page