Can't connect to SMTP from WordPress, WHMCS or other software.

inteldigital

Well-Known Member
Apr 5, 2018
87
15
8
England
cPanel Access Level
Root Administrator
Twitter
Hi,

I have this weird issue. I can't seem to connect to SMTP from WHMCS, or WordPress (for example) to send an email. It's just not connecting. All settings are correct. Port for SSL, correct. Is there any setting in exim I should be aware of that could cause this? I've tried disabling stuff like "Prevent user nobody from sending mail", the SMTP delay, weak ciphers etc. literally nothing works and cPanel Support have been more than useless.

Anybody got any suggestions?

Thanks
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,271
313
Houston
I'm sorry to hear that you feel our support hasn't been helpful. I found your ticket today and it would appear that the last response indicates that there was a misconfiguration of the SMTP settings per the documentation provide by WHMCS:

========================================================================

It seems that the WHMCS Email Settings you had configured were the following:
====
Mail Type SMTP
Mail Encoding 8bit
SMTP Port 465
SMTP Host localhost
SMTP Username [email protected]
SMTP Password <encrypted>
SMTP SSL Type SSL
====

According to WHMCS Email Setup Guide: https://help.whmcs.com/m/system/l/784309-configuring-whmcs-to-use-smtp Port 587 should be paired with the SSL setting instead of 465.

A continued review may likely require WHMCS Support's attention, are you be able to create a ticket with them using the following URL: https://www.whmcs.com/submit-a-ticket/
========================================================================

Were you able to get this functioning?