glupav

Active Member
Oct 6, 2012
34
0
6
cPanel Access Level
Root Administrator
I have a Joomla plugin that sends mail.
(everything is OK with the plugin cause I've checked it with Yahoo! SMTP server)

When I try to connect to some of my SMTP servers on my dedicated server it says

Code:
SMTP Error: Could not connect to SMTP host. | 
SMTP -> ERROR: Password not accepted from server: 535 Incorrect authentication data
(I guess that is an error code from the plugin)

I've triple-checked passwords and they are all fine.

Any suggestions???

NOTE: The isuue is with all SMTP servers on my dedicated server.
It worked fine till week ago and nothing was changed previously.
(ok i admit phpMyAdmin root password was set up but ??? )
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,911
2,233
363
cPanel Access Level
DataCenter Provider
Twitter
Hello :)

Are you attempting to connect to the local server to send email, or are using Joomla on a remote server to send via SMTP on another server? If Joomla is connecting to the local server via SMTP, check to make sure the domain name is in the following file:

Code:
/etc/localdomains
Thank you.
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,911
2,233
363
cPanel Access Level
DataCenter Provider
Twitter
Check to see if the email account is blocked by cPHulk:

"WHM Home » Security Center » cPHulk Brute Force Protection"

The Login/Brute History Report should list the email account if it's been blocked.

Thank you.
 

glupav

Active Member
Oct 6, 2012
34
0
6
cPanel Access Level
Root Administrator
I constantly log in with the root account.
My IP is whitelisted.
email account is not blocked by cPHulk.

Any other suggestions ? ? ?
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,911
2,233
363
cPanel Access Level
DataCenter Provider
Twitter
Please note that logging in as "root" and white listing an IP address will not necessarily prevent an email account from being locked out due to brute force attempts. However, you have stated that it's not listed at all in the cPhulk interface, so that should rule it out as a cause. Please check the following log file when an attempt to send email through the script is made:

Code:
/var/log/exim_mainlog
Do you notice any specific error messages? Also, you did not answer this previous question. Are you attempting to connect to the local server to send email, or are using Joomla on a remote server to send via SMTP on another server?

Thank you.
 

glupav

Active Member
Oct 6, 2012
34
0
6
cPanel Access Level
Root Administrator
The Joomla site and the SMTP server are on the same dedicated server
if that was the question ??? (my poor English)

will be back on you about

/var/log/exim_mainlog
 

glupav

Active Member
Oct 6, 2012
34
0
6
cPanel Access Level
Root Administrator
the following is in the log file after unsuccessful login into SMTP :

Code:
2013-08-16 11:57:03 SMTP connection from [5.9.xxx.xxx]:33716 (TCP/IP connection count = 2)
2013-08-16 11:57:04 courier_login authenticator failed for static.102.100.xxx.xxx.clients.your-server.de (domain2.com) [5.9.xxx.xxx]:33716: 535 Incorrect authentication data ([email protected])
2013-08-16 11:57:04 H=static.102.100.xxx.xxx.clients.your-server.de (domain2.com) [5.9.xxx.xxx]:33716 F=<[email protected]> rejected RCPT <[email protected]>: Please turn on SMTP Authentication in your mail client, or login to the IMAP/POP3 server before sending your message.  static.102.100.xxx.xxx.clients.your-server.de (domain2.com) [5.9.xxx.xxx]:33716 is not permitted to relay through this server without authentication.
2013-08-16 11:57:05 H=static.102.100.xxx.xxx.clients.your-server.de (domain2.com) [5.9.xxx.xxx]:33716 F=<[email protected]> rejected RCPT <[email protected]>: Please turn on SMTP Authentication in your mail client, or login to the IMAP/POP3 server before sending your message.  static.102.100.xxx.xxx.clients.your-server.de (domain2.com) [5.9.xxx.xxx]:33716 is not permitted to relay through this server without authentication.
2013-08-16 11:57:05 H=static.102.100.xxx.xxx.clients.your-server.de (domain2.com) [5.9.xxx.xxx]:33716 F=<[email protected]> rejected RCPT <[email protected]>: Please turn on SMTP Authentication in your mail client, or login to the IMAP/POP3 server before sending your message.  static.102.100.xxx.xxx.clients.your-server.de (domain2.com) [5.9.xxx.xxx]:33716 is not permitted to relay through this server without authentication.
2013-08-16 11:57:05 H=static.102.100.xxx.xxx.clients.your-server.de (domain2.com) [5.9.xxx.xxx]:33716 F=<[email protected]> rejected RCPT <[email protected]>: Please turn on SMTP Authentication in your mail client, or login to the IMAP/POP3 server before sending your message.  static.102.100.xxx.xxx.clients.your-server.de (domain2.com) [5.9.xxx.xxx]:33716 is not permitted to relay through this server without authentication.
2013-08-16 11:57:05 H=static.102.100.xxx.xxx.clients.your-server.de (domain2.com) [5.9.xxx.xxx]:33716 F=<[email protected]> rejected RCPT <[email protected]>: Please turn on SMTP Authentication in your mail client, or login to the IMAP/POP3 server before sending your message.  static.102.100.xxx.xxx.clients.your-server.de (domain2.com) [5.9.xxx.xxx]:33716 is not permitted to relay through this server without authentication.
2013-08-16 11:57:05 SMTP connection from static.102.100.xxx.xxx.clients.your-server.de (domain2.com) [5.9.xxx.xxx]:33716 closed by QUIT
2013-08-16 11:57:05 SMTP connection from [5.9.xxx.xxx]:33717 (TCP/IP connection count = 2)
2013-08-16 11:57:05 courier_login authenticator failed for static.102.100.xxx.xxx.clients.your-server.de (domain2.com) [5.9.xxx.xxx]:33717: 535 Incorrect authentication data ([email protected])
2013-08-16 11:57:05 SMTP connection from static.102.100.xxx.xxx.clients.your-server.de (domain2.com) [5.9.xxx.xxx]:33717 lost
2013-08-16 11:57:20 SMTP connection from 10ibl.datacenter.com.net [200.11.xxx.xxx]:53959 closed by QUIT
2013-08-16 11:59:26 SMTP connection from [59.90.xxx.xxx]:52124 (TCP/IP connection count = 1)
2013-08-16 11:59:26 no host name found for IP address 59.90.xxx.xxx
2013-08-16 11:59:28 1VAGoY-0005dq-O4 <= [email protected] H=([59.90.xxx.xxx]) [59.90.xxx.xxx]:52124 P=esmtp S=8870 [email protected] T="Get Slim! Fast and Safe!" for [email protected]
2013-08-16 11:59:28 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1VAGoY-0005dq-O4
2013-08-16 11:59:28 1VAGoY-0005dq-O4 => contact <[email protected]> R=virtual_user T=virtual_userdelivery
2013-08-16 11:59:28 1VAGoY-0005dq-O4 Completed
2013-08-16 11:59:28 SMTP connection from ([59.90.xxx.xxx]) [59.90.xxx.xxx]:52124 closed by QUIT
2013-08-16 11:59:50 SMTP connection from [5.9.xxx.xxx]:33807 (TCP/IP connection count = 1)
2013-08-16 11:59:50 courier_login authenticator failed for static.102.100.xxx.xxx.clients.your-server.de (aiiconference.net) [5.9.xxx.xxx]:33807: 535 Incorrect authentication data ([email protected])
2013-08-16 11:59:50 SMTP connection from static.102.100.xxx.xxx.clients.your-server.de (aiiconference.net) [5.9.xxx.xxx]:33807 lost
any suggestions ???
 
Last edited by a moderator:

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,911
2,233
363
cPanel Access Level
DataCenter Provider
Twitter
Per the ticket, the issue was resolved by modifying the hostname in the PHP configuration file of the script used for sending email to:

Code:
localhost
Thank you.
 

glupav

Active Member
Oct 6, 2012
34
0
6
cPanel Access Level
Root Administrator
somehow now the SMTP server works
inside settings in the Joomla plugin i put now localhost instead of mail.xxxdomainxxx.xxx
it works now
thanks for the support