The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't connect to SMTP server

Discussion in 'E-mail Discussions' started by glupav, Aug 14, 2013.

  1. glupav

    glupav Active Member

    Joined:
    Oct 6, 2012
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    I have a Joomla plugin that sends mail.
    (everything is OK with the plugin cause I've checked it with Yahoo! SMTP server)

    When I try to connect to some of my SMTP servers on my dedicated server it says

    Code:
    SMTP Error: Could not connect to SMTP host. | 
    SMTP -> ERROR: Password not accepted from server: 535 Incorrect authentication data
    (I guess that is an error code from the plugin)

    I've triple-checked passwords and they are all fine.

    Any suggestions???

    NOTE: The isuue is with all SMTP servers on my dedicated server.
    It worked fine till week ago and nothing was changed previously.
    (ok i admit phpMyAdmin root password was set up but ??? )
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,814
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Are you attempting to connect to the local server to send email, or are using Joomla on a remote server to send via SMTP on another server? If Joomla is connecting to the local server via SMTP, check to make sure the domain name is in the following file:

    Code:
    /etc/localdomains
    Thank you.
     
  3. glupav

    glupav Active Member

    Joined:
    Oct 6, 2012
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    The domain name(s) is(are) allready there ! ! !

    Any other suggestions ? ? ?
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,814
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Check to see if the email account is blocked by cPHulk:

    "WHM Home » Security Center » cPHulk Brute Force Protection"

    The Login/Brute History Report should list the email account if it's been blocked.

    Thank you.
     
  5. glupav

    glupav Active Member

    Joined:
    Oct 6, 2012
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    I constantly log in with the root account.
    My IP is whitelisted.
    email account is not blocked by cPHulk.

    Any other suggestions ? ? ?
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,814
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Please note that logging in as "root" and white listing an IP address will not necessarily prevent an email account from being locked out due to brute force attempts. However, you have stated that it's not listed at all in the cPhulk interface, so that should rule it out as a cause. Please check the following log file when an attempt to send email through the script is made:

    Code:
    /var/log/exim_mainlog
    Do you notice any specific error messages? Also, you did not answer this previous question. Are you attempting to connect to the local server to send email, or are using Joomla on a remote server to send via SMTP on another server?

    Thank you.
     
  7. glupav

    glupav Active Member

    Joined:
    Oct 6, 2012
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    The Joomla site and the SMTP server are on the same dedicated server
    if that was the question ??? (my poor English)

    will be back on you about

    /var/log/exim_mainlog
     
  8. glupav

    glupav Active Member

    Joined:
    Oct 6, 2012
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    the following is in the log file after unsuccessful login into SMTP :

    Code:
    2013-08-16 11:57:03 SMTP connection from [5.9.xxx.xxx]:33716 (TCP/IP connection count = 2)
    2013-08-16 11:57:04 courier_login authenticator failed for static.102.100.xxx.xxx.clients.your-server.de (domain2.com) [5.9.xxx.xxx]:33716: 535 Incorrect authentication data (set_id=info@domain.com)
    2013-08-16 11:57:04 H=static.102.100.xxx.xxx.clients.your-server.de (domain2.com) [5.9.xxx.xxx]:33716 F=<info@domain.com> rejected RCPT <m.dhote@domain.com.in>: Please turn on SMTP Authentication in your mail client, or login to the IMAP/POP3 server before sending your message.  static.102.100.xxx.xxx.clients.your-server.de (domain2.com) [5.9.xxx.xxx]:33716 is not permitted to relay through this server without authentication.
    2013-08-16 11:57:05 H=static.102.100.xxx.xxx.clients.your-server.de (domain2.com) [5.9.xxx.xxx]:33716 F=<info@domain.com> rejected RCPT <m.mathur@domain.com.in>: Please turn on SMTP Authentication in your mail client, or login to the IMAP/POP3 server before sending your message.  static.102.100.xxx.xxx.clients.your-server.de (domain2.com) [5.9.xxx.xxx]:33716 is not permitted to relay through this server without authentication.
    2013-08-16 11:57:05 H=static.102.100.xxx.xxx.clients.your-server.de (domain2.com) [5.9.xxx.xxx]:33716 F=<info@domain.com> rejected RCPT <m.singh@domain.com.in>: Please turn on SMTP Authentication in your mail client, or login to the IMAP/POP3 server before sending your message.  static.102.100.xxx.xxx.clients.your-server.de (domain2.com) [5.9.xxx.xxx]:33716 is not permitted to relay through this server without authentication.
    2013-08-16 11:57:05 H=static.102.100.xxx.xxx.clients.your-server.de (domain2.com) [5.9.xxx.xxx]:33716 F=<info@domain.com> rejected RCPT <mahavir@domain.com.in>: Please turn on SMTP Authentication in your mail client, or login to the IMAP/POP3 server before sending your message.  static.102.100.xxx.xxx.clients.your-server.de (domain2.com) [5.9.xxx.xxx]:33716 is not permitted to relay through this server without authentication.
    2013-08-16 11:57:05 H=static.102.100.xxx.xxx.clients.your-server.de (domain2.com) [5.9.xxx.xxx]:33716 F=<info@domain.com> rejected RCPT <mayank.mathur@domain.com.in>: Please turn on SMTP Authentication in your mail client, or login to the IMAP/POP3 server before sending your message.  static.102.100.xxx.xxx.clients.your-server.de (domain2.com) [5.9.xxx.xxx]:33716 is not permitted to relay through this server without authentication.
    2013-08-16 11:57:05 SMTP connection from static.102.100.xxx.xxx.clients.your-server.de (domain2.com) [5.9.xxx.xxx]:33716 closed by QUIT
    2013-08-16 11:57:05 SMTP connection from [5.9.xxx.xxx]:33717 (TCP/IP connection count = 2)
    2013-08-16 11:57:05 courier_login authenticator failed for static.102.100.xxx.xxx.clients.your-server.de (domain2.com) [5.9.xxx.xxx]:33717: 535 Incorrect authentication data (set_id=info@domain.com)
    2013-08-16 11:57:05 SMTP connection from static.102.100.xxx.xxx.clients.your-server.de (domain2.com) [5.9.xxx.xxx]:33717 lost
    2013-08-16 11:57:20 SMTP connection from 10ibl.datacenter.com.net [200.11.xxx.xxx]:53959 closed by QUIT
    2013-08-16 11:59:26 SMTP connection from [59.90.xxx.xxx]:52124 (TCP/IP connection count = 1)
    2013-08-16 11:59:26 no host name found for IP address 59.90.xxx.xxx
    2013-08-16 11:59:28 1VAGoY-0005dq-O4 <= contact@domain.com H=([59.90.xxx.xxx]) [59.90.xxx.xxx]:52124 P=esmtp S=8870 id=D7248532-03A3-0FF2-B2EA-DB23C22FBA59@ELDONCS T="Get Slim! Fast and Safe!" for contact@emforum.eu
    2013-08-16 11:59:28 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1VAGoY-0005dq-O4
    2013-08-16 11:59:28 1VAGoY-0005dq-O4 => contact <contact@domain.eu> R=virtual_user T=virtual_userdelivery
    2013-08-16 11:59:28 1VAGoY-0005dq-O4 Completed
    2013-08-16 11:59:28 SMTP connection from ([59.90.xxx.xxx]) [59.90.xxx.xxx]:52124 closed by QUIT
    2013-08-16 11:59:50 SMTP connection from [5.9.xxx.xxx]:33807 (TCP/IP connection count = 1)
    2013-08-16 11:59:50 courier_login authenticator failed for static.102.100.xxx.xxx.clients.your-server.de (aiiconference.net) [5.9.xxx.xxx]:33807: 535 Incorrect authentication data (set_id=info@domain.net)
    2013-08-16 11:59:50 SMTP connection from static.102.100.xxx.xxx.clients.your-server.de (aiiconference.net) [5.9.xxx.xxx]:33807 lost
    any suggestions ???
     
    #8 glupav, Aug 16, 2013
    Last edited by a moderator: Aug 16, 2013
  9. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,814
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Feel free to open a support ticket so we can take a closer look:

    Submit A Ticket

    You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  10. glupav

    glupav Active Member

    Joined:
    Oct 6, 2012
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Your Request id is: 4322547.
     
  11. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,814
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Per the ticket, the issue was resolved by modifying the hostname in the PHP configuration file of the script used for sending email to:

    Code:
    localhost
    Thank you.
     
  12. glupav

    glupav Active Member

    Joined:
    Oct 6, 2012
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    somehow now the SMTP server works
    inside settings in the Joomla plugin i put now localhost instead of mail.xxxdomainxxx.xxx
    it works now
    thanks for the support
     
Loading...

Share This Page