Can't create new account or its create bad.

wonder_wonder

Well-Known Member
Jan 16, 2019
100
35
28
Spain
cPanel Access Level
Root Administrator
Hello.
In the past in this same server I was create a new account with any problem
I try to create a new account since yesterday and always, I have the same problem:
When I create an account, when finish appears a error, this is the error:
Code:
The zone "newdomain.com" could not be parsed because of an error: There was an error while loading the zone for newdomain.com.  Please correct any errors in this zone manually and try again.  The exact error from the parser was: bad IP address, line 14: [ns1.newdomain.com. IN A 2a02:c205:2025:7125:0:0:0:1] at /usr/local/cpanel/Cpanel/ZoneFile/Collection.pm line 56.
 at /usr/local/cpanel/Cpanel/ZoneFile/Collection.pm line 56.
    Cpanel::ZoneFile::Collection::create_zone_file_objs(HASH(0x18c3498)) called at /usr/local/cpanel/Whostmgr/DNS/MX.pm line 345
    Whostmgr::DNS::MX::_fetchmx_backend(HASH(0x40ff388), "newdomain.com.db", HASH(0x18c3498)) called at /usr/local/cpanel/Whostmgr/DNS/MX.pm line 312
    Whostmgr::DNS::MX::fetchmx_ref_nodetect("newdomain.com.db", HASH(0x18c3498)) called at /usr/local/cpanel/Whostmgr/Accounts/Create.pm line 1867
    Whostmgr::Accounts::Create::_perform_dns_mx_operations(HASH(0x2ff7758), "; cPanel 86.0.16\x{a}; Zone file for newdomain.com\x{a}\$T"..., HASH(0x3da1e88)) called at /usr/local/cpanel/Whostmgr/Accounts/Create.pm line 1996
    Whostmgr::Accounts::Create::_setup_dns(HASH(0x2ff7758), HASH(0x3da1e88)) called at /usr/local/cpanel/Whostmgr/Accounts/Create.pm line 411
    eval {...} called at /usr/local/cpanel/Whostmgr/Accounts/Create.pm line 411
    Whostmgr::Accounts::Create::_wwwacct(__CPANEL_HIDDEN__, __CPANEL_HIDDEN__, __CPANEL_HIDDEN__, __CPANEL_HIDDEN__, __CPANEL_HIDDEN__, __CPANEL_HIDDEN__, __CPANEL_HIDDEN__, 0, ...) called at /usr/local/cpanel/Whostmgr/Accounts/Create.pm line 3140
    Whostmgr::Accounts::Create::__createaccount("language", "es", "bwlimit", "unlimited", "spf", 1, "featurelist", "default", ...) called at /usr/local/cpanel/Whostmgr/Accounts/Create.pm line 3275
    Whostmgr::Accounts::Create::_createaccount("language", "es", "bwlimit", "unlimited", "spf", 1, "featurelist", "default", ...) called at whostmgr/bin/whostmgr5.pl line 782
    main::wwwacct("wwwacct") called at /usr/local/cpanel/Whostmgr/Dispatch.pm line 273
    Whostmgr::Dispatch::_do_call("wwwacct", HASH(0x2bc87c8), HASH(0x2bcb348)) called at /usr/local/cpanel/Whostmgr/Dispatch.pm line 171
    Whostmgr::Dispatch::dispatch("wwwacct", 1, ARRAY(0x2bc86d8), HASH(0x2bcb348)) called at whostmgr/bin/whostmgr5.pl line 258
I go to edit dns zone of this new account and appears:

Code:
; cPanel first:86.0.16 (update_time):1584878989 86.0.16: Cpanel::ZoneFile::VERSION:1.3 hostname:server.myserver.es latest:86.0.16
; Zone file for newaccount.com
$TTL 14400
@      86400    IN      SOA     ns1.myserver.es. dany.myserver.es. (
        2020032200    ; serial, todays date+todays
        3600        ; refresh, seconds
        1800        ; retry, seconds
        1209600        ; expire, seconds
        86400 )        ; minimum, seconds

newaccount.com. 86400 IN NS ns1.myserver.es.
newaccount.com. 86400 IN NS ns2.myserver.es.

ns1.newaccount.com. IN A my ipv6 near 'my ipv6': bad dotted quad
ns2.newaccount.com. IN A my ipv6 near 'my ipv6': bad dotted quad

newaccount.com. IN A my ipv4

newaccount.com. IN MX 0 newaccount.com.

mail IN CNAME newaccount.com.
www IN CNAME newaccount.com.
ftp IN A my ipv4
newaccount.com. IN TXT "v=spf1 +a +mx +ip4:my ipv4 ~all"
Strange, because I view like want create a A record with the ipv6.

But I don't know how solved this...

Thanks and regards.
 

wonder_wonder

Well-Known Member
Jan 16, 2019
100
35
28
Spain
cPanel Access Level
Root Administrator
Solved....
Just when create this thread I think in....

My domain registrar, I have a DNS's records with ipv4 and ipv6, I view that, in my domain registrar are incorrect set the ipv6, are identify like ipv4.

I deleted the ipv6, create again the account and all fine.

Sorrys for the thread...