The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cant Create new Websites

Discussion in 'General Discussion' started by ~*dream*~, Sep 22, 2007.

  1. ~*dream*~

    ~*dream*~ Member

    Joined:
    Nov 14, 2006
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Accounts look like cpanel creates them but the username doesnt have any public_html
    Its same problem as shown in These threads:
    http://forums.cpanel.net/showthread...rror+occurred+while+processing+this+directive and http://forums.cpanel.net/showthread...rror+occurred+while+processing+this+directive


    I do have root access to this unmanaged server so I am pasting the /usr/local/cpanel/logs/error_log output:
    ----------------------
    Cpanel::IxHash: Warning, mangling data key msel which is longer then 64 bytes, using angle_bracket_encode
    Cpanel::IxHash: at whostmgr/bin/whostmgr.pl line 3126
    main::wwwacct called at whostmgr/bin/whostmgr.pl line 412
    Cpanel::IxHash: Warning, mangling data key msel which is longer then 64 bytes, using angle_bracket_encode
    Cpanel::IxHash: at whostmgr/bin/whostmgr.pl line 3145
    main::wwwacct called at whostmgr/bin/whostmgr.pl line 412
    tar: ./public_ftp: Cannot utime: Operation not permitted
    tar: ./public_ftp: Cannot change mode to rwxr-xr-x: Operation not permitted
    tar: ./public_html: Cannot utime: Operation not permitted
    tar: ./public_html: Cannot change mode to rwxr-xr-x: Operation not permitted
    tar: .: Cannot utime: Operation not permitted
    tar: .: Cannot change mode to rwxr-xr-x: Operation not permitted
    tar: Error exit delayed from previous errors
    (internal warning while parsing [stdin]) Sun Sep 23 01:00:48 2007 [31930] warn: safe_userchgid: chown: /home/bahooco/public_html: Permission denied at /usr/local/cpanel/Cpanel/SafetyBits.pm line 76.
    Cpanel::SafetyBits::safe_userchgid(32519, 99, '/home/seldstuf/public_html') called at /usr/local/cpanel/Whostmgr/Accounts/Create.pm line 761
    Whostmgr::Accounts::Create::_wwwacct('plan', 'pro', 'maxpark', 0, 'hasshell', 'n', 'maxlst', 'n', ...) called at /usr/local/cpanel/Whostmgr/Accounts/Create.pm line 1402
    Whostmgr::Accounts::Create::_createaccount('customip', '--Auto Assign--', 'plan', 'pro', 'maxpark', 0, 'password', changepass, ...) called at whostmgr/bin/whostmgr.pl line 3154
    main::wwwacct called at whostmgr/bin/whostmgr.pl line 412
    -------------------------------------------------




    Please letme know what should i do to make thme function normally.

    Thanks.
     
  2. USGlory

    USGlory Member

    Joined:
    Aug 1, 2005
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    [root@??? ~]# upcp --force

    Hopefully autoheal will resolve whatever issues you are having.
     
  3. ~*dream*~

    ~*dream*~ Member

    Joined:
    Nov 14, 2006
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    [root@cp ~]# upcp --force
    -bash: upcp: command not found
    [root@cp ~]#
     
  4. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    Try changing the cpanel build type to Release from WHM >> "Update Config".
    and execute the command as:

    /scripts/upcp --force
     
  5. ~*dream*~

    ~*dream*~ Member

    Joined:
    Nov 14, 2006
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    I did it, and it successfully completeed.

    BUT

    STill no success,


    Please help somebnody,

    I think its some permissions error, that cpanel cant create public_html and other directories in a user directory.
     
  6. ToddShipway

    ToddShipway Well-Known Member

    Joined:
    Nov 13, 2006
    Messages:
    300
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Houston, TX
    This is usually due to a problem with the user system on the server itself.

    Use 'adduser testuser' and you will see that the home directory is created but never given correct permissions as it will remain owned by root.

    You may have to contact your datacenter to have them investigate why system users aren't being added properly.
     
  7. ~*dream*~

    ~*dream*~ Member

    Joined:
    Nov 14, 2006
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
Loading...

Share This Page