Can't create table Wrong create options Error

EricaKeegan

Registered
Jan 26, 2017
2
0
1
South Africa
cPanel Access Level
Website Owner
Hi

I am attempting to transfer a site from one server to another, and am having trouble importing the database to the new server via phpmyadmin. When I import, I get the following error:
Code:
Error
SQL query:

--
-- Database: `prycisio_ctfadata`
--
-- --------------------------------------------------------
--
-- Table structure for table `ctf_audit`
--
CREATE TABLE IF NOT EXISTS `ctf_audit` (

`id` INT( 10 ) UNSIGNED NOT NULL AUTO_INCREMENT ,
`tableused` VARCHAR( 45 ) DEFAULT NULL ,
`idref` INT( 10 ) UNSIGNED DEFAULT NULL ,
`entry_date` DATETIME DEFAULT NULL ,
`entry_user` INT( 10 ) UNSIGNED DEFAULT NULL ,
`entry_browser` TEXT,
`entry_ip` VARCHAR( 16 ) DEFAULT NULL ,
`entry_session` TEXT,
`altid` INT( 10 ) UNSIGNED DEFAULT NULL ,
`entry_data` TEXT COMMENT 'other user data',
`checkhidden` VARCHAR( 255 ) DEFAULT NULL ,
`entry_type` VARCHAR( 45 ) DEFAULT NULL ,
PRIMARY KEY ( `id` )
) ENGINE = INNODB DEFAULT CHARSET = latin1 ROW_FORMAT = DYNAMIC AUTO_INCREMENT =519;



MySQL said: 

#1005 - Can't create table `prycisio_ctfadata`.`ctf_audit` (errno: 140 "Wrong create options")
I'm afraid I don't really know what I am looking at here. Can anyone help me with a solution?

Thanks
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
Hello,

Could you browse to the "Backups" option within cPanel and try using the "Restore a MySQL Database Backup" option? Let us know if this helps.

Thank you.
 

EricaKeegan

Registered
Jan 26, 2017
2
0
1
South Africa
cPanel Access Level
Website Owner
Hi

Yes I have tried that already. Using that option, when I try restore, my browser just hangs. If I check in phpmyadmin, the restore has created the database, but it is completely empty.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
I recommend reporting this issue to your web hosting provider so they can take a closer look, as the access level on your profile suggests you do not have root access to the system to investigate further.

Thank you.