Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Can't disable imap/pop?

Discussion in 'General Discussion' started by Zvi, Aug 8, 2009.

  1. Zvi

    Zvi Member

    Joined:
    Aug 8, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    51
    Location:
    SF Bay
    Hi All,

    on my VPS, I've disabled mailserver in WHM, also disabled exim, imap, mailma, etc.

    Still, ps shows
    dovecot 18243 0.0 0.3 4792 1840 ? S 20:28 0:00 pop3-login
    dovecot 18244 0.0 0.3 4792 1840 ? S 20:28 0:00 pop3-login
    dovecot 18245 0.0 0.3 4796 1840 ? S 20:28 0:00 imap-login
    dovecot 18246 0.0 0.3 4796 1840 ? S 20:28 0:00 imap-login
    root 18201 0.0 0.1 1796 588 ? Ss 20:28 0:00 /usr/sbin/dovecot
    root 18203 0.0 0.1 2236 880 ? S 20:28 0:00 dovecot-auth

    How can I get rid of them?

    I've rebooted the system just in case, no help, those are still up.

    Does cpanel need them for something even if I disable all mail on the box?

    P.S. Also, do I need any of those to send mail from php, which is using sendmail in php.ini, and does cpanel need any of it itself to send me notifications from root?
     
    #1 Zvi, Aug 8, 2009
    Last edited: Aug 8, 2009
  2. Eric

    Eric Administrator
    Staff Member

    Joined:
    Nov 25, 2007
    Messages:
    751
    Likes Received:
    11
    Trophy Points:
    143
    Location:
    Texas
    cPanel Access Level:
    Root Administrator
    Howdy,

    I don't have all of my tools but I'd check out:

    /scripts/setupmailserver

    via ssh. Last I recall it had a disable mode where you can shut imap and pop3 out.

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Zvi

    Zvi Member

    Joined:
    Aug 8, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    51
    Location:
    SF Bay
    Thanks!

    I've figured it out, it was dovecote that was bringing them up. After disabling it all is fine.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice