Can't edit certain blocks in Exim Advanced Editor

WifiOneOne

Registered
Oct 24, 2018
1
0
1
Belleville, IL USA
cPanel Access Level
Root Administrator
Running cPanel 76.0.0 on CentOS 6.10 kvm.

I'm in Exim Configuration Manager > Advanced tab. Am trying to edit the three "delay = #s" values to reduce the # of seconds. The relevant sections of Advanced editor are pasted below. The problem is even though these look like they should be editable fields, they can't be changed. Tried Firefox. Then tried Chrome with no add-ins enabled. Still can't edit the fields. Am I missing something that should be obvious?

On an earlier date we changed these settings direct in exim.conf without realizing the new values would be overwritten by cPanel later. My understanding is the standard way to ensure our exim changes "stick" is to make the changes in the Exim Config Advanced tab.

Any idea what I'm doing wrong? Thanks for any advice you can offer.


In "acl_smtp_connect" section:
warn
!hosts = : +loopback : +neighbor_netblocks : +trustedmailhosts : +recent_authed_mail_ips : +back
upmx_hosts : +skipsmtpcheck_hosts : +senderverifybypass_hosts : +greylist_trusted_netblocks : +greyl
ist_common_mail_providers : +cpanel_mail_netblocks
#only rate limit port 25
condition = ${if eq {$received_port}{25}{yes}{no}}
delay = 20s

In "acl_smtp_rcpt" section:
warn
!authenticated = *
!hosts = : +loopback : +neighbor_netblocks : +trustedmailhosts : +recent_authed_mail_ips : +back
upmx_hosts : +skipsmtpcheck_hosts : +senderverifybypass_hosts : +greylist_trusted_netblocks : +greyl
ist_common_mail_providers : +cpanel_mail_netblocks
#only rate limit port 25
condition = ${if eq {$received_port}{25}{yes}{no}}
delay = 20s

warn
#acl_m2 is spam = YES
condition = ${if eq {${acl_m2}}{1}{1}{0}}
!hosts = : +loopback : +neighbor_netblocks : +trustedmailhosts : +recent_authed_mail_ips : +back
upmx_hosts : +skipsmtpcheck_hosts : +senderverifybypass_hosts : +greylist_trusted_netblocks : +greyl
ist_common_mail_providers : +cpanel_mail_netblocks
delay = 40s
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
Hello @WifiOneOne,

It doesn't look like that value is modifiable directly from Web Host Manager. I encourage you to submit a feature request if you'd like to see an option to directly modify the number of seconds the message is delayed:

Submit A Feature Request

In the meantime, you could setup a custom bash script that automatically replaces all instances of "delay = 20s" to "delay = XXs" in the /etc/exim.conf file. Here's an example of the commands you could use in such a bash script:

Code:
replace "delay = 20s" "delay = 15s" -- /etc/exim.conf
/scripts/restartsrv_exim
You'd then set up the script to run after each cPanel update using a standardized hook:

Guide to Standardized Hooks
Guide to Standardized Hooks - System Functions - upcp

For example:

Code:
/usr/local/cpanel/bin/manage_hooks add script /path/to/custom-script.sh --manual --category System --event upcp --stage post
Thank you.