Nirjonadda

Well-Known Member
May 8, 2013
736
27
78
cPanel Access Level
Root Administrator
I have a problem to Enable cPHulk Firewalls. Please let me know,How to get working the Firewalls?

The system disabled firewall options. These options require IPTables v1.4 or higher and a non-Virtuozzo environment.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,229
463
Hello :)

Please post the output from the following command:

Code:
iptables -V
cat /etc/redhat-release
uname -a
Thank you.
 

Nirjonadda

Well-Known Member
May 8, 2013
736
27
78
cPanel Access Level
Root Administrator
Is my output.

Code:
login as: root
[email protected]'s password:
Last login: Tue Jan 27 23:50:25 2015 from xxx.xx.xxx.xxx
[email protected] [~]# iptables -V
iptables v1.4.7
[email protected] [~]# cat /etc/redhat-release
CentOS release 6.6 (Final)
[email protected] [~]# uname -a
Linux na.mysite.com 2.6.32-042stab093.4 #1 SMP Mon Aug 11 18:47:39 MSK 2014 x86_64 x86_64 x86_64 GNU/Linux
 

epaslv

Member
May 18, 2010
22
0
51
Melbourne, Australia
cPanel Access Level
Root Administrator
I have the same issue and am running VM's CentOS release 6.6 (Final), iptables v1.4.7 under SolusVM

The reply I got back from support was "Unfortunately this is a limitation with Virtuozzo"

Unless SolusVM and Virtuozzo are the same, I have a feeling this may be related to iptables modules that the host provides for the VM's.
 

epaslv

Member
May 18, 2010
22
0
51
Melbourne, Australia
cPanel Access Level
Root Administrator
FYI,

I've heard back from cPanel developers and they have made decision to not support Virtuozzo/OpenVZ in regards to cPhulk features.

Rather odd actually considering OpenVZ is listed as "Supported Virtual Environments"
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,229
463
Hello :)

Yes, per internal case number 163557, it was a design decision to not support the cPHulk firewall options on Virtuozzo/OpenVZ. You can open a feature request for this via:

Submit A Feature Request

Thank you.