Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Can't enable "/etc/mailhelo" options in WHM

Discussion in 'E-mail Discussion' started by sehh, Sep 28, 2011.

  1. sehh

    sehh Well-Known Member

    Joined:
    Feb 11, 2006
    Messages:
    579
    Likes Received:
    5
    Trophy Points:
    168
    Location:
    Europe
    In WHM's Exim configuration, there are two options:

    Reference /etc/mailhelo for outgoing SMTP HELO
    Reference /etc/mailips for outgoing SMTP connections

    Both are Off by default, so I try to enable them by selecting On. But no matter what I do, when the WHM page reloads after clicking "Save", they both return to the Off state.

    Anyone has the same problem?

    PS:
    I'm using the latest STABLE.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,479
    Likes Received:
    421
    Trophy Points:
    583
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Unless there's some sort of browser cache issue at play here, this sounds like a defect to me. I can't reproduce it here. You might want to put a ticket in to cPanel Support on this one.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. sehh

    sehh Well-Known Member

    Joined:
    Feb 11, 2006
    Messages:
    579
    Likes Received:
    5
    Trophy Points:
    168
    Location:
    Europe
    I did a little more digging and I found out that it is a javascript problem.

    The top option "Send mail from account’s dedicated IP", if enabled, should disable the two other options, since it overrides them. But it doesn't.

    Thus, all three options are selectable, when they shouldn't be when the top option is enabled.

    Minor issue, but would be nice if it was corrected.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,479
    Likes Received:
    421
    Trophy Points:
    583
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. sehh

    sehh Well-Known Member

    Joined:
    Feb 11, 2006
    Messages:
    579
    Likes Received:
    5
    Trophy Points:
    168
    Location:
    Europe
    Thanks, I've submitted a bug report.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice