The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't enable spamassasin

Discussion in 'General Discussion' started by xWho, Mar 31, 2006.

  1. xWho

    xWho Well-Known Member

    Joined:
    Apr 23, 2003
    Messages:
    112
    Likes Received:
    0
    Trophy Points:
    16
    In all my accounts, when I try to enable SpamAssassin, I get "The disk write test failed. You may have exceeded your quota, or the disk is full."

    First off, the disk isn't full. I wish it gave a better error message than this. I don't even know where to begin.
     
  2. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    Sounds to me as if your home partition is mounted as Read Only. Perhaps you have a corrupt disk ?
     
  3. xidica

    xidica Well-Known Member

    Joined:
    Apr 21, 2005
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Texas
    Check to make sure that quota information is correct, but the spamassassin module and binaries are often not installed. Force install it with :

    /scripts/realperlinstaller --force Mail::SpamAssassin

    If you're still getting weird disk input/output errors I'd definately check drive health with smartctl (provided SMART is supported and enabled on the drives), grep hdX /var/log/messages (where hdX is your hard drive device) to make sure you dont see 8,000 drive warnings/errors.
     
Loading...

Share This Page