royb

Registered
Mar 9, 2014
1
0
1
cPanel Access Level
Root Administrator
Hi am new to this and never setup a dedicated server before, but am more than competent running WHM and cpanels from a resellers level access, I’ve now decided to have a go at a dedicated server of my own.

I have managed to get whm installed, and create cpanels with domains all working, but webmail doesn’t work, Can setup email accounts in cpanel but when I go to the webmail icon it doesn’t work, it takes me to the webmail page ok but when I click on the go to secure webmail login icon it gives me
The connection has timed out
The server at mywebsite.co.uk is taking too long to respond.
The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer's network connection.
If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

Not sure if I have to install mail client software or if I haven’t flicked a switch somewhere in whm when I was installing it and setting it up to activate mail client software.
I have it enabled in the Tweak Settings

Any help would be well appreciated
Thanks Roy
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
Hello :)

Check to make sure there are no firewall rules on your server blocking ports 2095 or 2096. Also, check by using the IP address in the URL to rule out any problems with the DNS.

Thank you.
 

responseit

Member
Oct 21, 2014
7
0
1
cPanel Access Level
Root Administrator
Have you tried going to http://domain.com/webmail to see if it redirects to http://server.com:2096 (or 2095) ?

Make sure that you can reach webmail ports 2095 or 2096 from your location and that those ports are open on server firewall...
Had the same issue with webmail.domain.com and going to http://domain.com/webmail redirects me to http://domain.com/unprotected/redirect.html

All the DNS records are set. Originally using Cloudflare which I disabled for the client yesterday but still no change. Is there something I can do in the server?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
You can try rebuilding the Apache configuration file via:

Code:
/scripts/rebuildhttpdconf
Also, try clearing the browser/DNS cache on your system before reloading the URL.

Thank you.