Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Can't get Apache installed-properly/running on FreeBSD/Cpanel

Discussion in 'EasyApache' started by rnh, Apr 15, 2003.

  1. rnh

    rnh Well-Known Member

    Joined:
    Apr 15, 2003
    Messages:
    118
    Likes Received:
    0
    Trophy Points:
    166
    Hi I just got a new FreeBSD 4.7 server and installed Cpanel on it today.

    After the Cpanel install MySQL and Apache were still not installed, so I ran

    pkg_add -r mysql-server
    and
    pkg_add -r apache

    Now they show up in pkg_info:

    apache-1.3.27 The extremely popular Apache http server. Very fast, very
    mysql-client-3.23.52 Multithreaded SQL database (client)
    mysql-server-3.23.52_1 Multithreaded SQL database (server)
    (there was a lot more lines but I cut them out to save space)
    And MySQL shows up as running now in Cpanel, however apache still doesn't.

    Whereis says that httpd is there:

    gold# whereis apache
    apache:
    gold# whereis mysql
    mysql: /usr/local/bin/mysql /usr/local/man/man1/mysql.1.gz
    gold# whereis httpd
    httpd: /usr/local/sbin/httpd /usr/local/man/man8/httpd.8.gz
    gold# locate /httpd


    but I can't seem to get apache running and I'm getting alert e-mails every 5 minutes that Cpanel was trying to restart apache.


    I think that this is the problem as to why I can't get it started:

    server# /etc/rc.d/init.d/httpd start
    /etc/rc.d/init.d/httpd: /usr/local/apache/bin/httpd: not found
    /etc/rc.d/init.d/httpd start: httpd could not be started
    server# cd /usr/local/apache/bin/
    /usr/local/apache/bin/: No such file or directory.
    server# cd /usr/local/apache/
    server# ls
    domlogs

    Thanks for your help!
    Jesse
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. rnh

    rnh Well-Known Member

    Joined:
    Apr 15, 2003
    Messages:
    118
    Likes Received:
    0
    Trophy Points:
    166
    hmm... I installed more apache packages using pkg_add and got apache running, however Cpanel still doesn't recognize it as running, and is unable to restart it.

    also, running:

    /etc/rc.d/init.d/httpd start

    still returns:

    /etc/rc.d/init.d/httpd: /usr/local/apache/bin/httpd: not found

    It appears that the Apache install failed during my Cpanel install. Does anyone know how to reinstall it w/ Cpanel?

    When I ran the "update server software" it said that some of the apache packages were out of date but were unable to upgrade.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice