Can't get email to work...any ideas?

Seriom

Active Member
Sep 23, 2005
39
0
156
I had a server crash a week ago and since then my email hasn't worked a bit....we did a total OS reload w/ cpanel/whm

when I go to restart exim it restarts fine, but when I go to restart cppop, i get the "cppop has failed, please contact the sysadmin." error

I checked the Service Status section, and this is all that showed up:
psrvd up
named (9.3.1) up
Server Load 0.00 (4 cpus)
Memory Used 41.84 %
Swap 0.00 %
Disk ad0s1a (/) 4 %
Disk ad0s1e (/tmp) 0 %
Disk ad0s1f (/usr) 46 %
Disk ad0s1d (/var) 21 %
Disk ad1s1e (/backup) 15 %

I seem to recall before the crash that ALL services were listed in there, including exim

Any ideas why this is happening? if you need me to login ssh or post any more info let me know :)
 

Seriom

Active Member
Sep 23, 2005
39
0
156
forgot to mention

WHM 10.8.0 cPanel 10.8.2-R119
FreeBSD 5.4-RELEASE i386 - WHM X v3.1.0
 

Seriom

Active Member
Sep 23, 2005
39
0
156
After a little tinkering, my service status now looks like this:

cpsrvd up
named (9.3.1) up
pop failed
Server Load 0.04 (4 cpus)
Memory Used 43.35 %
Swap 0.00 %
Disk ad0s1a (/) 4 %
Disk ad0s1e (/tmp) 0 %
Disk ad0s1f (/usr) 46 %
Disk ad0s1d (/var) 21 %
Disk ad1s1e (/backup) 15 %

Pop is on there, but now failed
 

mohit

Well-Known Member
Jul 12, 2005
553
0
166
Sticky On Internet
ya just type it as it is.

it will force update your exim, lets hope it comes up after a exim restart,

see ya,
mohit
 

Seriom

Active Member
Sep 23, 2005
39
0
156
websupport said:
You may try with folowing script:
/scripts/eximup --force

:)
do I just type that into ssh?
 

Seriom

Active Member
Sep 23, 2005
39
0
156
mohit said:
ya just type it as it is.

it will force update your exim, lets hope it comes up after a exim restart,

see ya,
mohit
Just did that and it did update exim, but nothing still works...cppop has failed is the message
 

mohit

Well-Known Member
Jul 12, 2005
553
0
166
Sticky On Internet

Seriom

Active Member
Sep 23, 2005
39
0
156
OK, ThePlanet (where the box is) says that this is the issue:


---------------
plump# grep -A3 maildir /scripts/restartsrv_cppop
if ( $CPCONF{'maildir'} eq '1' ) {
exec('/scripts/restartsrv_imap',@ARGV);
exit();
}
plump# grep maildir /var/cpanel/cpanel.config
maildir=1
plump#

Your server is no longer configured to use the mbox format but rather maildir so cppop is no longer available.
--------------


how do I get it configured to the mbox format?
 

websupport

Well-Known Member
Jun 24, 2006
92
0
156
Try the scripts

Below script is useful to restart cppop
· restartsrv_cppop - Restart cppop.

Comand to run on shell is :
/scripts/restart_cppop

If above will not restart cppop on server then use following command
/scripts/courierup --force

If still problem persist paste few lines from /var/log/messages

:)
 

Seriom

Active Member
Sep 23, 2005
39
0
156
websupport said:
Below script is useful to restart cppop
· restartsrv_cppop - Restart cppop.

Comand to run on shell is :
/scripts/restart_cppop

If above will not restart cppop on server then use following command
/scripts/courierup --force

If still problem persist paste few lines from /var/log/messages

:)
/scripts/restart_cppop did not work

I did /scripts/courierup --force and it ran a big long list of stuff, and that didn't work either

how do I paste lines from /var/log/messages?

also, ThePlanet says my box is no longer configured for mbox format...how do I redo that?
 

WebScHoLaR

Well-Known Member
Dec 14, 2005
510
3
168
Planet Earth
/scripts/restart_cppop did not work
The correct restart script is /scripts/restartsrv_cppop and not /scripts/restart_cppop

how do I paste lines from /var/log/messages?
You need to login to the server via SSH and you can use tail command to check the last lines. For example login to the server via SSH and to get the last 20 lines run:

tail -20 /var/log/messages

also, ThePlanet says my box is no longer configured for mbox format...how do I redo that?
You can redo that by running /scripts/convert2maildir but please note that Mbox format is no more supported by cPanel and the cPanel is using Maildir format now so you should use Maildir by now.
 

Seriom

Active Member
Sep 23, 2005
39
0
156
WebScHoLaR said:
The correct restart script is /scripts/restartsrv_cppop and not /scripts/restart_cppop
did that, it restarted, and still says failed in the service status page


WebScHoLaR said:
You need to login to the server via SSH and you can use tail command to check the last lines. For example login to the server via SSH and to get the last 20 lines run:

tail -20 /var/log/messages
WebScHoLaR said:
You can redo that by running /scripts/convert2maildir but please note that Mbox format is no more supported by cPanel and the cPanel is using Maildir format now so you should use Maildir by now.
ok, so I don't need to do anything, so, now....why is email not working? as far as I can see this is a cpanel issue, and posting in the cpanel forums doesn't seem to be working, and cpanel support never emails back....so what do I need to do? I am paying for cpanel, I think it needs to be working...right?

sorry if I am frustrated, but all I seem to be getting from all sides is "maybe this will work", "maybe that will work"....and not one person can give me a straight answer as to why my email worked before, and now, with the same server setup, it isn't working now
 

Seriom

Active Member
Sep 23, 2005
39
0
156
oh yeah, here is the last 20 lines from /var/log/messages

Code:
Aug 31 03:01:18 plump stunnel: LOG5[25018:134635520]: stunnel 4.15 on i386-unknown-freebsd5.4 with OpenSSL 0.9.7e 25 Oct 2004
Aug 31 03:01:18 plump stunnel: LOG5[25018:134635520]: Threading:PTHREAD SSL:ENGINE Sockets:POLL,IPv4 Auth:LIBWRAP
Aug 31 03:01:18 plump stunnel: LOG5[25018:134635520]: 5417 clients allowed
Aug 31 03:01:18 plump stunnel: LOG3[25018:134635520]: Error binding cpanelhttps to 0.0.0.0:2083
Aug 31 03:01:18 plump stunnel: LOG3[25018:134635520]: bind: Address already in use (48)
Aug 31 06:49:55 plump named[9689]: *** POKED TIMER ***
Aug 31 08:11:59 plump named[9689]: *** POKED TIMER ***
Aug 31 08:19:33 plump named[9689]: *** POKED TIMER ***
Aug 31 10:36:38 plump named[9689]: *** POKED TIMER ***
Aug 31 13:21:14 plump named[9689]: *** POKED TIMER ***
Aug 31 15:01:43 plump stunnel: LOG5[50551:134635520]: stunnel 4.15 on i386-unknown-freebsd5.4 with OpenSSL 0.9.7e 25 Oct 2004
Aug 31 15:01:43 plump stunnel: LOG5[50551:134635520]: Threading:PTHREAD SSL:ENGINE Sockets:POLL,IPv4 Auth:LIBWRAP
Aug 31 15:01:43 plump stunnel: LOG5[50551:134635520]: 5417 clients allowed
Aug 31 15:01:43 plump stunnel: LOG3[50551:134635520]: Error binding cpanelhttps to 0.0.0.0:2083
Aug 31 15:01:43 plump stunnel: LOG3[50551:134635520]: bind: Address already in use (48)
Aug 31 16:04:27 plump stunnel: LOG5[18761:134635520]: stunnel 4.15 on i386-unknown-freebsd5.4 with OpenSSL 0.9.7e 25 Oct 2004
Aug 31 16:04:27 plump stunnel: LOG5[18761:134635520]: Threading:PTHREAD SSL:ENGINE Sockets:POLL,IPv4 Auth:LIBWRAP
Aug 31 16:04:27 plump stunnel: LOG5[18761:134635520]: 5417 clients allowed
Aug 31 16:04:27 plump stunnel: LOG3[18761:134635520]: Error binding cpanelhttps to 0.0.0.0:2083
Aug 31 16:04:27 plump stunnel: LOG3[18761:134635520]: bind: Address already in use (48)
 

WebScHoLaR

Well-Known Member
Dec 14, 2005
510
3
168
Planet Earth
For email related issue the email log is the best to check but first of all you need to check that whether all services are up and running. If you don't have much idea about it, get anyone working for you so that you don't mess up anything.
 

Seriom

Active Member
Sep 23, 2005
39
0
156
Unfortunately I am the only person working for me

not sure what to do...I am paying for cpanel, you think the least that would happen is the support at cpanel.net would answer my questions, but neither them nor my server provider seem to care whatsoever
 

Seriom

Active Member
Sep 23, 2005
39
0
156
are there any reputable people on the cpanel forums that would allow me to pay them to go in and fix this?
 

Seriom

Active Member
Sep 23, 2005
39
0
156
Here is the maillog dump.....seems like a lot of wierd stuff failing there


Sep 2 02:54:00 plump spamc[74969]: connect(AF_INET) to spamd at 127.0.0.1 failed, retrying (#1 of 3): Connection refused
Sep 2 02:54:01 plump spamc[74969]: connect(AF_INET) to spamd at 127.0.0.1 failed, retrying (#2 of 3): Connection refused
Sep 2 02:54:02 plump spamc[74969]: connect(AF_INET) to spamd at 127.0.0.1 failed, retrying (#3 of 3): Connection refused
Sep 2 02:54:03 plump spamc[74969]: connection attempt to spamd aborted after 3 retries
Sep 2 02:54:32 plump spamc[77550]: connect(AF_INET) to spamd at 127.0.0.1 failed, retrying (#1 of 3): Connection refused
Sep 2 02:54:33 plump spamc[77550]: connect(AF_INET) to spamd at 127.0.0.1 failed, retrying (#2 of 3): Connection refused
Sep 2 02:54:34 plump spamc[77550]: connect(AF_INET) to spamd at 127.0.0.1 failed, retrying (#3 of 3): Connection refused
Sep 2 02:54:35 plump spamc[77550]: connection attempt to spamd aborted after 3 retries
Sep 2 02:59:27 plump authdaemond: stopping authdaemond children
Sep 2 02:59:27 plump authdaemond: modules="authpipe", daemons=5
Sep 2 02:59:27 plump authdaemond: Installing libauthpipe
Sep 2 02:59:27 plump authdaemond: Installation complete: authpipe
Sep 2 19:57:17 plump authdaemond: stopping authdaemond children
Sep 2 19:57:17 plump authdaemond: modules="authpipe", daemons=5
Sep 2 19:57:17 plump authdaemond: Installing libauthpipe
Sep 2 19:57:17 plump authdaemond: Installation complete: authpipe
Sep 2 19:57:35 plump authdaemond: stopping authdaemond children
Sep 2 19:57:36 plump authdaemond: modules="authpipe", daemons=5
Sep 2 19:57:36 plump authdaemond: Installing libauthpipe
Sep 2 19:57:36 plump authdaemond: Installation complete: authpipe


also, here is the text shown when I try and start IMAP server "imap has failed, please contact the sysadmin (result was "couriertcpd is not running"). "
 

yapluka

Well-Known Member
Dec 24, 2003
301
1
168
France
cPanel Access Level
Root Administrator
All new installations of cPanel now use pop3d and it looks like you restored accounts configured with pop.

In SSH, type :
/scripts/convert2maildir

You'll get several options, depending on whether maildir is actually installed or not but you should get something like this :

[email protected] [~]# /scripts/convert2maildir
____ _
___| _ \ __ _ _ __ ___| |
/ __| |_) / _` | '_ \ / _ \ |
| (__| __/ (_| | | | | __/ |
\___|_| \__,_|_| |_|\___|_|

Mail Directory (maildir) Conversion System


maildir is enabled

1) Restore system to mbox (non-maildir) state.
2) Request Technical Support
3) Convert partially converted mail accounts
*) Exit
Enter Selection---]
Type : 3 (unless you actually want to get back to the old mbox, less efficient than maildir)
The script will convert all your mailboxes to the new format and you should be all set.
 

Seriom

Active Member
Sep 23, 2005
39
0
156
yapluka said:
All new installations of cPanel now use pop3d and it looks like you restored accounts configured with pop.

In SSH, type :
/scripts/convert2maildir

You'll get several options, depending on whether maildir is actually installed or not but you should get something like this :



Type : 3 (unless you actually want to get back to the old mbox, less efficient than maildir)
The script will convert all your mailboxes to the new format and you should be all set.

I did all that and am still getting a "could not connect to the incoming mail server" error