Can't get MailScanner to start

ramorse

Well-Known Member
Sep 6, 2003
254
5
168
cPanel Access Level
Root Administrator
Something has changed on one of my servers since last night. I can't get MailScanner to run. I have disabled it for now so new mail will get delivered via Exim. But there is a ton of mail in the MailScanner queue that won't get delivered until it gets properly restarted (or removed, I guess). Here is what I have done.

When I try to start MailScanner using /sbin/service MailScanner start I get the following error:

**** ERROR: You must upgrade your perl IO module to at least
**** ERROR: version 1.2301 or MailScanner will not work!

I have been following the directions on viewtopic.php?t=2722 including

/scripts/perlinstaller --force IO

Which resulted in:
Appending installation info to /home/admin/perl5/lib/perl5/x86_64-linux-thread-multi/perllocal.pod
OK
Successfully installed IO-1.25 (upgraded from 1.22)
1 distribution installed

But when I tried to start MailScanner after this I got the same error:
**** ERROR: You must upgrade your perl IO module to at least
**** ERROR: version 1.2301 or MailScanner will not work!

I have another Cpanel server with MailScanner running on it but it wasn't affected.