Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Can't get PGsql vworking

Discussion in 'Database Discussion' started by benzema79, Nov 24, 2011.

  1. benzema79

    benzema79 Registered

    Joined:
    Nov 24, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    51
    cPanel Access Level:
    Root Administrator
    Hi,

    I have Centos 4.9 (not sure if this is the problem using old version of centos) and php 5.3.8 working on the VPS I have. I have been trying to get postgresql working for days and still had no luck.

    I have installed postgresql 9.1 and then ran the /scripts/installpostgres

    This is the error i get right after this command:

    it continues to install and i can start postgresql service. However, in phpinfo() I don't see postgresql.

    Can someone help please?
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,608
    Likes Received:
    32
    Trophy Points:
    238
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    You would also need to compile in Postgres support in EasyApache (/scripts/easyapache) for PHP in order for postgresql to show up in a phpinfo page. It is similar to how MySQL needs to be compiled by running EasyApache script for PHP's MySQL support.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice