The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't get PGsql vworking

Discussion in 'Database Discussions' started by benzema79, Nov 24, 2011.

  1. benzema79

    benzema79 Registered

    Joined:
    Nov 24, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi,

    I have Centos 4.9 (not sure if this is the problem using old version of centos) and php 5.3.8 working on the VPS I have. I have been trying to get postgresql working for days and still had no luck.

    I have installed postgresql 9.1 and then ran the /scripts/installpostgres

    This is the error i get right after this command:

    it continues to install and i can start postgresql service. However, in phpinfo() I don't see postgresql.

    Can someone help please?
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    You would also need to compile in Postgres support in EasyApache (/scripts/easyapache) for PHP in order for postgresql to show up in a phpinfo page. It is similar to how MySQL needs to be compiled by running EasyApache script for PHP's MySQL support.
     
Loading...

Share This Page