The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't get phpinfo() to work for accounts on CloudLinux server.

Discussion in 'CloudLinux' started by jols, Apr 23, 2013.

  1. jols

    jols Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,111
    Likes Received:
    2
    Trophy Points:
    38
    Hi,

    I for sure do not have phpinfo in any of the php.ini disable_functions = lists, but no matter what, I just could not get a simple PHP script to display the php information just now. I tried the following script with several variations, but just could not get anything beyond a blank page for this:

    <?php

    phpinfo();

    ?>

    Work fine on our Redhat servers provided phpinfo is not in the disabled list. Anyone else have this issue with CL?
     
  2. iseletsk

    iseletsk Well-Known Member

    Joined:
    Mar 3, 2010
    Messages:
    163
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Princeton, New Jersey, United States
    what is in the apache error logs?
     
  3. jols

    jols Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,111
    Likes Received:
    2
    Trophy Points:
    38
    Nothing, that's the odd thing, we just get a blank page, nothing more.

    What scares me is that, it's as if /usr/local/lib/php.ini is not even being "looked at" by the "native" php v5.4 on this system.
     
  4. jols

    jols Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,111
    Likes Received:
    2
    Trophy Points:
    38
    Actually I was looking at the wrong error log, the entry was expected as something in reference to "not allowed by php configuration."

    The solution here was to enter the following at shell whenever there is a change to the main/native php.ini file:

    cagefsctl --force-update
     
Loading...

Share This Page