The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't get to the login screen after installing cPanel

Discussion in 'General Discussion' started by david_walden, Jul 2, 2008.

  1. david_walden

    david_walden Registered

    Jul 1, 2008
    Likes Received:
    Trophy Points:
    Hi, I have tried everything I can think of... including reformatting my server and reinstalling cPanel from scratch.

    What I'm doing is setting up cPanel and WHM on a test machine on our LAN to trial it (I have a 15 day trial license). So this is what I did...
    1. Install CentOS5 (clean install).
    2. Install cPanel and WHM.
    That all seems to go smoothly... no errors that I could see.
    3. Try and go to and all I get (after a minute or 2) is "Internet Explorer cannot display the page".

    I can SSH in problem and ping the server.

    I have tried these things...
    1. (same result as above).
    2. Turned the firewall off on my client PC.
    3. Connecting my client PC directly to the server (using Cat5 cable). SSH and ping OK, but still no login screen.
    4. Tried a different client PC, so have tried getting to the login screen in Windows XP, Windows 98; using both IE7 and Firefox.
    5. On the server I did...
    # wget
    Which gives...
    Connecting to connected.
    HTTP request sent, awaiting response... 401 Access Denied Still Working
    Authorization failed.

    Looking at /usr/local/cpanel/logs/access_log I see... - - [07/03/2008:11:04:55 -0000] "POST /.__cpanel__service__check__./serviceauth HTTP/1.0" 200 0 "" "" - - [07/03/2008:11:13:15 -0000] "POST /.__cpanel__service__check__./serviceauth HTTP/1.0" 200 0 "" "" - - [07/03/2008:11:13:18 -0000] "GET / HTTP/1.0" 401 0 "" "Wget/1.10.2 (Red Hat modified)" - - [07/03/2008:11:13:18 -0000] "GET / HTTP/1.0" 401 0 "" "Wget/1.10.2 (Red Hat modified)"

    The local wget requests show up there, but nothing else apart from the cpanel_service_check lines. I'm not sure what the cpanel_service_check is... probably not relevant. ie. none of the requests that I have made through my web browser show up in the access_log.

    That's about it. Thanking you in advance for your help.
  2. david_walden

    david_walden Registered

    Jul 1, 2008
    Likes Received:
    Trophy Points:
    It was the firewall

    CentOS installs RH firewall which needs to be opened. Obviously. Response from cPanel tech support...

    > I see that you have the RH firewall enabled. This is blocking access to WHM and cPanel. For proper cPanel functionality, you will need to be sure to open the following ports:
    > 20 ftp tcp inbound/outbound
    > 21 ftp tcp,udp inbound/outbound
    > 22 ssh tcp inbound
    > 25 smtp tcp inbound/outbound
    > 26 smtp tcp inbound/outbound
    > 37 rdate tcp outbound
    > 43 whois tcp outbound
    > 53 DNS tcp/udp inbound/outbound
    > (inbound is only needed if you run your own public DNS server)
    > 80 http tcp inbound/outbound
    > 110 pop3 tcp inbound
    > 113 ident tcp outbound
    > 143 imap4 tcp inbound
    > 443 https tcp inbound
    > 465 smtp tls/ssl tcp/udp inbound/outbound
    > 873 rsync tcp/udp outbound
    > 993 imap4 ssl tcp inbound
    > 995 pop3 ssl tcp inbound
    > 2077 webdav tcp/udp inbound/outbound
    > 2078 webdav ssl tcp/udp inbound/outbound
    > 2082 cpanel tcp inbound
    > 2083 cpanel ssl tcp inbound
    > 2086 whm tcp inbound
    > 2087 whm ssl tcp inbound
    > 2089 licensing server tcp inbound/outbound
    > 2095 Webmail tcp inbound
    > 2096 Webmail SSL tcp inbound
    > 3306 mysql tcp (only if you need to connect remotely)
    > 6666 chat tcp inbound

    So that worked and everything is sweet now. :)

Share This Page