The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't get vhost to work

Discussion in 'General Discussion' started by cwalke32477, Jun 27, 2010.

  1. cwalke32477

    cwalke32477 Well-Known Member

    Joined:
    Mar 2, 2010
    Messages:
    94
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Atlanta, Georgia
    cPanel Access Level:
    Root Administrator
    I am trying to get a server setup and the vhost won;t work.
    (xxx.xxx.xxx.xxx/~username)

    Proxy is enabled.
    I can't find where to enable mod_rewrite; it's not in the easy apache options.

    Code:
    Proxy [More Info ↑]
      	required for cPanel/WHM/Webmail/Webdisk proxy VirtualHost support
    
    If I try to access a url through ip/~username it takes me to a blue page that says
    Code:
    The server can not find the requested page:
    
        xxx.xxx.xxx.xxx/~username/ (port 80) 
    
    Please forward this error screen to 174.34.155.82's WebMaster.
    Apache/2.2.15 (Unix) mod_ssl/2.2.15 OpenSSL/0.9.8e-fips-rhel5 mod_mono/2.6 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at 174.34.155.82 Port 80
    
    
    Any Ideas? I've looked all over for an answere to this, but can;t find it
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,452
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Have you checked the setting in WHM located here?
    WHM >> Security Center >> Apache mod_userdir Tweak


     
  3. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    Be advised that mod_userdir doesn't work properly under non-DSO
    based servers such as those with phpSuExec, SuPHP, or FCGI based PHP.

    On these servers, mod_userdir protection should be enabled to disable the use of mod_userdir (http://ip/~username) as you should not be trying to connect to your site that way under those server types.

    It's part of the base core whenever you use EasyApache and really not
    something that you need to check off specifically.

    (In other words, you almost always have mod_rewrite and probably
    have it already installed right now as well too)

    Run the following at the shell (root) to see what modules you have presently:
    Code:
    #  httpd -l | sort -g 
    Be advised that some web software programs are a bit lazy where it
    comes to checking Apache modules and simply check the phpinfo()
    screen contents to see if you have certain Apache modules installed and then
    might have their programs tell you that you don't have mod_rewrite and
    others when indeed you actually do. This is because on any server type
    other than DSO, Apache modules loaded are not listed in the phpinfo() screen.
     
Loading...

Share This Page