grabyourhosting

Well-Known Member
Jan 18, 2007
88
4
158
cPanel Access Level
Root Administrator
On two of my servers, I have this error message. I cannot install php 7.4 or 7.4 with it's extensions. I am not using cloudlinux. Thank you.
Code:
Update Error:

Error: Package: xz-lzma-compat-5.2.2-1.el7.x86_64 (base)
Requires: xz = 5.2.2-1.el7
Installed: xz-5.2.2-1.el7.cloudlinux.1.x86_64 (@cloudlinux-x86_64-server-7)
xz = 5.2.2-1.el7.cloudlinux.1
Available: xz-5.2.2-1.el7.x86_64 (base)
xz = 5.2.2-1.el7
The entire output was logged to: /usr/local/cpanel/logs/packman/errors/2020-04-20_08:52:34-1
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,255
313
Houston
Hello,

The error indicates that the dependency it's looking for is the package:
xz-5.2.2-1.el7.x86_64 (base)

But you have:xz-5.2.2-1.el7.cloudlinux.1.x86_64 installed which is causing a conflict.

If you're running CloudLinux I believe this would be an issue with their repository. What's noted in:
Code:
/usr/local/cpanel/logs/packman/errors/2020-04-20_08:52:34-1
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,255
313
Houston
Hello @grabyourhosting

I'm curious why you have that package installed at all if you're not running CloudLinux?

I'd use the yum shell interface to do this:

To enter:
Code:
yum shell
Then run:
Code:
remove xz-5.2.2-1.el7.cloudlinux.1.x86_64
install xz-5.2.2-1.el7.x86_64
run
 
  • Like
Reactions: grabyourhosting

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,255
313
Houston
I have the same problem
What is the final solution to it as well?
Was there a part of the thread that you did not understand as this is solved here?
 

WebHostPro

Well-Known Member
PartnerNOC
Jul 28, 2002
1,721
27
328
LA, Costa RIca
cPanel Access Level
Root Administrator
Twitter
I got the same error trying to run EA4,

I tried this fix below, but the error remains when I try to run EA4 with PHP4.

To enter:

Code:

yum shell

Then run:

Code:
remove xz-5.2.2-1.el7.cloudlinux.1.x86_64
install xz-5.2.2-1.el7.x86_64
run

Any other ideas o how to fix this. This server might of had ClouLinux before but it has been removed now.
 

Attachments

webfyr

Member
Nov 1, 2015
5
2
3
sdsd
cPanel Access Level
Website Owner
How did you fix this? I also had CloudLinux a long time ago and uninstalled it since cPanel turned up their prices so mutch.

When trying to install php 7.4 from whm, error message is shown and the logs says this:

-> Package wordpress-cpaddon-php71.noarch 0:5.4.1-4.1 will be erased
---> Package xz-lzma-compat.x86_64 0:5.2.2-1.el7 will be installed
--> Processing Dependency: xz = 5.2.2-1.el7 for package: xz-lzma-compat-5.2.2-1.el7.x86_64
--> Finished Dependency Resolution
Error: Package: xz-lzma-compat-5.2.2-1.el7.x86_64 (base)
Requires: xz = 5.2.2-1.el7
Installed: xz-5.2.2-1.el7.cloudlinux.x86_64 (@cloudlinux-x86_64-server-7)
xz = 5.2.2-1.el7.cloudlinux
Available: xz-5.2.2-1.el7.x86_64 (base)
 

slm746

Registered
Jun 30, 2020
2
0
1
Turkey
cPanel Access Level
Root Administrator
Cloud Linux is recommended but there are many problems after uninstalling it. I'm getting the same error like you. Unfortunately, there is no solution in this regard. It's a sad situation.
 

slm746

Registered
Jun 30, 2020
2
0
1
Turkey
cPanel Access Level
Root Administrator
still same errors:

Loaded plugins: fastestmirror, universal-hooks
> Loading mirror speeds from cached hostfile
* EA4: 185.85.238.50
* cpanel-addons-production-feed: 185.85.238.50
* cpanel-plugins: 185.85.238.50
* base: mirror.bursabil.com.tr
* extras: mirror.bursabil.com.tr
* updates: mirror.provider.com.tr
> > > > > > > > > > > > > > > > > > > > > > > --> Running transaction check
---> Package ea-libzip.x86_64 0:1.6.1-3.3.3.cpanel will be installed
--> Processing Dependency: lzma for package: ea-libzip-1.6.1-3.3.3.cpanel.x86_64
---> Package ea-oniguruma.x86_64 0:6.9.5_rev1-1.1.1.cpanel will be installed
---> Package ea-oniguruma-devel.x86_64 0:6.9.5_rev1-1.1.1.cpanel will be installed
---> Package ea-php74.x86_64 0:7.4.6-1.1.2.cpanel will be installed
---> Package ea-php74-pear.noarch 0:1.10.7-3.3.3.cpanel will be installed
---> Package ea-php74-php-cli.x86_64 0:7.4.6-2.3.1.cpanel will be installed
---> Package ea-php74-php-common.x86_64 0:7.4.6-2.3.1.cpanel will be installed
---> Package ea-php74-php-curl.x86_64 0:7.4.6-2.3.1.cpanel will be installed
---> Package ea-php74-php-devel.x86_64 0:7.4.6-2.3.1.cpanel will be installed
---> Package ea-php74-php-exif.x86_64 0:7.4.6-2.3.1.cpanel will be installed
---> Package ea-php74-php-fileinfo.x86_64 0:7.4.6-2.3.1.cpanel will be installed
---> Package ea-php74-php-fpm.x86_64 0:7.4.6-2.3.1.cpanel will be installed
---> Package ea-php74-php-ftp.x86_64 0:7.4.6-2.3.1.cpanel will be installed
---> Package ea-php74-php-gd.x86_64 0:7.4.6-2.3.1.cpanel will be installed
---> Package ea-php74-php-iconv.x86_64 0:7.4.6-2.3.1.cpanel will be installed
---> Package ea-php74-php-litespeed.x86_64 0:7.4.6-2.3.1.cpanel will be installed
---> Package ea-php74-php-mbstring.x86_64 0:7.4.6-2.3.1.cpanel will be installed
---> Package ea-php74-php-mysqlnd.x86_64 0:7.4.6-2.3.1.cpanel will be installed
---> Package ea-php74-php-pdo.x86_64 0:7.4.6-2.3.1.cpanel will be installed
---> Package ea-php74-php-posix.x86_64 0:7.4.6-2.3.1.cpanel will be installed
---> Package ea-php74-php-xml.x86_64 0:7.4.6-2.3.1.cpanel will be installed
---> Package ea-php74-php-zip.x86_64 0:7.4.6-2.3.1.cpanel will be installed
---> Package ea-php74-runtime.x86_64 0:7.4.6-1.1.2.cpanel will be installed
--> Running transaction check
---> Package xz-lzma-compat.x86_64 0:5.2.2-1.el7 will be installed
--> Processing Dependency: xz = 5.2.2-1.el7 for package: xz-lzma-compat-5.2.2-1.el7.x86_64
--> Finished Dependency Resolution
Error: Package: xz-lzma-compat-5.2.2-1.el7.x86_64 (base)
Requires: xz = 5.2.2-1.el7
Installed: xz-5.2.2-1.el7.cloudlinux.1.x86_64 (@cloudlinux-x86_64-server-7)
xz = 5.2.2-1.el7.cloudlinux.1
Available: xz-5.2.2-1.el7.x86_64 (base)
xz = 5.2.2-1.el7
> Leaving Shell
 
Last edited by a moderator:

panamaservercom

Registered
Oct 27, 2006
2
1
153
This is what I did (make sure you have KVM access to the console, probably you will not be able to ssh)
Make a copy of
liblzma.so.5
and
liblzma.so.5.2.2
then find the rpm
Code:
rpm -qa | grep "xz-libs-5.2"
and remove it with
Code:
rpm -e xz-libs-5.2.2-1.el7.cloudlinux.1.x86_64 --nodeps
now restore the copy of the backuped files to /usr/lib64

NOW install the package
Code:
yum install xz-5.2.2-1.el7.x86_64
 

Radhi

Member
Feb 5, 2019
17
1
3
Tunisie
cPanel Access Level
Root Administrator
This is what I did (make sure you have KVM access to the console, probably you will not be able to ssh)
Make a copy of
liblzma.so.5
and
liblzma.so.5.2.2
then find the rpm
Code:
rpm -qa | grep "xz-libs-5.2"
and remove it with
Code:
rpm -e xz-libs-5.2.2-1.el7.cloudlinux.1.x86_64 --nodeps
now restore the copy of the backuped files to /usr/lib64

NOW install the package
Code:
yum install xz-5.2.2-1.el7.x86_64
Caused the server to stop !!!
What is the solution ?
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,255
313
Houston
Can you please open a ticket using the link in my signature? Once open please reply with the Ticket ID here so that we can update this thread with the resolution once the ticket is resolved.


Thanks!
 
  • Love
Reactions: Radhi